Jump to content
43oh

Error messages when running the standard Blink example


Recommended Posts

Can some explain what the following error messages are all about and why I am getting them when trying to compile the standard Blink example please? Plus, how to fix this.

 

Thanks.





C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\atof.c: In function 'atof':

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\atof.c:71:9: warning: floating constant exceeds range of 'double' [-Woverflow]

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\wiring_analog.c:65:0: warning: "DEFAULT_READ_RESOLUTION" redefined [enabled by default]

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\wiring_analog.c:35:0: note: this is the location of the previous definition

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\avr\dtostrf.c: In function 'dtostrf':

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\avr\dtostrf.c:36:3: warning: incompatible implicit declaration of built-in function 'sprintf' [enabled by default]

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\Stream.cpp: In member function 'bool Stream::find(char*)':

C:\Users\Mike\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\Stream.cpp:78:30: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings]
Link to post
Share on other sites

Can you show us your code?

It appears that the glue avr libs are not being found, while they aren't required for your blink they are compiled anyway.

 

Sounds like a bad installation. You might try to re-install. I certainly did not have this issue when I just installed Energia 18 on my Mac. I did need to install the old JDK, though. I can compile blink and bare-minimum no problem. Haven't tried flashing though. 8^)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...