Jump to content

can't find DSLite?

Recommended Posts

java.io.IOException: Cannot run program "/VOLUMES/gizmonics/work/msp430/energia-1.6.10E18/hardware/tools/DSLite/DebugServer/bin/DSLite": error=2, No such file or directory
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
    at java.lang.Runtime.exec(Runtime.java:620)
    at java.lang.Runtime.exec(Runtime.java:485)
    at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:11)
    at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:130)
    at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:209)
    at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
    at processing.app.Sketch.upload(Sketch.java:1187)
    at processing.app.Sketch.exportApplet(Sketch.java:1160)
    at processing.app.Sketch.exportApplet(Sketch.java:1132)
    at processing.app.Editor$DefaultExportHandler.run(Editor.java:2410)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: error=2, No such file or directory
    at java.lang.UNIXProcess.forkAndExec(Native Method)
    at java.lang.UNIXProcess.<init>(UNIXProcess.java:248)
    at java.lang.ProcessImpl.start(ProcessImpl.java:134)
    at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
    ... 11 more
An error occurred while uploading the sketch

Heh.  I expect this is a known/old problem but I failed when trying to google it.


Trying to run blink.  energia ver 1.6.10e18


I get the above error when I try to upload.  That file is there.

mode 755, user,group=root and running energia as root.


uname -a

Linux ws.jgscrater.com 3.10.0-327.36.3.el7.x86_64 #1 SMP Mon Oct 24 16:09:20 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


My board was selected correctly by default.  MSP420F5529LP, I've tried all three ports, ttyS0, ttyACM[01].

No joy.

The sketch won't upload.  (I get compilation warnings, which is kinda sad, but it seems to compile.)


I did not find a serial port driver on the web page, so I guess I don't need it?

or is that the issue?




Link to post
Share on other sites

yup.  that was it.


yum -y install glibc.i686

modified the error it got, it complained about a specific library.

locate libgcc_s.so.1
rpm -q --whatprovides /usr/lib64/libgcc_s.so.1
yum -y install libgcc.i686


and now it works.  Thanks, Robert.


FWIW it was using ttyACM0 as the [serial] port.



Link to post
Share on other sites
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...