Jump to content

Search the Community

Showing results for tags 'n00b'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 1 result

  1. Hey all, I'm relatively new to all this and I have been trying to get a temperature sensor to work with the launchpad. As in my previous posts I was trying for the DS18b20. I have the port of the code project on the back burner because there is a hell of a lot I need to learn to be able to port that over. So just to get something off the ground I have been trying to use the LM35 to read some temps. Here is the code I'm running float tempC; float tempF; void setup() { Serial.begin(9600); } void loop() { tempC = analogRead(6); //read the value from the sensor hooked up to pin 6 tempC = (3.3 * tempC * 100.0)/1024.0; //convert the analog data to temperature (Assuming 10bit ADC and 3.3v ref voltage I suspect this is where I'm screwing up) tempF = ((9.0*tempC)/5.0)+32.0; Serial.println(tempC); Serial.println(""); Serial.println(tempF); Serial.println(""); delay(1000); } The issue is that It is showing very high values. Like the order of 178 c? I also tried chaning the tempC calculation to tempC = (tempC*100.0)/1024.0 It gets closer but still not quite. (I'm monitoring through the serial monitor and I have not made any changes to the jumper position to my 1.4 board) Any and all help is appreciated. Regards, Alex
×
×
  • Create New...