Jump to content

Search the Community

Showing results for tags 'msp30fr2433'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 1 result

  1. Hello! I am currently moving a project from MSP430G2553 MCU to newer MSPFR2433. I have MSP-EXP430FR2433 board and Energia-1.6.10E18 IDE Software. From the beginning I saw very strange thing - big difference in DELAY and SLEEP intervals, but only on MSP-EXP430FR2433 board. For example, even simplest elementary code for BLINK run on MSP-EXP430FR2433: #define LED RED_LED void setup() { pinMode(LED, OUTPUT); } void loop() { digitalWrite(LED, HIGH); // turn the LED on (HIGH is the voltage level) sleep(4000); // wait for 4 seconds digitalWrite(LED, LOW); // turn the LED off by making the voltage LOW delay(1000); // wait for a second } On this board interval for ON (sleep command) visually is almost equal to OFF (delay command) interval (!). So SLEEP command is running about 4 times faster, than DELAY. While same code on MSP-EXP430G2 with MSP430G2553 and MSP-EXP430FR5969 boards is working fine. What is the reason ? It looks, like Energia library for MSP430FR2433 has some issues...Is it possible to fix it ? I understand, that MSP430G2xxx and MSP430FR2xxx have differences, but some basic functions should be running the same...isn't it ?
×
×
  • Create New...