Jump to content

Search the Community

Showing results for tags 'compile error'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 3 results

  1. I have a tm4c129 board. I have installed updates form the board manager for the TIVA C so now I can upload the default examples form Energia. 1. Problem arises when I try to add custom libraries. What is the correct method to add a library? 2. I can find only MSP430 folder at location E:\..\energia-1.6.10E18\hardware\energia , I suppose all boards installed should show up in the hardware library. 3. I have included the library which I am trying to compile Error: WARNING: Category '' in library SD is not valid. Setting to 'Uncategorized' Missing 'maintainer' from library in C:\Users\Admin\Documents\Energia\libraries\SD Error compiling for board LaunchPad (Tiva C) w/ tm4c129 (120MHz). sd-logger-source.zip
  2. With Energia 1.6.10E18 installed on my MacBook Pro with MAC OS Sierra 10.12.1 and Sketch 'Blink' selected, the following compiler error occurs; No Java runtime present, requesting install. exit status 1 Error compiling board LaunchPad w/ msp432 EMT (48MHz) Installing JAVA SDK has no effect. Is it a possible driver error? Energia works fine under Windows 10. Why do I need the java sdk. Regards Jan
  3. Hi Everyone! I am trying to use the AIR430 Booster pack, MSP430G2452 uC and programming it with Energia 0101E0012 on a Mac. If I simply try to compile the examples given in energia (for example, WirelessMonitorSensor), I get a compile error as follows: /Applications/Energia.app/Contents/Resources/Java/hardware/msp430/libraries/AIR430BoostUSAFCC/utility/Platform.cpp: In function 'void A110x2500SpiRead(unsigned char, unsigned char*, unsigned char)': /Applications/Energia.app/Contents/Resources/Java/hardware/msp430/libraries/AIR430BoostUSAFCC/utility/Platform.cpp:84:28: error: 'SPIMISO_SET_MODE' was not declared in this scope /Applications/Energia.app/Contents/Resources/Java/hardware/msp430/libraries/AIR430BoostUSAFCC/utility/Platform.cpp: In function 'void A110x2500SpiWrite(unsigned char, const unsigned char*, unsigned char)': /Applications/Energia.app/Contents/Resources/Java/hardware/msp430/libraries/AIR430BoostUSAFCC/utility/Platform.cpp:114:28: error: 'SPIMISO_SET_MODE' was not declared in this scope If I write my own program that just loads the AIR430BoosFCC.h and SPI.h headers (using the Sketch/Import Library.../AIRBoostUSAFCC), I get a different error: In file included from /Applications/Energia.app/Contents/Resources/Java/hardware/msp430/libraries/AIR430BoostUSAFCC/AIR430BoostFCC.h:29:0, from test.ino:1: /Applications/Energia.app/Contents/Resources/Java/hardware/msp430/libraries/AIR430BoostUSAFCC/utility/A110x2500Radio.h:109:10: error: 'boolean' does not name a type The code to generate this error is: #include <AIR430BoostFCC.h> #include <SPI.h> void setup() { pinMode(RED_LED,INPUT); Serial.begin(9600); } void loop() { Serial.println("Hello World"); delay(1000); } Any ideas how to get this working? Thanks!
×