Jump to content

Search the Community

Showing results for tags 'Serial Port'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 5 results

  1. Hi there Currently I am using the Serial1 pin to I2C for the LCD. so, I can't use the Serial1 in the CC3200EMT (multitasking).When I see the source code of Board_init.c, there is Board_openUART() function which seems to initiate the PIN. I need to change the pin 3 and 4 to 7 and 8. but even I changed the source code, it wasn't able to apply them. It seems the complier linking the binaries directly. Did you already announce the procedure how to recreate libraries? or Can you suggest other ways? //MAP_PinTypeUART(PIN_03, PIN_MODE_7); MAP_PinTypeUART(PIN_07, PIN_MODE_5); //MAP_PinTypeUART(PIN_04, PIN_MODE_7); MAP_PinTypeUART(PIN_08, PIN_MODE_5);
  2. Can anyone help on this issue please ? On Ubuntu 14.04 64 bit, I am unable to get the serial port to work with Energia 16 and MSP430G2. I have exactly followed the install instructions for Linux : http://energia.nu/guide/guide_linux/ including setting udev rules. The MSP430G2 can be programmed ok however any attempt to open the serial port monitor causes Energia to hang up/freeze. FYI, I also have an Arduino board with the latest Arduino IDE which has no problems with serial output on this same evironment (and setting that up was a breeze). It's a pity that getting Energia to work on Linux is so hard. I have seen previous postings on this issue suggest a custom build of the cdc_acm driver; is that really necessary given Arduino works fine ? Below is the output of dmesg: [42439.494174] usb 1-1.2: new full-speed USB device number 4 using ehci-pci [42439.609479] usb 1-1.2: New USB device found, idVendor=0451, idProduct=f432 [42439.609484] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [42439.609487] usb 1-1.2: Product: Texas Instruments MSP-FET430UIF [42439.609489] usb 1-1.2: Manufacturer: Texas Instruments [42439.609491] usb 1-1.2: SerialNumber: E7FF4D53F4181B50 [42449.663054] hid-generic 0003:0451:F432.0004: usb_submit_urb(ctrl) failed: -1 [42449.663078] hid-generic 0003:0451:F432.0004: timeout initializing reports [42449.663362] hid-generic 0003:0451:F432.0004: hiddev0,hidraw3: USB HID v1.01 Device [Texas Instruments Texas Instruments MSP-FET430UIF] on usb-0000:00:1a.0-1.2/input1 [42449.758556] cdc_acm 1-1.2:1.0: This device cannot do calls on its own. It is not a modem. [42449.758564] cdc_acm 1-1.2:1.0: No union descriptor, testing for castrated device [42449.758591] cdc_acm 1-1.2:1.0: ttyACM0: USB ACM device [42449.760730] usbcore: registered new interface driver cdc_acm [42449.760735] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
  3. I am trying to upload a sketch but am unable to, as there is no way to set the port, as the Serial Port option is greyed out in the Tools menu. I am running OSX 10.9.5, my device (CC3200 LaunchPad) is being recognised on the USB bus (see details below). USB <-> JTAG/SWD: Product ID: 0xc32a Vendor ID: 0x0451 (Texas Instruments) Version: 5.00 Serial Number: cc3200 Speed: Up to 12 Mb/sec Manufacturer: FTDI Location ID: 0xfa130000 / 6 Current Available (mA): 500 Current Required (mA): 500 I have tried installing the VCP drivers from FTDI. I am using the latest version of Energia. Any other suggestions?
  4. hello i am using TM4c123GXL. i am facing problem to Read the string on the Serial Port. Please give me idea ..how i can get my goal.... the function Serial.Read() return the integer .... i want to get the string ...how is this possible Thank you...
  5. QUESTION: Any pointers as to why the Serial Port is grayed out on 64-bit Centos 6? In the next post, is my detailed installation log (with errors) - but here is a quick summary: I determined that I'm on 64-bit X86 Centos 6. I checked to see if the libusb drivers are installed. I checked to see what version of Java is installed. I checked to see how Java is configured. I downloaded the Energia Linux binary tarball (energia-0101E0009-linux.tgz) I untarred the Energia tarball to create an energia-0101E0009 directory. I ran the energia application. I set the board to msp430g2553 (16MHz) I failed at selecting the serial port because the selection was grayed out. I ran the default "Blink" procedure, which caused the board LEDs to blink. I modified the "Blink" procedure, and tested that it was working. I tried to open the Energia Serial Monitor - but failed. Googling for how to solve this problem, I added a udev file & rebooted. Googling further, I added user1 to the various groups and rebooted. Googling further, I obtained and compiled librxtx-master. I installed the EPEL rxtx using "sudo yum install rxtx". Yet, the serial port is still grayed out! Q: How do I diagnose WHY the MSP430 serial port is grayed out? Note: Searching this forum came up with this - but it doesn't seem to apply as it's on Windows: - serial port grayed out in IDE ver E0009
×