Jump to content
43oh

Search the Community

Showing results for tags 'STELLARIS'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

  1. Hello it looks like I bumped into an issue which might be of interest, and needs to be investigated. I have a string of I2C devices running on i2C Bus on Arduino Mega (MCP4531 potti, LM-75 Temp sensor, 2x PCF 8575 I/Expanders). All running smooth. The next step I had to exchange the Mega with Tiva Stellaris Launchpad (EK-TM4C129E ), which I did, I havent changed anything on the setup besides the Mega2560 with Launchpad. While running the i2C scanner I saw, full Bus of devives. Furthermore I changed the i2C modules (0,1,2 with setModule()) nothing changed, same issue persists. Pull-ups var
  2. I know that Stellaris is dead already. The only reason I still own an Stellaris EK because my friend gave it to me......for free and brand new! I just want to fade an LED, that's all ! And btw, are there any good tutorials for Stellaris MCUs? Thanks alot, to anybody that is willing to help me.
  3. Is there a way to use the SoftwareSerial library on the Stellaris Launchpad TM4C123GXL board? I am trying to connect a Sparkfun serial enabled LCD screen to the board but the SoftwareSerial library is only compatible with 20, 16, and 8 MHz processors, and the TM4C123GXL is an 80 MHz chip. How can I use this LCD screen with the Stellaris Launchpad over a UART connection? Do I need to use SoftwareSerial or can I do without it? I am programming in Energia 0101E0017 on Windows 7 64 bit. Any help is greatly appreciated, thanks!
  4. Hi all, Based on reading the 430 forum and Github Energia/Pervasive issues lists, it appears that someone has successfully setup and tested the EPD Booster with Stellaris (LM4F120). I have acquired an older 2.7 Pervasive Display (which appears to require PWM) and booster board (version 1.5). Using Energia, I can successfully directly connect using my MSP430G2553 so I know the board/display is ok. I want to connect the EPD to my Stellaris -- since there is a PWM requirement, I believe I will need to use the wireharness (instead of direct connecting) and set up a macro for PWM to co
  5. Buy: The 43oh Store or Rob's Tindie Store. The newest version of the Ethernet BoosterPack is based on the newest chip from WIZnet, W5500. P1.5 - SCLK P1.6 - MISO P1.7 - MOSI P2.3 - /CS P2.4 - /INT P2.5 - /RST Configuration jumpers are on the bottom, PMODE1-PMODE3, LINK LED, and ACT LED. LED jumpers control which LEDs are used, on board or socket. Available on Tindie.
  6. Hello All, Is there any sample program for using the CAN with Stellaris/Tiva-C with energia IDE ? I could see D:\energia-0101E0017\hardware\lm4f\cores\lm4f\driverlib can.c and can.h files. How to include this .h files and have a program which transmit some data Thanks for your support Dino
  7. The other day I recorded myself unboxing this kit I got for a training I am taking, and uploaded it to my youtube channel. In case anyone would like to watch, here is the link: The kit is quite nice, featuring a Cortex M4 processor and a lot of goodies on board (OLED display, accelerometer, temperature sensor, current sensor, etc.). The other nice thing about it is the demo application it comes with, that is basically a data logger that can record all of the things mentioned above (XYZ channels of the accelerometer, current, internal and external temperature) PLUS 4 channels that ar
  8. I'm back with another issue with my Stellaris LaunchPad. I have a short Energia sketch which uses the SPI library to write to the serial LCD on the ADS1118 Booster Pack. The sketch works as expected. The problem is that it somehow leaves the Stellaris in a state in which it cannot be flashed successfully by lm4flash. I have to connect the Stellaris LaunchPad, flash it (works fine the first time), disconnect the USB cable, reconnect, flash again, and so on. The symptoms seem to match what a TI employee posted on the E2E Community back in 2011, where changing the function of PORTC pins
  9. I'm trying to combine some Energia libraries for the ADS1118 ADC and the SPI serial LCD included on the ADS1118 Booster Pack. Using simple digitalWrite() calls, I'm able to write to the LCD, but I'm trying to switch to using the Energia SPI library. The documentation for SPI.begin() says I can set a slave select pin; however, the compiler rejects a call to SPI.begin(LCD_CS) because there is no SPI.begin(int slaveSelectPin) defined. With the following code, the default pin 2 slave select appears to be used, because it happens to be connected to the buzzer on the ADS1118 Booster Pack, an
  10. I've just noticed that the ADS1118 Booster Pack's J4 connector has long pins extending below the PCB, and one of them can contact the top of the VDD jumper. It looks like a possible short could occur between these two points. For now, I've stuck a business card in between to keep them from touching. Do the Booster Pack design guidelines include any bottom-side exclusion areas for downward-extending pins?
  11. Camera Flash Timer and Measurement Tool This project is an amalgamation of many other ideas and projects by other brilliant folks plus my own twist on things. Hopefully I have given credit to all those whose work I have expanded upon and incorporated. Apart from libraries, I have written the majority of the code from scratch implementing what I have learnt from this and other forums. Still quite a few bugs and it is probably 80 - 90% complete. I did get some perspex laser cut for it, but I didnt have the right software for it and borked the file conversion and received cute
  12. main.cHallo How to implement an CAN BUS COMMUNICATION between CAN1 and CAN2 on Stellaris microcontroller.I need to transmit and receive the messages between two ifferent CANs. Herwith I am attaching my main function Thx in advance
  13. Hello, fellow launchpad enthusiasts! I am having problems reading temperature sensor values on my stellaris launchpad (LM4F120H5QR). The values returned by analogRead(TEMPSENSOR) are erratic and do not correlate with actual temperature. I use ubuntu 14.04 and energia 0101E0014. I tried following code: uint32_t TempRead = 0; float TempC = 0; void setup() { Serial.begin(9600); analogRead(TEMPSENSOR); } void loop() { TempRead = analogRead(TEMPSENSOR); TempC = (float)(1475 - ((2475*TempRead)/4096))/10; Serial.print("ADC value: "); Serial.println(TempRead); Serial.print("Temperature in C: "); Se
  14. Hello, I managed to port the MPU9150Lib at https://github.com/richards-tech/MPU9150Lib to Energia. I had to make few changes in defines in dmp code, and the provided CalLib, and now it compiles for MSP430G2553, MSP430F5xx, Stellaris Launchpad, and the Tiva-C series (TM4C123) launchpad. CalLib writes to either flash or eeprom depending on architecture. It has failed for MSP430G2553, due to code size. It compiles for MSP430F5xx although I dont have a board yet to test. I have not tested the stellaris launchpad but I suspect it works, it does WORK on the Tiva-C series launchpad. H
  15. Hello to everyone, I am new to this forum after playing around happily with TI MSP 430 and also a bit with Stellaris Board. Mostly with Getting Started with the MSP430 Launchpad from Fernandez/Dang as my reference. So far so good anything did work well but I am just wondering if someone thought about porting Energia in a way that it would run on a Raspberry Pi Bramble( clust er of RPi) And by doing that also being able to run DEV on RPi only connected to USB hubs for power. The HDMI monitor excluded. Thanks in advance for any feedback Regards Gottfried
  16. WS2812 driver for Tiva is available here
  17. Hi friends. I began to a project at school which is about connecting ARMs. I have two stellaris launchpads and I'm trying to connect them over an nRF24l01. I use keil platform. Project is about sensors when first module sees an obstacle it will transmit it to the other Launchpad through RF. However I couldnt find any rf libraries. I dont know what to do and I really need your advice. Hope you can help me. Have a good day:)
  18. Hello friends, I just now got the stellaris launchpad to have hands on experience with ARM architecture. I have installed the driverlib and I can blink the LEDs through the APIs. The driverlib makes it easy to program the stellaris but with these APIs we cannot understand how the registers are programmed even when we look at the definitions of the APIs. These APIs are specific to a particular family. Thus, I wont be able to understand the ARM architecture. I request you all to please guide me regarding this problem. It would be great if I could find online training material
  19. Hi all, I'm working with Stellaris Stepper motor RDK from TI- Luminary Micro. I'm using USB Serial Interface for interfacing the Device with my Application developed using C#. Currently i'm stuck with sending the control commands from my Application. I can able to start & stop the Stepper motor by sending the following commands. But i'd like to set the Target Steps/sec. I cant understand how to form a command control with requred Target Steps. So any Help regarding this is appreciated. code: To startMotor: byte[] StartMotorRequest = new byte[] {0xff,0x07,0x13,0x14,0x00,0xcf,0xff, 0
  20. Hello, I am trying to analogWrite on the RGB leds, with energia. Appearently this can be done, as the original came with a demo program of this sort. Also the documentation of energia, the hardware documentation states that this RGB led pins are indeed analogWritable (purple) But when i try to use analogWrite - it will either take a 0 or 1 position, and no PWM will be outputted. It works as expected with digital output. Any ideas? Best Regards, -C.B.
  21. Hi together, I am trying to get UART working on my Stellaris Launchpad (LM4F120H5QR) using the onboard PIN headers (UART1/2) instead of the USB cable (UART0). This is how my code looks like (based on uart_echo from StellarisWare). I am using a FOCA tiny break-out board (integrating a FT232 IC) to receive the data on my terminal software. Currently, I am trying to set up UART1 and GPIOB (PB0 / PB1). However, I do not receive anything on my temrinal software, while using the standard uart_echo code for UART1 it works properly. Can somebody tell me what I am missing? If this works, I am gett
  22. Hello everyone, I recently purchased a stellaris for a school and I am having trouble finding a code for the space invaders game that I can play on a 16x2 LCD. can anyone help me?
  23. Hi all, I'm testing system clock frequency. 1) change board.txt (energia_dir)\hardware\lm4f\boards.txt ###################################################### # Tiva C TM4C1233H6PM 80MHz # with launchpad ###################################################### lpTivaC-1.name=Tiva C w/ TM4C1233H6PM (80MHz) lpTivaC-1.upload.maximum_size=262144 lpTivaC-1.build.mcu=cortex-m4 lpTivaC-1.build.f_cpu=80000000L lpTivaC-1.build.core=lm4f lpTivaC-1.build.variant=stellarpad lpTivaC-1.ldscript=lm4fcpp.ld ###################################################### # Tiva C TM4C1233H6PM 25MHz # wi
  24. Please refer to LaunchPads and BoosterPacks Pins Maps for the updated and maintained pins maps. Thank you! ---- Please find the map for the pins on the StellarPad (aka. LaunchPad Stellaris LM4F). Front Rear Originals are in Energia wiki at https://github.com/e...a/wiki/Hardware
  25. I'm working with the stellaris launchpad on energia (version 1010E0009). I need to use two hardware serial ports, and I'm finding that it does not work. I've made a VERY simple sketch that demonstrates this behavior: When every port but one is commented out, the program runs fine. The light blinks, serial data moves, etc. When more than one is created, the first round of data goes out to each port, but it crashes somewhere. Often, the first few characters of the second loop begin printing on port zero. This doesn't happen when the delay(100) is in there. I'm not sure if this is
×
×
  • Create New...