Jump to content

Search the Community

Showing results for tags '1.6.10e18'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 4 results

  1. Part Number: TM4C123GH6PM Tool/software: Energia 1.6.10E18 LaunchPad board name and version: TIVA TM4C123GH6PM IDE version: Energia 1.6.10E18 or CCS7.0 OS name and version: Windows7 While uploading a simple LED Blink code on Tiva TM4C123GH6PMevaluation board, I get an error "Failed: Unable to find an entry in the TPI ini file for "TMS470REX"", failing to upload to the device. Please help!
  2. This snippet does not give the expected results (and I know I should be checking the return code of sscanf()...), the string contains text like "60.0" when asked for a frequency. float request = 50.0f; sscanf(string, "%f", &request); // having trouble since energia version 1.6.10E18 with floats... Under version energia_0101E0015, request becomes whatever float value is in the string (say 60.0), but under energia_1.6.10E18 request remains at the initialized value. Same with this snippet: sprintf(timecodeBuffer, "f# %04d ft %.03f %02d:%02d:%02d.%02d.%03d Squid_%c_[%02d:%02d:%02d.%02d] delta:%.03f \n", frameNumber, frameTime, computeHours, computeMinutes, computeSeconds, computeFrames, computeMilliSecs & 0x0000ffff, live, timecodeHours, timecodeMinutes, timecodeSeconds, timecodeFrames, timeDiff); Under version energia_0101E0015 it prints everything fine, but under energia_1.6.10E18 the floats are printed as a blank space. Computing with float values is not a problem. My include section looks like this: #include <Ethernet.h> #include <EthernetUdp.h> #include "inc/hw_ints.h" // our TM4C1294NCPDT is in the SnowFlake interrupt class #include "inc/hw_memmap.h" #include "driverlib/pin_map.h" #include "driverlib/sysctl.h" #include "driverlib/pwm.h" #include <string.h> #include <stdio.h> #include "Wire.h" // using the I2C bus for display My setup: Tiva-C connected EK-TM4C1294XL, 120 MHz tmc129 I tried upgrading to version 1.6.10E18. I really like the new board chooser and it downloaded the appropriate drivers and build tool chain. I think however the problem originated with the different tool chain. My OS is Kubuntu 18.04 LTS (with 32 bit libraries licb6:i386 for the lm4f tool chain to work under 64-bit ubuntu)
  3. Does not upload blink code "an error occurred while uploading the sketch" see below I can see it's on com14 when I plug it in. thanks Randy <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] C:\Users\Randy\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\atof.c: In function 'atof': C:\Users\Randy\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\atof.c:71:9: warning: floating constant exceeds range of 'double' [-Woverflow] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] C:\Users\Randy\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\avr\dtostrf.c: In function 'dtostrf': C:\Users\Randy\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\avr\dtostrf.c:36:3: warning: incompatible implicit declaration of built-in function 'sprintf' [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] C:\Users\Randy\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\Stream.cpp: In member function 'bool Stream::find(char*)': C:\Users\Randy\Downloads\energia-1.6.10E18-windows\energia-1.6.10E18\hardware\energia\msp430\cores\msp430\Stream.cpp:78:30: warning: deprecated conversion from string constant to 'char*' [-Wwrite-strings] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] <command-line>:0:12: warning: missing whitespace after the macro name [enabled by default] Sketch uses 760 bytes (4%) of program storage space. Maximum is 16,384 bytes. Global variables use 20 bytes (3%) of dynamic memory, leaving 492 bytes for local variables. Maximum is 512 bytes. MSPDebug version 0.22 - debugging tool for MSP430 MCUs Copyright (C) 2009-2013 Daniel Beer <dlbeer@gmail.com> This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. usbutil: unable to find a device matching 0451:f432 An error occurred while uploading the sketch
  4. Hi all, i tried to compile my old sketch for my CC3200 with the new Energia 1.6.10E18. After installing the board and importing the libraries I get for all functions in the imported libraries a "not declared in this scope" error during compilation. The sketch uses four external libraries and for all of them I have the same problem. The same sketch was compiled without errors within Energia 15. I think there is something wrong with the library import. Can somebody help me. Regards Ingo
×
×
  • Create New...