Jump to content
43oh

Search the Community

Showing results for tags 'uart'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

  1. Dear all, I am an AVR atmega8 refugee, and msp's clocking scheme seems pretty feature rich (not to mention complex!). I am using MSP430G2 launchpad (g2553). This program uses TImerA, and hardware UART with interrupt. It runs at 1Mhz from DCO. And the peripherals take clock from SMCLK. The UART just echos whatever it receives. The timer generate 500ms delay, and toggles the red and green leds on board http://pastebin.com/yApLyFbu The problem is, I can only have one peripheral at a time using the SMCLK. If I have the above code running exactly as it is, the timer will correctly r
  2. Hello, I'm currently working on a project involving G2553 MCU and Sparkfun Bluesmirf Silver BT module. I'm programming my MCU using the MSP430 Launchpad as a programmer and Energia IDE. I'm trying to configure the Bluetooth module using the firmware that I upload to the MCU. I connected the MCU's hardware UART pins to the Bluesmirf pins. Pin 1.1 (HW RX) to the module's RX and vice versa. I supply the same voltage to the MCU and the module (supply voltage connected to the breadboard from the Launchpad itself, multimeter shows values at around 3.5V). Bluesmirf's datasheet says the Vcc shoul
  3. .. finally made the switch and flashed OpenWrt to a TP-Link WR703N router, added a 16G memory flash stick, and connected to my first F5529 LaunchPad. Here is a picture of the setup. The version of OpenWrt is 12.09. To connect with the MSP Launchpad, need to install the acm driver by opkg install kmod-usb-acm And also installed "screen" for serial client by opkg install screen Apart from the missing bridge library that come with the Yun, i'm quite satisfied with this setup, especailly the tiny form factor of the whole package. The LaunchPad seems to enjoy running with her new I
  4. Hello everyone. I am a beginner with the MSP430 and need help. I am using MSP430G2452 launchpad and another MSP430G2452 which is on a breadboard. I really just need help getting started. I hooked UART between the two and supplied both with voltages, is this the correct way to set it up or am I missing something? How is the J3 configuration supposed to be? Also, I do not know where to go with the coding. How do I program a simple LED on the breadboard from the second MSP430? Thank you so much in advance!!
  5. Hi everyone, I make a GUI and send a string contains 4 bits, The first time i send ( E.g "1234") I have received "1234" But the 2nd i have received "2341", so on the third i have received "3412" So data was shifted, I have debugged and detected in my received string have a char with value ="10" (LF), Although i havent send it. How can i fix my error? Plz give a solution, thank in advance.
  6. Hi! I'm haivng an unusual problem with UART0 on Tiva C Launchpad. I'm also using Code Composer Studio 5.5. What I'm trying to do right now is to do A/D conversion on the microcontroller and send data to a PC via the serial port. Basically, my program right now sets up peripherals and then goes into a while(1) loop where it samples data from the ADC and then sends them via UART. I'm not using interrupts at this point at all. My code looks like this: unsigned const int BaudRate=5000000;//I've tried with lower data rates, but they're not the problem here. int main(void) { ROM_SysC
  7. I have beaglebone black install ubuntu 13.04, i wanna send a data to LM4F120XL and receive data from it, have anyone used to do it? plz give a suggest or a tutorial ?
  8. I'm developping some codes with Energia or TI CCS for the TI LaunchPad MSP-EXP430G2, v1.4 and v1.5, with G2553 and G2452 chips. I organize DIY workshops. I'm playing with various computers, I enumarate them: 1x W7Pro32, 1x W7Starter, 1x W8.1x64, 1x TP-Link TL-MR3020+OpenWrt, 1x TP-Link WR710N+OpenWrt. Nothing is going right with serial, only my old W7Pro32 can read/write thru the USB serial ! Even my 2 OpenWrt TP-Link can't communicate ! If I play with some Arduino in place of TI LaunchPad, all USB serial is working fine (except the known reset problem of Arduino USB serial). Y
  9. Hi I'm new with energia and I'm trying to use the Hardware serial communication with a Lauchpad Rev. 1.4 so I connect the RX end TX jumpers in cross but it doesn't work...Can anyone help me? this is the simple code I use: void setup() { Serial.begin(9600); } void loop() { Serial.println("Hello !!!"); delay(500); } I try to use also the software serial communication for but it doesn't work
  10. Hi there, I have a Stellaris launchpad LM4F120, and i'm trying to get an assembly language UART example to work. I used Valvano's example project for keil found here: http://users.ece.utexas.edu/~valvano/arm/ file name: UART2_4F120asm.zip This example uses UART0, and it works fine. I can also adapt this code to use UART1 and UART2 with no problems, by simply appropriately changing macro values as can be seen in this register definition file: http://users.ece.utexas.edu/~valvano/arm/lm4f120.s However, I wish to use UART7, and the trouble lies in that there is no definition for
  11. Hi together, I am trying to get UART working on my Stellaris Launchpad (LM4F120H5QR) using the onboard PIN headers (UART1/2) instead of the USB cable (UART0). This is how my code looks like (based on uart_echo from StellarisWare). I am using a FOCA tiny break-out board (integrating a FT232 IC) to receive the data on my terminal software. Currently, I am trying to set up UART1 and GPIOB (PB0 / PB1). However, I do not receive anything on my temrinal software, while using the standard uart_echo code for UART1 it works properly. Can somebody tell me what I am missing? If this works, I am gett
  12. Hello, I'm very new to uCs, so please bear with me and my inevitable incorrect use of terminology (corrections appreciated!). I've been doing a lot of reading, and wrote a little program to TX/RX characters from PuTTY over UART. I think maybe I have some inappropriate UART settings, because the very first TX always prints garbage, even on reset. Would someone mind please taking a look for me? I'll just post the UART setup routine, and the print routine unless posting the whole code would be more useful. I've also attached a PuTTY screenshot as an example of the "garbage" I mean, a
  13. For the sake of thanking this community for solving my issue ,I would like to write a post on how I overcame this issue thanks to community member Stepman . I use the TIva C Series Launchpad . For a program employing UART if you are getting errors like Description Resource Path Location Type unresolved symbol UARTprintf, first referenced in ./main.obj Description Resource Path Location Type unresolved symbol UARTStdioConfig, first referenced in ./main.obj Then you have not copied or linked your uartstdio.c file from utils/uartstdio.c If you are getting errors like Description
  14. This DCO calibrator starts with me not having a crystal on my board, and stealing rick's idea about using the UART to calibrate the DCO. It works without the UART peripheral or capture compare. The host sends the 'U' character and the micro responds with what adjustment it made, or that it calibrated to the target frequency. When the micro is calibrated, it sends the calibration constant values to the host, which prints them for the user. I used an oscope to verify the frequency on the P1.4's SMCLK output. Code is here: https://github.com/analog10/UART_DCO_Calibrator rick's original c
  15. hi everyone, i'm sampling from single channel ADC and send the data over UART. now i need to two channel simultaneously and send the data. for one channel my code is below: ----------------------------------------------- ADC10CTL1 = INCH_5 + ADC10DIV_3 ; // Channel 5, ADC10CLK/4 ADC10CTL0 = SREF_0 + ADC10SHT_3 + ADC10ON + ADC10IE; //Vcc & Vss as reference ADC10AE0 |= BIT5; ADC10CTL0 |= ENC + ADC10SC; // Sampling and conversion start, single measure! while(1) { if(!((P1IN & BUTTON)==BUTTON)) { ADC10CTL0 |= ENC +
  16. Hi there, I'm pretty new to the world of ARM microprocessors ,having recently started with the Stellaris launchpad LM4F120. I wish to send data from the microcontroller over a serial interface to be read with a terminal program such as Putty. The trouble is, I have not been able to find any resources on the internet that would help me initialize and use UART in the assembly language. Any help in the form of links to simple tutorials or example code snippets would be greatly appreciated. Thanks.
  17. hi everyone, thanks to Nate Zimmer Uart example, i could achieve to send string over uart. But i have send ACD values to UART. ADC has 10 bit output. How could i transmit the ADC data? Can i send directly? let say ---------------------------------- value=ADC10MEM; UART_TX(unsigned int value ?); // void UART_TX(int * value) // Define a function which accepts a character pointer to an array { unsigned int i=0; while(value) // Increment through array, look for null pointer (0) at end of string { while ((UCA0STAT & UCBUSY)); // Wait if line TX/RX module is b
  18. Hello, I found some devices which should allow me to connect naked MSP430G2553 chip to PC over USB. But here is one problem I don't really understand. I found devices with FTDI chip (I know it's a brand name) and devices which I found under "TTL UART" or "USB to TTL". Here is link to the FTDI one: https://www.sparkfun.com/products/9873 Here is link to the TTL one: http://dx.com/p/usb-2-0-to-ttl-uart-5-pin-cp2102-module-serial-converter-blue-152317 So, my question is: is there any difference between those two? Because there is huge difference in price. Thanks for replies
  19. I'm working with the stellaris launchpad on energia (version 1010E0009). I need to use two hardware serial ports, and I'm finding that it does not work. I've made a VERY simple sketch that demonstrates this behavior: When every port but one is commented out, the program runs fine. The light blinks, serial data moves, etc. When more than one is created, the first round of data goes out to each port, but it crashes somewhere. Often, the first few characters of the second loop begin printing on port zero. This doesn't happen when the delay(100) is in there. I'm not sure if this is
  20. fdsa

    UART problem

    I'm trying to get a simple uart program working as shown below and I'm having issues with the baud rate being 9600. The program works fine with the baud rate being 115200. The code is based on the code provided in the Stellaris workbook. #include <inc/hw_gpio.h> #include <inc/hw_memmap.h> #include <inc/hw_sysctl.h> #include <inc/hw_types.h> #include <driverlib/gpio.h> #include <driverlib/rom.h> #include <driverlib/sysctl.h> #include <driverlib/uart.h> int main() { // Set clock to 80 Mhz. ROM_SysCtlClockSet(SYSCTL_SYSDIV_2_5 | SYSCTL_US
  21. Hi there! I've got a strange (to me) issue with UART flow control on LM4F120XL. For testing purpouse I use the UART1 both with FIFO enabled and disabled. When FIFO is enabled I use hardware flow control, when FIFO is disabled I'm trying to use the RX interrupt to perform software flow control (I assert and deassert RTS by code insider the interrupt handling routine). The thing is the I would like to test various RTS behaviours: 1) RTS off after 2, 4, 8, 12, 14 characters when FIFO is enabled 2) RTS off after every char when FIFO is disabled But what I see is that when FIFO is enabled (with
  22. Hello! I know I've been posting loads of problems which you have all been very helpful with and I appreciate it. I'm at the last stage in my project where I have to send an image as a byte array (values from 0-255) via serial communication, use H/W UART to receive bytes and map them onto my RGB LED display to create the image. I've configured the UART at 115200 BAUD, clock at 18MHz, I'm using the UCA0 ISR routine to map the received bytes into a 3D array "image[8][8][3]" where the 1st, 2nd, and 3rd terms are row, column, RGB component, respectively. I am seeing results on the display whe
  23. Yet another software only serial class implementation? What makes this one different? C++ template based with asm routines to implement read and write. Works with any pin and port combination. You can mix and match, put read on P2.0 and write on P1.2. Small size even with Energia. Multiple instances allowed. Each instance uses about 12 bytes so you are only limited by the number of pins and memory on your chip. Big plus, doesn't use the timer. Read on if this piques your interest. This code implements a C++ template based software only blocking serial UART class. It doesn't use the timer peri
  24. I'm coding a module for using the UART in the Stellaris Launchpad. I want to use FIFOs. My problem is with the documentation. LM4F120H5QR datasheet states each UART has a 16x8 FIFO for Tx and another 16x8 FIFO for RX. But I can't find what is the FIFO width and what is the FIFO depth. Is the FIFO "16 bit x 8 elements", or is it "8 bit x 16 elements"? PS: Why UART FIFO isn't documented like for example the SSI FIFO. For the SSI FIFO, the datasheet makes it clear: "Separate transmit and receive FIFOs, each 16 bits wide and 8 locations deep"
  25. Hello MSP430 coders once again i am working on the latest thing such as take input from the Hyper terminal or Putty, and display it in jhd162a (16x2 display) via MSP430G2231 I successfully finished 1. UART with Hyper-terminal 2. Displaying String to JHD162A the problem i am facing in g2231 is .. i am able to print String only like .............taking example printf("Hello this is launchpad"); but i want to make it print like int i = 0; for(i=o;i<=200;i++) ( printf("The number is : %d ", i); ) i am giving you scenario so i take the printf Example ..
×
×
  • Create New...