Jump to content
43oh

Search the Community

Showing results for tags 'msp430g2452'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 14 results

  1. Hello, The Blink example works 16 times slower than expected on EXP430G2 rev.1.3 with MSP430G2452. Also enableXtal() gives up after >30 seconds. Perhaps some divider not properly adjusted. I wanted to play with the kids and Energia/Launchpad, but no luck :( Usually, I use CCS for MSP430 development, and I'm not quite familiar with Energia and the init sequence. Energia 1.8.7E21 (Linux 64), Launchpad EXP430G2 rev 1.3, MSP430G2452, no XTAL
  2. Hello, I am experiencing a frustrating problem which I couldn't find an answer to anywhere online so far, I apologize if a related question was posted before and I didn't find it. I have TI MSP-EXP430G2 Launchpad with an MSP430G2452 on it and I'm trying to upload a basic program (the Blink example) with Energia. After the program has been successfully uploaded the program is not run immediately on the chip and the led doesn't start blinking. Instead there is a long delay (30sec to a few minutes) between powering the device on and the start of the execution. There don't seem to
  3. I downloaded Energia 1.6.10e18 I am programming an msp430g2452 I am using LanchPad MSP-EXP430G2 to program my part (on a custom board via spi-by-wire) I am running Energia on Windows 7 I ran update on Energia MSP430 boards via Boards Manager to version 1.0.2 When compiling I get the following errors: In usi_spi.cpp I had to change a couple of instances of spi_tx to spi_send (fixed code below): void spi_transmit16(const uint16_t data) { spi_send(data & 0xFF); spi_send((data>>8) & 0xFF); } void spi_transmit(void *buf, uint16_t count) { ui
  4. So I'm working on a fingerprint scanner project with this repo written for arduino for the scanner I'm using. When I try using this library in Energia, it's been giving me a ram error and refuses to compile. I know that pin assignments and certain things are different between using Arduino to program an atmega microprocessor and using Energia to program an MSP430G2452 with a launchpad, but just compiling it without uploading shouldn't change anything. Here are the errors I'm getting when I try to compile the enroll sketch (attached below) -enroll.cpp.elf section `.bss' will not fit in re
  5. Dear all, I'm using CCS on Win7 and Launchpad 430g2 with a 2452 chip. I cannot get the ISR to execute when I externally drive comparator input voltage up and down. Minimal code is here. I think it should toggle LED whenever I go up. (Other code examples are reading P1.1 comparator correctly in same setup and also LED is connected correctly as tested with other code.) Any idea? Any obvious fault in code? Thanks! Matjaz #include <msp430.h> int main(void) { WDTCTL = WDTPW | WDTHOLD; // Stop watchdog timeractivate comp P1OUT = 0; P1DIR = BIT0; CACTL1 = CAREF1 +
  6. Hi, I'm trying to read analog values from a SHARP IR sensor GP2Y0A41SK0F using the MSP430F5529 launchpad. There was not any error when I verified and uploaded the codes in Energia. However, when I clicked on the Serial Monitor, nothing showed up. But when I chose the MSP430G2452 from the "Tools" menu, the monitor successfully showed the analog values. I connect Vcc (red wire) to 5 V pin, the ground (black wire) to GND pin, and the analog output (white wire) to P6.4 pin/A4 pin. The same thing also happened to the MSP430G2553 launchpad. It only works when MSP430G2452 is selected.
  7. Here is my current project and entry for the Hackaday Prize: http://hackaday.io/project/2375-Garden_automation_and_sensor_network The main purpose originally was to have temperature monitoring of a small outdoor greenhouse, but then I decided to expand it from there. For more info look into the project page via the link above. Description originally from my hackaday projects page: This is a project to create a small network of sensors in the garden, and possibly some automation. The sensor data will be logged on an embedded Linux server (probably a Raspberry Pi or BeagleBone)
  8. Hi All, I am trying to use the AIR430BoostFCC library using the MSP430G2452 uC on the Launchpad. It appears that the library does not play well with this particular uC. The code will run until I call the Radio.begin() function, at which point it stops. Perhaps this is because the G2452 has a USI SPI interface and not a USCI? The MSP430G2553 seems to work correctly (with USCI), but not the G2452. Previously I had a problem compiling code using the AIR430BoostFcc library, which was fixed but the problem had something to do with the defines for USI SPI. That post is here. Perhaps there ar
  9. Here's what has been keeping me busy (apart from my real job) since just after Christmas - a timed camera remote. It is mostly code complete, although could do with a few tweaks here and there. The hardware however isn't quite finished as I'm still waiting for a few parts to be delivered before I can finally finish it - the most critical of which is the 2.5mm stereo plug to go into the camera. Consequently it hasn't actually fired my camera yet, but I'm confident it will work correctly when the final parts arrive. Background Many moons ago, I created a serial port remote release for my S
  10. Hi guys! I'm trying to use energia for a simple TX/RX with cc1101 and launchpad + msp430g2452, but i don't know how to use spi to comunicate cc1101 with msp430 in energia interface... can sombody help me? I'am using: Energia 0101E0011 windows 7 (64 bits)
  11. I've written a tiny library that implements I2C master functionality on MSP430 devices that only have the USI module (for example, MSP430G2412 or MSP430G2452). It's small, simple, works well for me, and might help others in their projects. Blog post at http://jan.rychter.com/enblog/msp430-i2c-usi-library-released Github repo at https://github.com/jwr/msp430_usi_i2c Have fun!
  12. Hi I'm wondering if there's a way to create multiple threads on an msp430g2553 or msp430g2452 using Energia. My project is to try to get software PWM, so I need to create a loop to turn the pin on and off at the correct times, but in a different thread. Thanks in advance!
  13. Hi, I have working code for msp430g2452 which sends data via spi as 8 bit at once. Could somebody, please, say how to change this code to send the data as 16 bit at once? Thanks a lot in advance. #include <msp430.h> // #define PIN_SCLK BIT5 //1.5 #define PIN_DATA BIT6 //1.6 #define PIN_CS1 BIT4 //1.4 #define PIN_CS2 BIT0 //1.0 #define PIN_RED BIT0 //1.0 #define SELECT(PIN) P1OUT &= ~PIN #define DESELECT(PIN) P1OUT |= PIN // #define M_DECODEMODE 0x09 #define M_INTENSITY 0x0A #define M_SCANLIMIT 0x0B #define M_SHUTDOWN 0x0C #define M_DISPLAYTEST 0x0F
  14. Hi, I am having trouble getting the ADC interrupt working for the msp430g2452. I am simply trying to turn on a flag when the interrupt goes off but it doesn't seem to be working. Code below.... #include <msp430g2452.h> void initAdc(); volatile char flag = 0; int main(void) { WDTCTL = WDTPW | WDTHOLD; // Stop watchdog timer P1DIR |= BIT6; P1OUT &= ~BIT6; initAdc(); __bis_SR_register(GIE); while(1){ if(flag == 1){ P1OUT |= BIT6; }else{ P1OUT &= ~BIT6; } } return 0; } void in
×
×
  • Create New...