Jump to content

Search the Community

Showing results for tags 'energia'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 553 results

  1. ksachinkumar

    Serial monitor

    I an using mspexp430g2 launchpad on energia with windows 10 OS.In this while compiling the inbulit "DigitalReadSerial" example code from energia IDE ,at that time it should print the output in the Serial Monitor screen . But it does not print anything.Please help me.
  2. I want know why my code isn't work, I used to use in TM4C129 and edit the code to used in TM4C123GXL, but it doesn't work. #include <stdint.h> #include "driverlib/sysctl.h" #include "driverlib/qei.h" int pos; void setup() { Serial.begin(9600); // Setup QEI Module SysCtlPeripheralEnable(SYSCTL_PERIPH_QEI0); GPIOPinConfigure(0x00031806); //GPIO_PD6_PHA0 GPIOPinConfigure(0x00031C06); //GPIO_PD7_PHB0 GPIOPinTypeQEI(GPIO_PORTL_BASE, GPIO_PIN_1 | GPIO_PIN_2); // Configure and Enable QEI QEIConfigure(QEI0_BASE, (QEI_CONFIG_CAPTURE_A_B | QEI_CONFIG_NO_RESET | QEI_CONFIG_QUADRATURE | QEI_CONFIG_NO_SWAP), 2147483648); QEIVelocityConfigure(QEI0_BASE, QEI_VELDIV_1, SysCtlClockGet()); // Divide by clock speed to get counts/sec QEIEnable(QEI0_BASE); QEIVelocityEnable(QEI0_BASE); } void loop() { // Report Position & Velocity of Encoder to Serial Terminal Serial.print(QEIPositionGet(QEI0_BASE)); Serial.print(','); Serial.println(QEIVelocityGet(QEI0_BASE)); delay(10); }
  3. With the 5.25.0 msp432pr board file update, my SPI stuff has stopped working. Some time back, there was an issue with spi modes 0/1 being switched. As such, that was the direction I was looking to try and figure out my current problem. While digging around I noticed this: 5.23.1\cores\msp432r\ti\runtime\wiring\SPI.h #define SPI_MODE0 SPI_POL0_PHA0 #define SPI_MODE1 SPI_POL0_PHA1 #define SPI_MODE2 SPI_POL1_PHA0 #define SPI_MODE3 SPI_POL1_PHA1 5.25.0\cores\msp432r\ti\runtime\wiring\SPI.h #define SPI_MODE0 SPI_POL0_PHA1 #define SPI_MODE1 SPI_POL0_PHA0 #define SPI_MODE2 SPI_POL1_PHA1 #define SPI_MODE3 SPI_POL1_PHA0 If I swap the definitions for SPI_MODE0 and SPI_MODE1 my code works again. So has the mode swapping problem re-appeared?
  4. Hello, I am playing around with msp432e401y launchpad in Energia and in my case analogWrite() does not work. I am not confident what this behavior is not related to my system, so I would like to get confirmation from other forum members. Thanks
  5. yaywhatfun

    MSP430GET w/ MSP430G2302

    Hi, rank TI n00b here: I am a professional developer working a often in the Arduino IDE with Atmel, ESP, ARM, ATtiny and Kendryte processors among others. I am replicating a client design centered around an MSP430G2302 (14 pin TSSOP versus the apparently several different pin counts for this model) and thought the Launchpad MSP430GET would be a good programmer as it claims to support the MSP430G2302... and Energia is very familiar to me as it is essentially the Arduino IDE. I am finding no way to access the MSP430G2302 from Energia, nor any way to specify a 14 pin vs 16 pin package. Is this IC supported, and if so how do I use it? If this is one of those things where I'll get asked 'would YOU like to support it'; then I can assume it's unsupported despite what the literature claims. I am ready to pay the premium for using an ATMEGA328P-AU in order to be able to move on from trying to make this work to getting on with programming and designing this product. Thank you
  6. When installing energia on Linux Ubuntu the install runs successfully and produces a desktop icon and a menu item. The problem is that both launchers point to "/home/$USER/Downloads/energia-1.8.7E21/arduino" - but the file "arduino" does not exist in the energia directory so the app will not launch.
  7. I am using MSP432P401R and wanted to increase the I2C frequency from 100kHz(Standard) to 400kHz(Fast). In the Wire library for arduino, there is a function Wire.setclock(). Has anybody written such a function for energia? Because it is not there in energia. I went through the wire and twi libraries and found the following, In wire library, Wire.endTransmission calls a fucntion in twi library, twi_writeTo() which has the following line of code, UCBzCTL1 |= UCSSEL_2; // SMCLK Is this the line of code that sets the clock speed? Also in the twi.h library, the line of code, #define TWI_FREQ 100000L defines the frequency as 100kHz, but even if I changed it to 400000L, I don't see any change on hardware. Is this the right way? I'd appreciate if anyone can help me with this. Thanks
  8. Hi Everyone, I'm looking for ILI9340C library so that I can import that library in Energia and burn a program on TIVA C series. I read some of the forums on this websites but some people are using a different launchpad and some are using ILI9341 or some other LCD. I need to work with TIVA C launch pad and ILI9340. I'm using Energia. Before that I was Using Keil uVision to make some libraries for TIVA C Launchpad to work with ILI9340 but that were not that much efficient. I read some of you successfully made libraries to work with TIVA C launcpad and ILI9340 but links provided on those forums are not working or the content from those links have been removed. So please help me. Thanks.
  9. There's a problem in interfacing Neo-6m GPS module with CC3200 MCU. I have to interface with Neo-6m GPS module with CC3200 MCU for getting the coordinates of a particular location. GPS module works fine when I interface it with Arduino UNO/Mega/Nano. Before I bought my own CC3200 MCU, I had interfaced Neo-6m GPS module with CC3200 at an Industrial training Institute and it worked fine there. Now, when I'm trying to interface GPS module with same configuration, setup and program, it shows nothing on Energia's Serial Monitor. Please check video (attached). Please let me know whether jumpers and wires are connected correctly. VID-20190629-WA0002.mp4
  10. Hi, I am trying to use Energia with EK-TM4C1294XL, but I am unable to install the right LaunchPad board on Energia. I downloaded the proper driver usinghttp://energia.nu/guide/guide_windows/and downloaded Energia for Windows using http://energia.nu/download/. As a point of reference, my computer is Windows 64 bit. I then usedhttp://energia.nu/guide/boards/ to install the right LaunchPad board, but I am receiving the following error message shown below. I tried all troubleshooting suggestions on the links provided, but I can’t seem to find a solution to my problem. Can you help me determine the cause of this and help me resolve it?
  11. Hi, Does energia IDE support programming a MSP432 microcontroller on a custom board (by JTAG, SWD or UART) ? If not, what are the hardware modifications needed to support it? In the Energia website I can only see that the launchpads are supported https://energia.nu/guide/install/macos/ Regards and thank you
  12. I'm trying to get Energia21 working with my MSP432E (which I'm still struggling with) and ran into a problem. The platform.txt file references dslite 7.2.0.2096. However, to get this version of dslite, I must install the TivaC board...which installs this version of dslite in .../Energia15/packages/energia/tools/dslite. It seems like there is a mismatch between the dslite version that the v5.19.0 msp432e board is installing and the platform.txt file jrd PS FWIW, now that I fixed this, I get a "Frequency out of range error"...I tried other versions of dslite (6.2.1.1594, 8.0.0.1202, and 8.2.0.1400) to no avail.
  13. Hi Energia V1.8.7E2 OSX 10.14.5 I have been using Energia for a while now to program first a pair of CC1310 Launchpad boards and now the custom boards were designed with the information from that initial exercise. While the Launchpad boards can be programmed directly by Energia the custom boards have no XDS110 debugger interface so need to be programmed using the bootloader and UART. We accomplish this by using a USB->TTL serial adaptor and TI's Smart RF Flash Programmer 2 running in a Windows virtual machine. The issue is this... to get the newly compiled .elf I have to navigate to a folder with a name similar to /var/folders/tn/mrcpkdls2fx208png2rqfvcr0000gn/T/arduino_build_222512/. This folder path and name changes on every rebuild so I have to search for it every time. Not ideal. OK, so the questions are; Can this output folder be changed and, if so, how? What does "Export Compiled Binary" in the Tools menu do? On my system it compiles the current sketch but appears to do nothing else. It would be nice if it actually did something like allow you to save the compiled binary somewhere known on the drive. Thanks
  14. I am making a cloud-based attendance system in my database resides on a particular URL, which is stored at the string variable "server" according to the code. I have multiple WiFi networks in my organisation. I tested my whole system on one of the WiFi networks and I was able to connect to the server and push my data to the cloud. I had a meeting last evening and I had to use another WiFi network for which I entered the required credentials. My system successfully got connected to Wifi network but at the time of pushing the data to the cloud, it showed "Connection failed(to the server)". I tried that many times but no help. Then we thought of using the mobile hotspot. there the server worked fine again. What can be the issue? is the network anyway related to the server? Thanks in advance.
  15. Hello everyone, I would like to know how can I get digital input working under Simulink Embedded Coder Target for Energia. I had successfully used the digital output block in my Simulink models with MSP-EXP430G2 Launchpad, but didn't succeed for the digital input. Does the digital input block require external mode to operate? Please help
  16. Hello,. My idea is about connecting two CC3200 without a separate WiFi router like with their own like for example share it app which connects two devices using wifi one device with hotspot and one connected to that hotspot and share data.Is it possible to do that? As my idea is to share short text data between devices. using energia I want to continuously send/receive data between 2 cc3200 without any other modem unit or with another cc3200 which will be an access point between 2 of them. Is this possible ? If so , where should i begin? cc3200 (unit a) <-------> cc3200 (unit b) or cc3200 (unit a) <------via cc3200 (as AP) -------> cc3200 (unit b) Thank you
  17. Hello everyone! I need editing Energia Library for more flexebility. For example, the msp430 launchpad only have one UART available if i use Energia. How can i configure other UARTs? I need at least 3 UART and I know that TivaCTM4C1294XL have 4 UARTs. Also I need an option for add a parity bit for serial communication. Thank you so much! Gino
  18. i try to use this example but nothing happened // Wire Slave Sender // by Nicholas Zambetti <http://www.zambetti.com> // Demonstrates use of the Wire library // Sends data as an I2C/TWI slave device // Refer to the "Wire Master Reader" example for use with this // Created 29 March 2006 // This example code is in the public domain. #include <Wire.h> void setup() { Wire.setModule(0); Wire.begin(2); // join i2c bus with address #2 Wire.onRequest(requestEvent); // register event } void loop() { delay(100); } // function that executes whenever data is requested by master // this function is registered as an event, see setup() void requestEvent() { Wire.write("hello "); // respond with message of 6 bytes // as expected by master } and this one // Wire Master Reader // by Nicholas Zambetti <http://www.zambetti.com> // Demonstrates use of the Wire library // Reads data from an I2C/TWI slave device // Refer to the "Wire Slave Sender" example for use with this // Created 29 March 2006 // This example code is in the public domain. #include <Wire.h> void setup() { Wire.setModule(0); Wire.begin(); // join i2c bus (address optional for master) Serial.begin(9600); // start serial for output } void loop() { Wire.requestFrom(2, 6); // request 6 bytes from slave device #2 while(Wire.available()) // slave may send less than requested { char c = Wire.read(); // receive a byte as character Serial.print(c); // print the character } delay(500); } with this pin thank you
  19. johnsondavies

    Lisp for the MSP430 FR6989 LaunchPad

    My Lisp interpreter for microcontrollers, uLisp, now supports the MSP430 FR6989 LaunchPad board, with the ability to write text to the LCD display from Lisp programs: For more information see uLisp for the MSP430 FR6989 LaunchPad.
  20. Hi, I have got a hc-05 Bluetooth module, an MSP-EXP430FR4133 board. Now I want to connect them with my computer. However, even I successfully send data from my computer to control the MSP430, it cannot send data back. Can someone tell me what I can do? Here is my code. By the way, I'm using energia for it and set my HC-05 as a slave module. _________________________________________________ // most launchpads have a red LED #define LED RED_LED //see pins_energia.h for more LED definitions //#define LED GREEN_LED void setup() { Serial.begin(9600); /* Define baud rate for serial communication */ pinMode(LED, OUTPUT); } void loop() { if (Serial.available()>0) /* If data is available on serial port */ { char state = Serial.read(); /* Data received from bluetooth */ if (state == '0') { digitalWrite(LED, HIGH); Serial.write("LED turned ON"); state=0; } else if (state == '1') { digitalWrite(LED, LOW); Serial.write("LED turned OFF"); state=0; } } ----------------------------------------------------------------------------------------------------------------------- Waiting for replay! Thank you Kelly
  21. hello, Im trying to interface a 2 inch rgb LCD display with ST7789v lcd driver im using the ucglib library for this i get a few errors stating not been declared need assistance with this please. I attached the library used and the screen shot. ucglib-master_editted.zip
  22. What I'm trying to do: We have been developing a project for school on a MSP430F5529 LaunchPad. We now want to move our project to a custom PCB for the final part. My partner has been using the UCB0 SPI module available through the LaunchPad to communicate to a sensor while I have been separately (as in a completely different sketch) using the same module to run the CC3100MODBOOST Boosterpack. Because no one on my team has much programming experience, we are using Energia to develop the project. We first tried to start with CCS, but we were in way over our heads. Now that we have our different subsystems working, we are using an evaluation board to test out our circuit before going to a PCB. In order to run the SPI module and the sensor at the same time, I want to move the SPI communication with the CC3100 to the UCA1 SPI module. I think I figured out to set up and access all of the pins through pins_energia.h. I created a new board for our setup and added it to Energia. I used some LEDs to check that I could access GPIO pins that weren't accessible on the LaunchPad, and they would all light up when I wanted them to. (I used the digitalWrite() function to check that I actually set up the pins_energia.h file correctly. I didn't directly send the pins high with "P1DIR |= BIT0; P1OUT |= BIT0;" style assignments.) My next step was to switch communication with the CC3100 from UCB0 to UCA1 so my partner could keep using UCB0 for communication with his sensor. This is where I got really lost. I know that the code I have is using the SPI library included with Energia, but I don't know how to modify to do what I want it to do. So my main question ultimately is: "How do I get the Energia sketch to use UCA1 instead of the default UCB0 SPI module for communication with the CC3100?" Secondary to that, I am hesitant to change the installed libraries for Energia. Is there a way that I can reference copies of those libraries where my changes will be made? What I've tried: Looking through the code, I think that for the F5529, Energia is using the functions defined in utility/usci_spi.cpp. For this file at least, it seems to be hardcoded that the MSP will use UCB0. I tried to go through the file and replace every instance of "UCB0" with "UCA1", but that didn't work. I've also tried to look through some other posts about using alternate SPI ports on the F5529, but either I couldn't understand them or they didn't have solutions posted. Hardware: LaunchPad - MSP-EXP439F5529LP Rev 1.6 MCU - MSP430F5529IPN Evaluation board - MSP-TSP430PN80USB Boosterpack - CC3100MODBOOST Rev 1.0 Software IDE - energia-1.8.7E21 OS - Windows 10 Pro Other 43oh posts I've looked at (or at least the most relevant ones): https://forum.43oh.com/topic/5844-f5529-using-alternate-spi-and-i2c-interfaces/ https://forum.43oh.com/topic/5174-getting-i2c1-ie-usci_b1-to-work-on-f5529-launchpad/ Thank you so much for y'alls help with this. I've been trying for a while now to get this on my own, but I keep hitting a wall. This is my first post here, so please let me know if I need to provide any additional info or if there was a different way I should have posed this question. Thank you! Edit: typos/grammar
  23. hello I am getting a cc3200 launchpad and mpu9250, there I want to get the sensor data. I am using the Energia IDE, could anyone have a suggestion for the library of mpu9250 used in Energia IDE? There I just found the library used in Arduino IDE. Is that universal? best wishes
  24. I have been trying to use this i2c code on energia. it works perfectly fine on arduino. i am new to tiva and need help using energia libraries with the multiple i2c ports. any help is appreciated trialEnergua.ino Adafruit_PWMServoDriver.h Adafruit_PWMServoDriver.cpp
  25. Hello there, Ive been trying to use the UART on pin number 3 and 4 by using serial for monitoring the received data and serial1 for connecting and controlling the hardware(GPS) but the by using serial1 i think the uart isnt active. i see by connecting gps to putty that there is no data sent from the cc device . I checked the hardware serial .h and .cpp file where in the cpp file there is serial1 functions mentioned but in the pins_energia file i see no pin initialized as uart only analog, timers and gpio's are initialized. So what can i do to make it work. 1 2 3 4 5 6 7 8 9 10 11 12 13 Serial1.begin(112500); Serial.begin(19200); delay(50); Serial1.println("AT"); delay(1000); Serial1.println("AT+QGNSSC?"); delay(1000); Serial1.println("AT+QGNSSC=1"); delay(1000); Serial1.println("AT+QGNSSTS?"); delay(1000);
×