Jump to content

Search the Community

Showing results for tags 'compile'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 6 results

  1. I am a first time user running Energia 1.7.7E21 on a Windows 7 machine. (Fresh install). My board is an EX-TM4C123GXL. (Tivia C Series Launchpad) The Problem (1 of 2) While trying to run the Blink example program I get the error "Error while detecting libraries included by..." The full message is given below. I have searched, but have not been able to locate information on where the includes should be. Switching to verbose output has provided more info but I'm not quite sure what I am looking for. The code has this as it's first line (this line does not show up in the IDE): #include <Arduino.h> I have tried copying Arduino.h from another location into ... Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system/inc but this did not resolve the issue. I suspect that there may be something wrong with my install but cannot spot it. Any help would be much appreciated. The full messages returned were as follows: Energia: 1.8.7E21 (Windows 7), Board: "LaunchPad (Tiva C) w/ tm4c123 (80MHz)" C:\Program Files (x86)\energia-1.8.7E21\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\energia-1.8.7E21\hardware -hardware C:\Users\Frank\AppData\Local\Energia15\packages -tools C:\Program Files (x86)\energia-1.8.7E21\tools-builder -tools C:\Program Files (x86)\energia-1.8.7E21\hardware\tools\msp430 -tools C:\Users\Frank\AppData\Local\Energia15\packages -built-in-libraries C:\Program Files (x86)\energia-1.8.7E21\libraries -libraries C:\Users\Frank\Documents\Energia\libraries -fqbn=energia:tivac:EK-TM4C123GXL -ide-version=10807 -build-path C:\Users\Frank\AppData\Local\Temp\arduino_build_567315 -warnings=none -build-cache C:\Users\Frank\AppData\Local\Temp\arduino_cache_167371 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\arm-none-eabi-gcc\6.3.1-20170620 -prefs=runtime.tools.arm-none-eabi-gcc-6.3.1-20170620.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\arm-none-eabi-gcc\6.3.1-20170620 -prefs=runtime.tools.dslite.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\dslite\7.2.0.2096 -prefs=runtime.tools.dslite-7.2.0.2096.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\dslite\7.2.0.2096 -verbose C:\Program Files (x86)\energia-1.8.7E21\examples\01.Basics\Blink\Blink.ino C:\Program Files (x86)\energia-1.8.7E21\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\energia-1.8.7E21\hardware -hardware C:\Users\Frank\AppData\Local\Energia15\packages -tools C:\Program Files (x86)\energia-1.8.7E21\tools-builder -tools C:\Program Files (x86)\energia-1.8.7E21\hardware\tools\msp430 -tools C:\Users\Frank\AppData\Local\Energia15\packages -built-in-libraries C:\Program Files (x86)\energia-1.8.7E21\libraries -libraries C:\Users\Frank\Documents\Energia\libraries -fqbn=energia:tivac:EK-TM4C123GXL -ide-version=10807 -build-path C:\Users\Frank\AppData\Local\Temp\arduino_build_567315 -warnings=none -build-cache C:\Users\Frank\AppData\Local\Temp\arduino_cache_167371 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\arm-none-eabi-gcc\6.3.1-20170620 -prefs=runtime.tools.arm-none-eabi-gcc-6.3.1-20170620.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\arm-none-eabi-gcc\6.3.1-20170620 -prefs=runtime.tools.dslite.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\dslite\7.2.0.2096 -prefs=runtime.tools.dslite-7.2.0.2096.path=C:\Users\Frank\AppData\Local\Energia15\packages\energia\tools\dslite\7.2.0.2096 -verbose C:\Program Files (x86)\energia-1.8.7E21\examples\01.Basics\Blink\Blink.ino Using board 'EK-TM4C123GXL' from platform in folder: C:\Users\Frank\AppData\Local\Energia15\packages\energia\hardware\tivac\1.0.3 Using core 'tivac' from platform in folder: C:\Users\Frank\AppData\Local\Energia15\packages\energia\hardware\tivac\1.0.3 Detecting libraries used... "C:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\tools\\arm-none-eabi-gcc\\6.3.1-20170620/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf -w -x c++ -E -CC -mmcu=cortex-m4 -DF_CPU=80000000L -DARDUINO=10807 -DENERGIA=10807 -DENERGIA_EK_TM4C123GXL -DENERGIA_ARCH_TIVAC "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\variants\\EK-TM4C123GXL" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system/driverlib" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system/inc" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system" -mcpu=cortex-m4 -mthumb -mfloat-abi=hard -mfpu=fpv4-sp-d16 -mabi=aapcs "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\cores\\tivac" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\variants\\EK-TM4C123GXL" "C:\\Users\\Frank\\AppData\\Local\\Temp\\arduino_build_567315\\sketch\\Blink.ino.cpp" -o nul Error while detecting libraries included by C:\Users\Frank\AppData\Local\Temp\arduino_build_567315\sketch\Blink.ino.cpp Generating function prototypes... "C:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\tools\\arm-none-eabi-gcc\\6.3.1-20170620/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -nostdlib -fno-threadsafe-statics --param max-inline-insns-single=500 -fno-rtti -fno-exceptions -Dprintf=iprintf -w -x c++ -E -CC -mmcu=cortex-m4 -DF_CPU=80000000L -DARDUINO=10807 -DENERGIA=10807 -DENERGIA_EK_TM4C123GXL -DENERGIA_ARCH_TIVAC "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\variants\\EK-TM4C123GXL" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system/driverlib" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system/inc" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\system" -mcpu=cortex-m4 -mthumb -mfloat-abi=hard -mfpu=fpv4-sp-d16 -mabi=aapcs "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\cores\\tivac" "-IC:\\Users\\Frank\\AppData\\Local\\Energia15\\packages\\energia\\hardware\\tivac\\1.0.3\\variants\\EK-TM4C123GXL" "C:\\Users\\Frank\\AppData\\Local\\Temp\\arduino_build_567315\\sketch\\Blink.ino.cpp" -o "C:\\Users\\Frank\\AppData\\Local\\Temp\\arduino_build_567315\\preproc\\ctags_target_for_gcc_minus_e.cpp" arm-none-eabi-g++: error: unrecognized command line option '-mmcu=cortex-m4'; did you mean '-mcpu=cortex-m4'? exit status 1 Error compiling for board LaunchPad (Tiva C) w/ tm4c123 (80MHz). Problem 2 - Unrecognized command line option -mmcu. This appears to be a typo. The preferences.txt file found at File -> Preferences does not have an entry that matches. Any help on where to find this setting would be appreciated. Thanks in advance
  2. Matze

    Compile error

    Hello guys, I need help. I trust to program one LED with three Buttons on an MSP430, but when I compile the programme it shows an error. I have no Idea. In the following document you can see the code and the error report. Thank you. int R1 = P2_1; // LED Rot int G1 = P2_0; // LED Grün int Blau1 = P1_5; // LED Blau int T1 = P1_4; // Taster 1 int T2 = P1_3; // Taster 2 int T3 = P1_2; // Taster 3 int Time = 300; // Variable 1 int Zeit = 100; // Variable 2 void setup() { pinMode(R1, OUTPUT); pinMode(G1, OUTPUT); pinMode(Blau1, OUTPUT); pinMode (T1, INPUT_PULLUP); pinMode (T2, INPUT_PULLUP); pinMode (T3, INPUT_PULLUP); } void loop() { if(digitalRead(T1)==LOW) { int i; for(i=0;i<=30;i++){ digitalWrite(Blau1,HIGH); delay(50); digitalWrite(Blau1,LOW); delay(50); int i =+ 1; } for(i=0;i<=30;i++){ digitalWrite(R1,HIGH); delay(50); digitalWrite(R1,LOW); delay(50); int i =+ 1; } for(i=0;i<=30;i++){ digitalWrite(G1,HIGH); delay(50); digitalWrite(G1,LOW); delay(50); int i =+ 1; } } else{ digitalWrite(G1,LOW); digitalWrite(R1,LOW); digitalWrite(Blau1,LOW); } if(digitalRead(T2)==LOW) { digitalWrite(R1,HIGH); delay(Time); digitalWrite(R1,LOW); delay(Zeit); digitalWrite(R1,HIGH); delay(Time); digitalWrite(R1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); delay(Zeit); digitalWrite(G1,HIGH); delay(Time); digitalWrite(G1,LOW); delay(Zeit); digitalWrite(G1,HIGH); delay(Time); digitalWrite(G1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); digitalWrite(R1,HIGH); delay(Time); digitalWrite(R1,LOW); delay(Zeit); digitalWrite(R1,HIGH); delay(Time); digitalWrite(R1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); delay(Zeit); digitalWrite(G1,HIGH); delay(Time); digitalWrite(G1,LOW); delay(Zeit); digitalWrite(G1,HIGH); delay(Time); digitalWrite(G1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); delay(Zeit); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(Blau1,LOW); } if(digitalRead(T3)==LOW) { digitalWrite(R1,HIGH); delay(Time); digitalWrite(G1,HIGH); delay(Time); digitalWrite(R1,LOW); delay(Time); digitalWrite(Blau1,HIGH); delay(Time); digitalWrite(G1,LOW); delay(Time); digitalWrite(R1,HIGH); delay(Time); digitalWrite(R1,LOW); digitalWrite(Blau1,LOW); delay(Time); } else{ digitalWrite(G1,LOW); digitalWrite(R1,LOW); digitalWrite(Blau1,LOW); } } JUSTUS.ino Neues Textdokument.txt
  3. I'm trying to connect the MSP432P401R and it keeps giving me this error when I try to verify: Energia: 1.6.10E18 (Mac OS X), Board: "RED LaunchPad w/ msp432 EMT (48MHz)" Exception in thread "main" java.lang.UnsupportedClassVersionError: processing/app/ino2cpp/Main : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637) at java.lang.ClassLoader.defineClass(ClassLoader.java:621) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) exit status 1 Error compiling for board RED LaunchPad w/ msp432 EMT (48MHz). I'm just running the blinking light demo code. I've tried all the sereal ports and keep getting the same error. ideas?
  4. ewparker

    MSP432 Won't Compile

    When I try to compile with my MSP432P401R I get the following error Energia: 1.6.10E18 (Windows 10), Board: "RED LaunchPad w/ msp432 EMT (48MHz)" arm-none-eabi-g++: error: CreateProcess: No such file or directory exit status 1 Error compiling for board RED LaunchPad w/ msp432 EMT (48MHz). Any ideas on a fix? Regards, Eli
  5. anwar1506

    Energia compilation error

    Hey everyone, I'm trying to interface an MSP-EXP430FR5969 with a GPS+GSM module (https://tronixlabs.com.au/arduino/shields/3g-shield/adafruit-fona-3g-cellular-breakout-900-and-2100-mhz-for-optus-vodafone-australia/) I've been able to send a text message to my mobile using the Arduino, but when I try on Energia 1.6 with the module now plugged into the MSP430 I get compilation errors (mainly due to atof not being declared). Here's the code I am using: #include <stdlib.h> #include <stdio.h> #include "Adafruit_FONA.h" #define FONA_RX 4 #define FONA_TX 3 #define FONA_RST 5 #include <SoftwareSerial.h> SoftwareSerial fonaSS = SoftwareSerial(FONA_TX, FONA_RX); SoftwareSerial *fonaSerial = &fonaSS; Adafruit_FONA_3G fona = Adafruit_FONA_3G(FONA_RST); void setup() { while (!Serial); Serial.begin(115200); fonaSerial->begin(4800); fona.begin(*fonaSerial); sendText(); } void loop() { } void sendText () { char sendto[21]= "04XXXXXXXX"; char message[141] = "Text Text Text Text Text Text Text Text Text Text Text Text"; fona.sendSMS(sendto,message); if (!fona.sendSMS(sendto, message)) { Serial.println(F("Sending message")); } else { Serial.println(F("Sent!")); } } "C:\Users\...\Adafruit_FONA.cpp:909:30: error: 'atof' was not declared in this scope" is the main error I am getting. Any suggestions on how to have this compile please? Thanks in advance
  6. Hello all, A year or two ago I attempted to setup Code::Blocks with the arm-none-eabi toolchain so that I could compile and run my Energia projects without dealing with the idiosyncrasies of the Processing-based IDE. I did not much understand command-line tools or GCC and so my efforts were somewhat frustrated. I have picked it up again, and almost have it working. I have analyzed the verbose output from Energia to determine which compiler/linker flags are used, and set up Code::Blocks to do the exact same things as Energia during compilation (excepting one thing, which I will get to later). My projects compile, and I am able to upload them to the device, but for some reason the behaviour is not quite the same. (Specifically, a function I wrote for projecting 3D triangles to a plane does not return the correct value. I initially suspected a problem with the FPU configuration, but I debunked that by trying some other math which compiled and ran correctly.) Also, the .bin file generated by Energia is a slightly different size than the one generated by Code::Blocks. The only difference in the build processes between the two that I can see is that Energia uses arm-none-eabi-ar to roll an archive from the compiled "cores" code which the compiled application is then statically linked against, whereas my Code::Blocks setup compiles and then links everything together in one step. I do not think this is a significant difference, but I can try doing that if all else fails. The build output from Energia and Code::Blocks is attached below, as well as the generated .bin files for each. The code which was compiled to produce the .bin files is identical. If anyone can figure this one out, or help me understand better how Energia goes from code to executable, it would be much appreciated! P.S.: I had to change the file extensions of the .bin's to .txt so that I could upload them. CodeBlocksOutput.txt EnergiaOutput.txt CodeBlocksbin.txt Energiabin.txt
×