Jump to content
43oh

Search the Community

Showing results for tags 'Reset'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 10 results

  1. PLEASE HELP. Does a method exist to do a software reset for the CC320EMT LAUNCHXL? I tried the following Sketch, which compiles and works for the CC3200 LAUNCHXL but not the CC320EMT LAUNCHXL It would not compile and produced this error warning: 'FlashIntStatus' initialized and declared 'extern' [enabled by default] extern unsigned long FlashIntStatus(tBoolean bMasked); C:\Users\lfree_000\Downloads\energia-0101E0017-windows\energia-0101E0017/hardware/cc3200emt/libraries/flash/flash.h:102:37: error: 'tBoolean' was not declared in this scope
  2. I've been working on a project for MSP-EXP430G2 which requires two buttons and hit the problem that S1 is set up as a reset button. Unlike S2 it's not connected to a regular GPIO pin; instead it's connected to the nRST/NMI pin. I looked for information on using the reset button as a user input and found some examples, but they all used the NMI ISR to track rising and falling edges. For example, see this post from the 43oh blog: Using the MSP430G2xx1 nRST NMI Pin as an Input. I really wanted some way to sample the current state of the button directly, which is tricky because there's n
  3. Good morning. I've been using the MSP430 launchpad and programming it using Energia 18. Anyway, for the whole time I've been using Energia, it very often have to unplug and plug back in my device in order to send it another build. Have any of you seen this problem before? Sometimes it works without having to unplug the hardware, however, over 50% of the time, I have to unplug the LaunchPad in order to upload new code to it from Energia. It seems to get hung while attempting the upload. So, to overcome this, I unplug the Launchpad, click the Upload button again, usually get an
  4. I have an Energia project that seems to go astray under rare and seemingly random circumstances - it can occur anywhere from hours to months apart and I haven't been able to pin the cause down. It starts right up again after a reset. It isn't critical if it is down for a minute or so but I am usually not around to reset it manually. However, I can monitor things in the firmware and tell when things are not working correctly. In this situation it is easy enough to force a reset from Energia by writing to the watchdog timer and control register with an improper password. For example, in
  5. Hi All, I have a problem with the watchdog timer reset. I am using Energia with a CC3200 on a custom board but the same issue occurs with a Launchpad. I have cut down the code to demonstrate the problem it is part of a much larger project which has a process control element and needs a watchdog timer. I have cobbled the demo together from all over the place so there are many different coding styles (smells) used - sorry It is spread over 2 tabs The full project has 30. From my reading, the reset functions are unreliable so TI suggests, test if the system has recovered fro
  6. Today my Metawatch Strata decided to completely lock up after charging, and now I can't reset it. I even tried the firmware updater (my Strata runs firmware 1.5.3, and there is 1.5.5 available), it tries to query the watch, but fails. So, does anyone have a tool that can reset the Metawatch via the charge / update clip so I can avoid opening it?
  7. Cmr

    ezchronos msp430

    Trying to find where I can restart to default my dev watch. I might be blind or I look in wrong places but nothing has helped me so far.
  8. I bought C2000 a 1 week ago. I started working today, have been working from last 6 hours. Problem is when ever I flash the program into the C2000 it gets uploaded but whenever I press reset button then program gets lost. All this is happening in Energia IDE. Correct me if I am doing something wrong. Reply asap Thank You
  9. Hey all, I recently got a Nokia 5110 LCD working using the LCD_5110 lib from GitHub. Works great, so thanks to giants whose shoulders I stand atop! I moved my chip (G2553) directly to the board as I have done several times before (with a pullup resistor on RST), and I loaded a little demo program on it with my "loader" board (just TEST, RST, GND, and VCC hooked up to the emulation side of an LP). Program loads and runs fine, but when I remove the loader and cycled power (I was just changing battery sources from a 6V pack to a 9V battery -- they are dropped to 3.3V), the LCD does not i
  10. I played with a MSP430F5510 over the weekend and had a problem: The chip got really warmed (too warm, touchable, but not burning hot) when I connected 4 pins (PWR, GND, RST, TEST) to a programming dongle (from the Chronos watch or from the EZ2500RF board). I checked everything and did see any short, or wrong polarity. CCS is able to flash some code into the F5510 chip in this condition, but it was slow and really warm (almost uncomfortable to hold my finger flat on it). I couldn't verify if it worked or not since I didn't have any test code, and the circuit wasn't complete (Just the chip on a
×
×
  • Create New...