Jump to content

Search the Community

Showing results for tags 'MSP432'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

Found 117 results

  1. Has any one been able to port the WS2811 lib to msp432?
  2. hello ..I am a new user .. i have a msp4323p401r launchpad ..and i have to interface it with an SD card ...can anyone help ..please??
  3. Hi, I'm a bit new to this... I'm wanting to improve the performance of the SPI, I understand that using DMA is the best solution. Are their any example of SPI with DMA? Currently without DMA, I have the SPI setup to send 1 byte at a time with: SPI_transmitData(LCD_EUSCI_MODULE, data); What I want to do is change this so I can fill a buffer with bytes, then say Send. Once thats finished sending I want to fill the buffer again and send the next set of bytes. I tried to use this code although it appears to hang at the last line! DMA_enableModule(); DMA_setControlBase(m_controlTable); DMA_assignChannel(DMA_CH0_EUSCIB0TX0); DMA_disableChannelAttribute(DMA_CH0_EUSCIB0TX0, UDMA_ATTR_ALTSELECT | UDMA_ATTR_USEBURST | UDMA_ATTR_HIGH_PRIORITY | UDMA_ATTR_REQMASK); DMA_setChannelControl(UDMA_PRI_SELECT | DMA_CH0_EUSCIB0TX0, UDMA_SIZE_8 | UDMA_SRC_INC_8 | UDMA_DST_INC_8 | UDMA_ARB_8); DMA_setChannelTransfer(UDMA_PRI_SELECT | DMA_CH0_EUSCIB0TX0, UDMA_MODE_BASIC, m_data_array, (void*)SPI_getTransmitBufferAddressForDMA(EUSCI_B0_MODULE), 1024); DMA_assignInterrupt(DMA_INT1, 0); Interrupt_enableInterrupt(INT_DMA_INT1); ? I was planning to use the code above by filling the buffer "m_data_array" then calling DMA_enableChannel(0); although this didn't work. How do i know when the buffer has been transmitted?
  4. I have a Dig Pot the TPL0501 by Texas Instruments that I am trying to control with a micro controller. Link Here: http://www.ti.com/lit/ds/slis136a/slis136a.pdf I have been able to successfully control this with my CC3200 and the output signals look like Photo 1 attatched. I have since decided I want to do this with my MSP432 but I am not able to get it to work. The same code should work for each I assume. The output signals I am getting for the MSP432 are shown in photo 2. I have tried changing the mode but nothing seems to help. Any ideas? My code is listed below: #include <SPI.h> const int SS = 18; uint8_t value = 150; void setup() { pinMode(SS, OUTPUT); SPI.begin(); digitalWrite(SS, HIGH); SPI.setBitOrder(MSBFIRST); SPI.setDataMode(SPI_MODE3); SPI.setClockDivider(SPI_CLOCK_DIV32); } void loop() { digitalPotWrite(value); delay(100); } int digitalPotWrite(int x) { digitalWrite(SS, LOW); SPI.transfer(x); digitalWrite(SS, HIGH); }
  5. How can I interface an SD card to msp432p401r launchpad ??
  6. Hi, I'm struggling to get the the ILI9341 display to work on a MSP432. I've used it on an arduino with this display driver, so I figured that would be a good start for the porting. This display is setup to use SPI (SCK,MISO,MOSI, CS,DC). I understand this is called 4 wire SPI? The following is the code used to init the SPI is this correct? GPIO_setAsOutputPin(LCD_RESET_PORT, LCD_RESET_PIN); GPIO_setOutputLowOnPin(LCD_RESET_PORT, LCD_RESET_PIN); GPIO_setAsOutputPin(LCD_DC_PORT, LCD_DC_PIN); GPIO_setOutputLowOnPin(LCD_DC_PORT, LCD_DC_PIN); GPIO_setAsOutputPin(LCD_SPI_CS_PORT, LCD_SPI_CS_PIN); GPIO_setOutputLowOnPin(LCD_SPI_CS_PORT, LCD_SPI_CS_PIN); // // Configure SPI peripheral. // GPIO_setAsPeripheralModuleFunctionOutputPin(LCD_SPI_MOSI_PORT, LCD_SPI_MOSI_PIN, LCD_SPI_MOSI_PIN_FUNCTION); GPIO_setAsPeripheralModuleFunctionOutputPin(LCD_SPI_MISO_PORT, LCD_SPI_MISO_PIN, LCD_SPI_MISO_PIN_FUNCTION); GPIO_setAsPeripheralModuleFunctionOutputPin(LCD_SPI_CLK_PORT, LCD_SPI_CLK_PIN, LCD_SPI_CLK_PIN_FUNCTION); eUSCI_SPI_MasterConfig spiMasterConfig = { EUSCI_B_SPI_CLOCKSOURCE_SMCLK, // SMCLK Clock Source CS_getSMCLK(), // Get SMCLK frequency 15000000, // SPICLK = 15 MHz EUSCI_B_SPI_MSB_FIRST, // MSB First EUSCI_B_SPI_PHASE_DATA_CHANGED_ONFIRST_CAPTURED_ON_NEXT, // Phase EUSCI_B_SPI_CLOCKPOLARITY_INACTIVITY_LOW, // Low polarity EUSCI_B_SPI_4PIN_UCxSTE_ACTIVE_HIGH // SPI Mode }; //EUSCI_B_SPI_4PIN_UCxSTE_ACTIVE_HIGH //EUSCI_B_SPI_4PIN_UCxSTE_ACTIVE_LOW SPI_initMaster(LCD_EUSCI_MODULE, &spiMasterConfig); SPI_enableModule(LCD_EUSCI_MODULE); SPI_clearInterruptFlag(LCD_EUSCI_MODULE, EUSCI_B_SPI_RECEIVE_INTERRUPT); The code i'm unsure about is: - GPIO_setAsPeripheralModuleFunctionOutputPin Should SCK, MOSI, MISO all be set as output or input? - EUSCI_B_SPI_CLOCKPOLARITY_INACTIVITY_LOW Not really sure what this means is it correct? - EUSCI_B_SPI_PHASE_DATA_CHANGED_ONFIRST_CAPTURED_ON_NEXT Not really sure what this means is it correct? -EUSCI_B_SPI_4PIN_UCxSTE_ACTIVE_HIGH Not really sure what this means is it correct? - SPI_clearInterruptFlag(LCD_EUSCI_MODULE, EUSCI_B_SPI_RECEIVE_INTERRUPT); I'm not using interrupts should I remove this line? Board: MSP432 Launchpad Datasheet: http://www.adafruit.com/datasheets/ILI9341.pdf
  7. Hello, I got my msp432 LP and started porting some of my previous code to the newer Energia MT, using the clock library. I want to measure number of variables from my sensors, and display them on the Sharp LCD board. Namely: float sensors[15]; Clock clockDisplay; Clock clockMeasure void setup() { ... clockDisplay.begin(update_display, 1000, 1000); clockDisplay.start(); clockMeasure.begin(measure_parameters, 1000, 100); clockMeasure.start(); ... } void update_display() { screen.clearBuffer(); screen.text(10, 10, floatToString(buffer, sensors[1], 2, 5, false)); screen.flush(); } void measure_parameters() { sensors[0] = ina219_A.getShuntVoltage_mV(); sensors[1] = ina219_A.getBusVoltage_mV(); sensors[2] = ina219_A.getCurrent_mA(); ... } So I have two clocks, one measuring and storing sensor values in a float array, the other (should be) displaying the values from the float array on to the LCD screen. I have verified that both the sensor reading and the display to be in working order indepedently, but it appears that the float[] is not accessible to both of the methods, i.e. it is not shared memory. What are the possible ways to fix this? What approaches should I take when I am dealing with this kind of system? Previously I used millis() inside the loop, to count, and trigger certain functions when the time is appropriate. It seems to me that Energia MT with MSP432 is really really nice, and I am planing to build all my new code on this. @@Rei Vilo We need more solid examples. Any help/ideas/recomendations are greatly appreciated. Best regards, C.A.
  8. Hi guys, this forum have already helped me a lot, but I never needed to make a post. So, here I am I am using the MSP432 LaunchPad with CC3100. I could not find useful examples to use the CC3100 on CCS, so I decide to use Energia. What I need to do is get some analog data, convert it to digital and send it through the TCP/IP protocol. So far, everything is working fine, the problem is that I need the ADC sample rate be around 1kHz and I could not find where I can change it or verify it. Do you guys know what is the default ADC sample rate for MSP432? Also, I am using ADC with 14 bits of resolution. Thank you!
  9. Uploading a very basic sketch 48488 bytes to the LaunchPad MSP432 requires up to 30 seconds. Is there a way to speed-up the process? Sketch size Upload log
  10. Hello, I want to design and make Cubesat OBC(On board computer) using MSP 432 & energia for eash coding and RTOS. But i am student and begginer. if i design like schematic for MSP432-Lunchpad, could i use energia without any other processes? if not, How can i use energia for my DIY board? and I want to connect SRAM to MSP432 using SPI communcation and control SPI using energia is it possible? Could i use fully functionality of RTOS using energia ? and if you any other advice, please let me know. I'd appreciated if you reply these questions. Thank you much.
  11. Hi guys, do you know if there is a way to set different priorities to different threads of a sketch? For example, if we had a slow thread which senses a thermomenter and another one which sends data serially bit-banging a pin, and another one which senses an emergency stop (whatever, just imagine they are all pretty fast processes) I would like to set a list of priorities for the underlying TI/RTOS to handle possible needs. Is there a way to implement this? Also... if we set interrupts to handle certain events... how does Energia signal the RTOS the priority for this (like in don't interrupt an interrupt )? Thanks for your insights Gast
  12. Hello, I am in trouble with MSP-EXP432P401R Launchpad UART module when evaluating the board uart capabilities with the CCS - DriverLib example:uart_pc_echo_12mhz_brclk. To keep everything simple, on MSP side I have not made any modification on the example code. In LabVIEW using Example finder with keywords "Serial" the vi named: "Basic Serial Write and Read.vi" you can find the host VI for test. My problem is: The elapsed time between sending a byte to the MSP UART and receiving a byte takes too long. In the above example, it takes 150 ms to get a reply from MSP432. I have tried the following: Changing the USB ports (type 2.0 | type 3.0) MCLK speed, UART speed Changed the MSP432 launchpad and the Host PC too without any success. The problem: It takes 150ms to get a first character from the MSP since I write into it. After the first byte arrived to host, all the remaining data can transfer fast and smooth it there are. Later on, I have repeated the test with .NET based Serial Host application but nothing changed. Here is my original thread from TI Forum: https://e2e.ti.com/support/microcontrollers/msp430/f/166/t/417262 Unfortunately, I have not received any useful reply for almost a week. Could you help me to handle this issue? Thank you so much! UPDATE: I scoped the MSP432 UART pins (RXD, TXD) with Logic analyzer and attached the image of the result. You can see the MSP works very well, so the problem should be somewhere else. Have you every met similar situation? I suppose the PC side buffer issue...
  13. A totally new MSP on the way. I assume a new device rather than just a new LaunchPad, although the video focuses on LaunchPads.
  14. It appears that tone() and noTone() were left out in the port of Energia to MSP432. C:\Users\schen\AppData\Local\Temp\build4827627254845353855.tmp/W18_PWM_buzzer.ino:16: undefined reference to `tone(unsigned char, unsigned int)' C:\Users\schen\AppData\Local\Temp\build4827627254845353855.tmp/W18_PWM_buzzer.ino:19: undefined reference to `noTone(unsigned char)' collect2.exe: error: ld returned 1 exit status
  15. pinMode(n, INPUT_PULLDOWN) does not work on MSP432. The pins seem to function as input and the pull-up is always enabled in any input mode.
  16. I am using Energia 0015 with MSP432 LaunchPad. There are some missing functions in the library. I patched a few of them in the application code to get it to work. I would like to move the patches to the library. Unlike the Energia library for MSP430 or Tiva, the library does not get rebuild every time I hit verify or upload (which is a good thing). But I don't know how the library gets rebuild. Could someone explain it? Much appreciated.
  17. The SPI.setBitOrder() and SPI.setDataMode() function calls seem not to do anything on the MSP432 LaunchPad. They work fine with TivaC LaunchPad.
×
×
  • Create New...