Jump to content
43oh

Search the Community

Showing results for tags 'MSP430G2553'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

  1. Hello everyone. I'm a beginner and doing some project with the MSP430 2553. I connected the MMA7455 and used different libraries to get some data, but I'm doing something wrong. Perhaps I use the wrong ports, or the wrong configuration, or I don't know what I'm missing. With the libraries I get to show text in the terminal, but the values are always 0. I would be grateful if someone could help me out, I'm for days on this problem. SCL -> 1.6 SDA -> 1.7 Libraries I used: https://playground.arduino.cc/Main/MMA7455 https://arduino-info.wikispaces.com/accelerometer
  2. I was trying to port a sketch that used the Serial port with non standard UART parity and character length to Energia. I noticed that the UART port isn't setup to handle anything except 8-N-1. While the code below can't do all the combinations that are available to the atmega, it can do 7/8 bit, even/odd parity and 1/2 stop bits. I created a patch that will at least fix it for the chip I am using (msp430g2553). It will need some work for other chips. Apply the attached patch to the source of the latest Energia source tree. (as of 11/11/2015) -rick (See new optional second parameter
  3. SIMPL = Serial Interpreted Minimal Programming Language Hi, It's been about a year since I talked about SIMPL - a tiny language that allows you basic control of a microcontroller using serial commands. In the 6 months I have coded it up in MSP430 assembly language to make it super compact - and fast - with high level commands taking about 1uS to execute on the virtual machine interpreter. SIMPL is based on a jump table - so for any single, printable ascii character, the jump table will act on it and execute whatever function you choose to write. This technique gives amaz
  4. Do you have date time to introduce support for C++11 as introduced to ESP8266/ESP32 on ARDUINO IDE. Thank you for your help example: namespace { enum class STATES_MSP: std::uint8_t { MSP_Sleep,MSP_Poweron,MSP_PIR_Alarm,RTC_Alarm,ESP_Power_off,ESP_Heartbeat,ESP_Power_on }; };
  5. I'd like to monitor power and indicate to the user of my device when power is getting low (via flashing LED). Does MSP430G2553 support power monitoring and does the Energia library have any tools to access this monitoring?
  6. Seems to me that I2C is a fairly commonly used way to communicate between MSP430G2553 and various sensors. However, I cannot seem to find a standard library that implements it. There are many home spun implementations and there doesn't seem to be a standard I2C Library. I'm VERY NEW to the embedded development world, but have been a windows programmer for 20 years. I'm used to having standard reusable libraries that do the grunt work for me so I don't have to re-invent something that has been done by others 100 times already... Am I just missing something or are all embedded developers
  7. Good Morning, This may be the wrong place to ask this question. If so, please let me know where to ask it.. I've been a Windows programmer for 20 years. I've pretty much stuck to User Interface development the whole time. I have been using .net and C# for the past 10 years so I am VERY SPOILED when it comes to letting the language do the grunt work and I finesse the code. I now find myself working on a personal project which requires me to program the MSP430G2553 controller. I started out by using Energia (which if you don't know, is a fork off of Arduino) The advantage of it
  8. I'm writing my own i2c library and need to be able to simultaneously change PinMode on 2 pins. One for SCL and one for SDA. Is there a way to change PinMode on 2 pins simultaneously? I want the behavior of the follwing: PinMode(14,OUTPUT); PinMode(15,INPUT); without the 2.5microsecond delay between the 2 calls above.
  9. After making the wearable MSP430 for Halloween this year I was requested to make more for a children's dance group. I have a question, but first some background. This is the latest version: Everything works fine. I use an adapter with pogo pins to program it as shown in the photo. There are three LEDs on the PCB, a push button switch for the user, and more accessible pins than the previous version. Parts are TSSOP and 0805 SMD. Snap fasteners and stainless thread can be used to connect it to LEDs on the costume. A CR2032 coin cell is used to power it (coin cell holder is on the backsi
  10. So, I've read the threads and have made things work once, but now, without seeming to have changed anything, I'm getting code that goes into never-never land.. In twi.c, around line 607 in Energia version 17, I get a lockup in the first while statement: #if defined(__MSP430_HAS_USCI__) || defined(__MSP430_HAS_USCI_B0__) || defined(__MSP430_HAS_USCI_B1__) /* Ensure stop/start condition got sent before we exit. */ if(sendStop) { while (UCBxCTL1 & UCTXSTP); // end with stop condition } else { while (UCBxCTL1 & UCTXSTT); // end with (re)start condition } #endif I've been
  11. ?Hello, I am trying to upload a "Blink" program to my MSP-EXP430G2. I have no problems uploading code successfully through Code Composer Studio. But if I try to update the same code through Energia, it won't work. The error message is: usbutil: unable to find a device matching 0451:f432 An error occurred while uploading the sketch I have checked that the port number and board are correctly selected. Could anyone offer any help troubleshooting this? I want to use Energia over CCS, mainly so I can quickly and easily get a read-out of the serial port. But if anyone knows of an ea
  12. Ok, so I've changed over to an MSP430G2553IRHB32R Controller. This is in the QFN 32 pin package. According to it, P1.6 is for SCL I2C and P1.7 is for SDA I2C. On the 20 pin board, they are pins 14 and 15. On the 28 pin board they are pins 22 and 23. On the 32 pin board they are pins 21 and 22. So, I'm trying to use the simple I2C Scanner and get nothing. I have 2 I2C devices attached, but cannot see either of them. There have been many posts about inserting a Wire.write(1); command and copying updated files into the system. I'm using the latest Energia 18 on a Windows 10 ma
  13. I'm trying to use a Launchpad 430 to program a board that has an MSP430G2553IRHB32R. I am doing this on a Windows 10 machine. I've removed the jumpers on the Launchpad and connected VCC and Ground to the other board. I've also connected RST and TEST pins. I created a simple blinky sketch which runs just fine with a stand alone Launchpad 430. However, when I attempt to program my custom board with the same code, I get the following error. MSP430_GetNumberOfUsbIfs MSP430_GetNameOfUsbIf Found FET: HID0003:COM5 MSP430_Initialize: HID0003:COM5 Firmware version is 20409001 MSP430_VCC: 30
  14. Hi everyone! I'm new here and I'm pretty new with MSP430 as well. I have been working on a project that measure vibration using accelerometer (ADXL362) and send the information by RF using nRF24L01. I had successful doing this using ADLX345, but I could not do it with ADXL362. The nRF2401 it's working well. Anybody can help me? Follow the code: #include <Enrf24.h> #include <nRF24L01.h> #include <string.h> #include <SPI.h> Enrf24 radio(P2_0, P2_1, P2_2); // P2.0=CE, P2.1=CSN, P2.2=IRQ const uint8_t txaddr[] = { 0xDE, 0xAD, 0xBE, 0xEF, 0x01
  15. Hello all! I am currently working on a project that uses two NRF24L01 modules to communicate between two MSP430G2553 chips. The goal is to send a 14 character string of numbers and letters between the two devices. I have been trying to get code working with Code Composer Studio for a few weeks now, but have had no success at all. I found several posts on this forum from others who have tried similar things and this post in particular, http://forum.43oh.com/topic/2050-nrf24l01-registerscommands-and-functionswork-in-progress/page-2 with a link to a library created by Spirilis, however I
  16. on MSP430G2553 mounted on launchpad I have a problem with converting an integer to a String: uint8_t x=10; uint8_t y=10; String xx = String(x,DEC); String yy = String(y,DEC); Serial.println (xx); Serial.println (yy); with Energia Vers 0101E0012 the result is 10 for xx and 10 for yy but i will to use Energia V17 to use LMP4 mode . the result is garbage for the two converted value --> xxx (three characters) then CR then xxx(garbage three characters) the other problem with Energia V 18 , i can not reprogram the chip (on Windows 9) error is : unable to find a devic
  17. on MSP430G2553 mounted on launchpad I have a problem with converting an integer to a String: uint8_t x=10; uint8_t y=10; String xx = String(x,DEC); String yy = String(y,DEC); Serial.println (xx); Serial.println (yy); with Energia Vers 0101E0012 the result is 10 for xx and 10 for yy but i will to use Energia V17 to use LMP4 mode . the result is garbage for the two converted value --> xxx (three characters) then CR then xxx(garbage three characters) the other problem with Energia V 18 , i can not reprogram the chip (on Windows 9) error is : unable to find a devic
  18. Good morning, I'm using the latest Energia 18 build with Windows 10. I'm plugged into an MSP430 Launchpad with an MSP430G2553 chip on the board. The following code hangs on the Wire.endTransmission() statement.. Can somebody throw me a bone here and tell me how to fix this? int findAddress(int fromAddress, int toAddress) { int address = 0; for (int a = fromAddress; a < toAddress; a++) { Serial.print(a); Serial.print(" - beginTransmission.. "); Wire.beginTransmission(a); // delay(3); // Wire.write(1); Serial.print(" e
  19. This code example works with Anaren and CC2500 BoosterPacks, (and of course with many other CCxxxx boards, like eZ430-RF2500,) and with G2553 LaunchPad. The code was based on slaa325 from TI (I am using same RF configs.) To use it, just un-comment one of the following lines in msp.h: //#define HARDWARE 2500 // CC2500 BoosterPack SPI1 G2553 LP //#define HARDWARE 915 // Anaren (915MHz) G2553 LP //#define HARDWARE 4302500 // EZ430-RF2500 CCxxxx.zip
  20. I would like to be able to program some MSP430G2553's with my MSP430G2553 Launchpad. Anyway one board is 25 pin and the other is 28 pin. Energia seems to only support the Launchpads for MSP430. How do I add the following boards to the List? MSP430G2553IRHB32R (25 pin) MSP430G2553IPW28 (28 pin)
  21. Hello everyone; As you can see bitshifting a byte 16 bits and storing in a long doesn't seem to work, while shifting storing and shifting again works perfectly. Is this behaviour normal? Using energia 0101e0017 on win7 with msp430g2553 launchpad. Also i'm not 100% sure but i think bitshifting 16 bits worked fine on a tm4c123gxl launchpad because i ran into this while converting a code that was written for tm4c to msp.
  22. I am using the latest version: energia-0101E0017. I just reloaded it from Energia's website this morning. It is their December 2015 version. I am using the latest CCS version 6.1.3. I installed a fresh version of that a couple days ago and have applied all the updates I could find. Using the very popular I2C_Scan tool, I get bad results. I either get all addresses telling me there's a device there, or if I do a write(0); between begin and end transmission, I get no devices... See brief code snip below: void findAddress(int fromAddress, int toAddress) { for (int a = fromAddres
  23. For the AT commands from energia's serial monitor it appears as some characters missing!!! Any solutions? Below is my output: AT+CREG? +CREG: 0,1 OK AT+CREG=? +CREG: (0-2) O AT+CFUN=? +CFUN: (0,1,4),(-) K
  24. Hello - here is my example sketch that i did for another project - after i got it finished - i realized that i should share it because i could not find complete example like this on my own previously which included using the analog input to measure position of the arm - maybe it saves someone else a few minutes L298N_Motor_Example_12in_actuator_public.ino
  25. This is a recap of a little adventure in the hopes that it helps someone else out there. This application is on an MSP430G2553 MCU. CSS is used as the IDE and the Energia libraries are in play (a good tooling combination, highly recommend J). The app spends most of its time in LPM3. It wakes up periodically to do certain tasks and also wakes up when traffic comes in on the UART RX channel. The ISR for the RX channel detects the arrival of a command and acts on the command during the ISR. Part of servicing a command is sending a response, which is transmitted via the UART TX channel
×
×
  • Create New...