Jump to content
43oh

Search the Community

Showing results for tags 'Energia'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

  1. I get the error "'SPISettings' does not name a type" when I compile my code for LoRaWAN. The codes are working in Arduino with the libraries LoRa.h and SPI.h. I have added the image to where the error is pointing at (In LoRa Library) and the Error message as well below. I tried changing the energia SPI library to the Arduino SPI library as well but this created more problems. Out of all the things I tried, the most simple error I get is here when it says "Does not name a type". How can I correct that bit of code to get rid of this error. I'm a relative beginner in Energia and no
  2. Hello, I could not find complete answer so posting this question. Is it possible to use MSP432 hardware serial (2..3) in Energia? Is there any specific reason it is not implemented or special syntax has to be used? Thanks in advance
  3. In the standard Button example in Energia (Examples->02.Digital->Button), it works fine when I upload it to the MSP432P401R. But if I add a delay to the loop that is greater than 250ms, then the LED that's supposed to turn back on when the button is released, never turns back on. If the delay is less than 250ms, then the sketch works as expected. Why do you think this happens? const int buttonPin = PUSH2; // the number of the pushbutton pin const int ledPin = GREEN_LED; // the number of the LED pin // variables will change: int buttonState = 0; // variabl
  4. I cannot get this led to dim. It will flash on and off but no PWM as far as I can see. I copied the code right from the website here. http://energia.nu/Tutorial_Fading.html and wired everything the way it should be. Using a 220Ohm resistor instead of the 10k they had in there BOM. What am I doing wrong? I am using the MSP430G2231 chip and have all my settings in energia set accordingly I really don't know what I am doing wrong or if I have a faulty chip? Looking for someone to point me in the right direction.
  5. Hi, Is there anyway I can convert specific Arduino Libraries to Energia? I am using lora.h github library in Arduino, but now I want to use it on Energia. How can I modify this library to support my msp430g2553 device on Energia? Thank you.
  6. Hey guys, I´m using TM4C123G but I can´t configure Energia. When I go in board management and try downloading Energai TivaC Boards it fails and an error messaging appears saying "error during download..." Anyone knows how can I sovle it? Regards!
  7. Hallo, I have ordered the MSP-EXP430FR2433 from TI. While I am waiting I have installed the MSP-EXP430FR2433 board. I opened the ASCIITable .ino in Energia and clicked the V button. I get the following errors: Energia: 1.6.10E18 (Windows XP), Board:"MSP-EXP430FR2433LP" I:\EnergiaIDE\arduino-builder -dump-prefs -logger=machine -hardware "I:\EnergiaIDE\hardware" -hardware "C:\Documents and Settings\hmjswt\Local Settings\Application Data\Energia15\packages" -tools "I:\EnergiaIDE\tools-builder" -tools "I:\EnergiaIDE\hardware\tools\msp430" -tools "C:\Documents and Settings\h
  8. Hello, I have MSP430FR6989 Launchpad. As per below schematic,I generate internal Vref+ voltage 1.2V on Pin P1.1. I'm successfully measure 1.19V on pin P1.1. So,This Vref I apply in NTC as per below schematic( please ignore MSP430FR4133). But I got an issue in below code: void Vref_ON() { while(REFCTL0 & REFGENBUSY); // If ref generator busy, WAIT REFCTL0 |= REFVSEL_0 + REFON + REFOUT; // Enable internal 1.2V reference while(!(REFCTL0 & REFGENRDY)); // Wait for reference generator
  9. Usama

    MSP430 GPS

    Hi, Is there any GPS library for energia that supports MSP430g2553? TinyGPS++ doesn't seem to work. Please help. Thank you.
  10. Hi, When doing offset calibration for pH sensor in Arduino we bring pH 7 to 2.5V as Arduino analog output is 5V. Does that mean when the same is done with msp430g2553 the voltage be adjusted to 1.5V as msp430g2553 analog pins output around 3V only? When I tried adjusting the pot I could only bring it to a minimum of 2.5V with msp430. Does anyone know why? Thanks.
  11. The MSP432P104R SPI mode definitions have opposite polarity as the conventional modes, that is confusing enough. Yet, when I import an Energia project into CCS, the SPI polarities of the modes are reversed. I used tone() built-in function in Energia IDE for MSP432P104R. It had no output. I imported the project into CCS to debug it, the tone() function works under CCS. I am using Energia 1.6.10E18 and did all the updates of the libraries. I am using CCS v8 with all the updates. I also deleted the msp432_MSP-EXP432P401R_core and re-import the project and that did not change anything I
  12. Hi! Im getting these errors: This is my main code, it just reproduces a tone: Reproductor.ino #include "Nota.h" #include "Imperial_March.h" using namespace std; #include <vector> #include <string> template class std::basic_string<char>; #define DO 261.626 #define RE 293.665 #define MIb 311.127 #define MI 329.628 #define FA 349.228 #define FAs 369.994 #define SOL 391.995 #define SOLs 415.305 #define LA 440.000 #define SIb 466.164 #define SI 493.883 #define DOM 523.251 #define DOMs 554.365 #define REM 587.330 #define MIMb 622.254 #define MIM 659.25
  13. I'm using ccs7.4, import Energia e18, choose blink example, use MSP-FET Flash Emulation Tool to program for IC msp430g2452. The code is working. it blink led. But take about 25second to begin running. I don't know why. i need some help.
  14. Hello my friends, I have a macbookPro with macOS highSierra and I installed the latest version of IDE energy. After that I tried to compile the basic blink example. Following error was returned: ino2cpp: error: sketch directory '{build.project_path}' doesn't exist or isn't a directory. exit status 1 Error compiling for board RED LaunchPad w/ msp432 EMT (48MHz). Can someone help me? I would like to have energia functional.
  15. Hello, I am experiencing a frustrating problem which I couldn't find an answer to anywhere online so far, I apologize if a related question was posted before and I didn't find it. I have TI MSP-EXP430G2 Launchpad with an MSP430G2452 on it and I'm trying to upload a basic program (the Blink example) with Energia. After the program has been successfully uploaded the program is not run immediately on the chip and the led doesn't start blinking. Instead there is a long delay (30sec to a few minutes) between powering the device on and the start of the execution. There don't seem to
  16. Hello! I m trying to run the code for the coin acceptor mechanism. its getting compiled properly on but on updation it is showing no output on serial monitor i.e serial monitor is completely blank. Since i m using Energia IDE for TM4C123gxl so i have tried the same code on Arduino IDE as well and over there it is giving the exact output as i want. and all the things are correctly selected ie the port, board and everything. What could be the problem? Code.txt
  17. Ssherry

    cc3100

    I am working on code related to sending an email through cc3100booster and msp432p401r. I am having an issue in connectivity of wifi in the module when the wifi connection code is provided in void setup(). I am providing mobile's hotspot and it gets connected and disconnected periodically. I require an continuous connection. When the wifi connection code is written inside loop(), the connection problem is solved but a newer issue is arised i,e, the program is running for email but not for the server [In server program i am sending temperature and pulse count value to thingspeak.com to get
  18. Some topics come aver and over again. Here are the most frequent questions. Wouldn't be nice to have all of them in one single place? Listed questions: Netiquette for Newbies What Information to Provide When Asking for Help I²C Check-List Porting an Arduino library to Energia Use Pins Number instead of Pins Names with Energia Add a New Board to Energia LaunchPad and BoosterPack Pins Maps Boards Supporting the Galaxia Library Netiquette for Newbies What Information to Provide When Asking for Help
  19. Hello, I'm using energia 1.6.10E18 with the launchpad MSP430G2 and the MSPG2553 installed. So I saw that in another forum the library from cactus.io was used for the BME280. That library was for the I2C. Now I want to use the SPI library and they had one.(http://cactus.io/hookups/sensors/barometric/bme280/hookup-arduino-to-bme280-barometric-pressure-sensor-spi). So I installed the library changed it to hardware SPI with the cs pin on P2_1. And it compiled, but i'm only getting these results: 813.81 mb 100.00 % 0.00 *C 32.00 *F 813.81 mb 100.00 % 0.00 *C
  20. Hello, I want to connect cc3220 to firebase database. Earlier I was using Esp8266 with firebase-arduino library but Energia do not support this library. How can it be done on cc3200?
  21. I'm porting my compact Lisp interpreter, uLisp, to the MSP430FR5994 LaunchPad, and would like to provide SD card support. I've already got code working with AVR chips using the Arduino SD library. Is there a port of this to Energia, or something similar? Thanks, David
  22. This is a fun project that was created for my embedded systems class at John Brown University that allows you to create your own quiz wizard similar to the jeopardy game show system. The main portion of this code is run on an MSP430F5529 launchpad, and nRF24L01 transceiver modules were used to obtain the wireless functionality. It makes use of the Enrf24.h library to operate the transceiver modules, and the user interface is output to the serial monitor of the energia IDE. Four buttons wired into the MSP430F5529 then allow the user to interact with the system. The wireless module was created
  23. Hi All, I am new to msp430 world, so far i have done many projects with mbed (LPC1768,KL25Z and K64F). I liked mbed as it is so easy to use, however to make cost efficent and low power products i am now trying to learn msp430. I want to interface msp430g2553 with cc1101 transceivers. I have done the basic communication using mbed(like sending and receiving data). However I need some help with msp430. I want to use msp430 as transmitter first and receive data on mbed-lpc1768. I have converted the mbed library to msp430(changed syntax where required) and managed to compile it wit
  24. Check the usual suspects: Is the I²C bus initialised? Wire.begin(); Does the I²C device run at 3.3V? Otherwise, use a logic-level converter. Are pull-ups installed? Try 10, 4.7 or 2.2 kΩ for the SDA and SCL lines. In case the LaunchPad provides multiple I²C ports, is the correct port selected? Try Wire.setModule(0); // or other port number Wire.begin(); Still nothing? Use a logic analyser to trace the signals on the I²C port. (To be continued...)
  25. I am trying to interface GY-80 (only adxl345) to TM4C1294XL board using Energia. But outputs comes out to be 0. And also there comes this error "Failed to load dynamic library: 'ftd2xx.dll' " while uploading but the code gets uploaded successfully. I am pasting the code below, can somebody tell me where i am doing it wrong? #include "Wire.h" #define Power_Register 0x2D #define BW_rate 0x2C #define Int_enable 0x2E #define dataFormat 0x31 #define X_Axis_Register_DATAX0 0x32 #define X_Axis_Register_DATAX1 0x33 #define Y_Axis_Register_DATAY0 0x34 #define Y_Axis_Register_DATAY1 0x35 #define Z
×
×
  • Create New...