Jump to content
43oh

Search the Community

Showing results for tags 'ENERGIA'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Sparkfun


Github

  1. Hello! I am compiling the following code through CCS 6.1.3, it is an imported sketch first then I add some thing else for it. But it seems It stuck in the setup function because it goes to LPM4 when it tries to use any USCI related function( For example: Wire.begin(),write to ()). Can some one help me with it? Thanks. The attach file is the ino file from energia 17 and the following is the Code? The uc is MSP430F5529, and it is trying to use I2C to communicate with ADXL345, UART to communicate with ESP8266. The reset is ADC stuff. And we have a button to do some control. Each of these par
  2. Hi all. Newb here. I just picked up (5) MSP-EXP430F5529LP's on a whim while placing an order for Arduino swag. MCM is blowing them out at $4 a piece so I figured I have nothing to lose and will enjoy the new experience. Of course, I'm running into issues. Most of the tutorials on Energia are for older versions and have a few different options. Anyway, I am just starting out with these boards and I believe I have downloaded and installed all necessary drivers and software. Energia sees the Launchpad and gives me the 2 com ports as it should. I open the "Blink" example sketch, click Upload,
  3. With Energia 1.6.10E18 installed on my MacBook Pro with MAC OS Sierra 10.12.1 and Sketch 'Blink' selected, the following compiler error occurs; No Java runtime present, requesting install. exit status 1 Error compiling board LaunchPad w/ msp432 EMT (48MHz) Installing JAVA SDK has no effect. Is it a possible driver error? Energia works fine under Windows 10. Why do I need the java sdk. Regards Jan
  4. Hello everyone, I'm doing a project using Tiva C 1294 and ESP8266 for wifi connection. I have done with connect Tiva C and ESP8266 via Serial. I also tested with AT commands of ESP8266. My goal is to connect the Tiva C 1294 with Internet through Wifi ( not Ethernet connected). I've tested sucessfully the Temboo applications via Ethernet connected. However, when I change to ESP8266, I meet a lot of stucks. ESP8266 is using AT commands to connect to Internet. Therefore, it totally different from CC3300 ( I dont' have chance to use it). Energia doesn't support ESP8266 library. Hence,
  5. Hi, I am trying to make a UART connection with a device from serial1 in MSP432. It isn't working as i cannot see anything printing on my serial monitor (I am trying to print the data stored in global variables using serial/USB). Wherein the same code works fine on MSP430 or TM4C1294 devices. I have double checked my wiring connections.. P3.2, P3.3 for RX, TX. Can anyone here help me resolve this issue or point out where im going wrong.. Please find the code below //----------------------------------------------------------------------------- // Microchip MCP39F501 Power Monitor
  6. I have a project using an MLX90614 that I have prototyped on an Arduino. Now I want to move to the CC3200 to add WiFi support. I've been fighting with the I2C for a few days now and could use some help. A few notes: The built-in I2C sensors (BMA222 and TMP006) work fine in the default configuration. The max speed for the MLX90614 is 100 KHz, but the default for the CC3200 is 400 KHz The MLX90614 is technically SMBus, but it works flawlessly with the Wire library on a standard Arduino. I have modified the Wire library in the hardware/cc3200 folder to call MAP_I2CMasterInitExpClk(I2C_BASE,
  7. Good morning, I'm using the latest Energia 18 build with Windows 10. I'm plugged into an MSP430 Launchpad with an MSP430G2553 chip on the board. The following code hangs on the Wire.endTransmission() statement.. Can somebody throw me a bone here and tell me how to fix this? int findAddress(int fromAddress, int toAddress) { int address = 0; for (int a = fromAddress; a < toAddress; a++) { Serial.print(a); Serial.print(" - beginTransmission.. "); Wire.beginTransmission(a); // delay(3); // Wire.write(1); Serial.print(" e
  8. Good morning. I've been using the MSP430 launchpad and programming it using Energia 18. Anyway, for the whole time I've been using Energia, it very often have to unplug and plug back in my device in order to send it another build. Have any of you seen this problem before? Sometimes it works without having to unplug the hardware, however, over 50% of the time, I have to unplug the LaunchPad in order to upload new code to it from Energia. It seems to get hung while attempting the upload. So, to overcome this, I unplug the Launchpad, click the Upload button again, usually get an
  9. I have the following error message when i try to upload the energia sketch onto my MSP432 device. fatal: CORTEX_M4_0: Error connecting to the target: (Error -1063 @ 0x0) Device ID is not recognized or is not supported by driver. Confirm device and debug probe configuration is correct, or update device driver. (Emulation package 6.0.14.5) My launchpad was working fine until before this. Any known solutions for this problem. Please advice
  10. Hi Guys, I have been trying to interface CC2500 with my G2 launchpad, i am unable to do so. i interfaced cc2500 with the default spi configuration given in the SPI library with Energia. P2.0 - CS (active low) P1.5 - SCLK P1.6 - MISO aka SOMI P1.7 - MOSI aka SIMO P19- GD0 GDO2 pin is hanging i found a library which i used to code, the code initially checks the value in the registers of cc2500 and serially prints it and matches it with the default values. i have attached the thumbnails of serial output. when my CS pin is connected i get "o" output for all reisters and when i leave it open i
  11. I am just getting started on my development using a custom PCB and may pin out on my board is a little different then the launchpad pin out so I need to change the H file. pins_energia.h I need to access p8.0 of the MSP430F5529 and of course this pin is not used on the Launchpad so I need to add it to the h file and use it in my code. Actually I cannot find this file in the downloaded energia software. Standard C requires h files to be declared or #included. Why is energia not using an #include statement in the example c file ( ie blink project) ? How can energia properly access
  12. Hello, I want to make a wireless thermometer using two microcontrollers. How do I write the code in Energia to transmit and receive a variable using a 433 Mhz RF module? Transmitter Setup: I have a TM4C123G connected to a RF transmitter using TX(3) pin 34 on the MCU. The TM4C123G is also connected to a LM34DZ Temp sensor. I need help to modify this working code to send the temperature variable using tx(3) pin 34 /*TM4C123G*/ //initializes/defines the output pin of the LM34 temperature sensor int outputpin= A11; // (pin # 2), use A11 analog input //---------------
  13. Hi, Previously I was using CC3200 launch pad for developing my module. But now I want to use GPIOs and control leds etc on launch pad. When using normally, I used digitalWrite(pinnumber,1); But now I want to control led etc using GPIO. How to accomplish that in Energia. I have seen peripheral library for cc3200 , but I am not able to use it. Kindly help asap.
  14. Where are the files related to compiler for arm cortex or tiva in energia in the latest version? It used to be under hardware/tools/lm4f/bin
  15. I would like to program MSP-EXP430G2 Launchpad from my Linux machine using energia. After installing energia-1.6.10E18, I am getting error message stating "cannot verify signature block file META-INF/BCKEY". Below are details for my setup:- OS: ubuntu 16.04 :::::::::::::: /etc/lsb-release :::::::::::::: DISTRIB_ID=Ubuntu DISTRIB_RELEASE=16.04 DISTRIB_CODENAME=xenial DISTRIB_DESCRIPTION="Ubuntu 16.04.1 LTS" :::::::::::::: /etc/os-release :::::::::::::: NAME="Ubuntu" VERSION="16.04.1 LTS (Xenial Xerus)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 16.04.1 LTS" VERSION_ID="16.04" HOME_
  16. Hello everybody, I would like to measure the speed rotation of a motor. For this, i use a photodiode. The signal waveform is given by the picture. I want to measure this signal frequency using the MSP430F5529 and Energia and display it in the serial monitor. I know i have to use the Timer A in Capture/Compare mode but I don't know how. I saw a lot of codes but they use CCS and the MSP430g2553 and it is not clear for me. How can I proceed to measure the frequency of my signal ? The frequency can vary from 50Hz to 500Hz. Thank you for your help.
  17. Hey all, I recently got a Nokia 5110 LCD working using the LCD_5110 lib from GitHub. Works great, so thanks to giants whose shoulders I stand atop! I moved my chip (G2553) directly to the board as I have done several times before (with a pullup resistor on RST), and I loaded a little demo program on it with my "loader" board (just TEST, RST, GND, and VCC hooked up to the emulation side of an LP). Program loads and runs fine, but when I remove the loader and cycled power (I was just changing battery sources from a 6V pack to a 9V battery -- they are dropped to 3.3V), the LCD does not i
  18. Hi, I want to use USR-C322. I want to use Energia to burn the code.I would like to know how to burn the code using JTAG and how to connect the SOP pins. Please refer:- http://energia.nu/cc3200guide/] I would like to know that while using CC3200 TI launchpad, a jumper used to be there from SOP2 and TCK_JTAG while coding with energia. Now how to use USR-C322 with Energia. I want to burn my code using Energia.
  19. Hi, As it seems to work on MSP430 device like MSP430F5529, I share it here too : http://forum.43oh.com/topic/9858-energia-library-wiznet-w5100w5200w5500/ Ethernet_Wiznet.zip
  20. Hi all, It was a real pain in the ass to find information about interfacing LP + Wiznet ethernet chip with energia so I'm here to share my work. I was looking for a library for ethernet chips from Wiznet (W5100,W5200,W5500) for TivaC series LP. The first problem I met was that as TM4C129 LP already has an ethernet.h library, I simply could not copy a new ethernet.h library for non-ethernet Ethernet_Wiznet.zip
  21. Hello, I am using example code of energia Pfatfs library named "PFatFsfileTest". This program reads "T_READ.txt" file from sd card properly. But It can't write string "Hello world" 10 times to the file "T_WRITE.txt" into sd card. Instead, it just writes only "H". I am posting the original code of file below: /*----------------------------------------------------------------------*/ /* Petit FatFs sample project for generic uC (C)ChaN, 2010 */ /*----------------------------------------------------------------------*/ /* ported to Energia */ /* copy the two files t_read.t
  22. I have modified the code and now the zero crossing interrupt is occurring.But the timer is still not functioning.Can anyone see and tell whether I have configured it right? #include "inc/hw_ints.h" #include "inc/hw_memmap.h" #include "inc/hw_timer.h" #include "inc/hw_types.h" #include "debug.h" #include "interrupt.h" #include "timer.h" #include "driverlib/prcm.h" #include "inc/hw_gprcm.h" #include "wiring_private.h" #include "driverlib/rom_map.h" #include "driverlib/pin.h" void setup() { pinMode(2,INPUT_PULLUP); pinMode(4,OUTPUT); noInterrupts(); MAP_PRCMPeripheralClkEnable(PRCM_TIMERA0,PRCM
  23. Hi , I am unable to use the Timers of CC3200 on Energia. Kindly view my code snippet and see what errors have I made.I am getting the errors which I have mentioned at the last. CODE:- #include <driverlib/timer.h> #include <inc/hw_timer.h> void setup() { pinMode(2,INPUT_PULLUP); pinMode(9,OUTPUT); noInterrupts(); TimerIntStatus(TIMERA0_BASE,true); TimerDisable(TIMERA0_BASE,TIMER_A); TimerIntDisable(TIMERA0_BASE,TIMER_TIMA_MATCH); TimerConfigure(TIMERA0_BASE,TIMER_CFG_A_PERIODIC_UP); TimerPrescaleSet(TIMERA0_BASE,TIMER_A,32); TimerMatchSet(TIMERA0_BASE,TIMER_A,7500); TimerInt
  24. Hello everyone; As you can see bitshifting a byte 16 bits and storing in a long doesn't seem to work, while shifting storing and shifting again works perfectly. Is this behaviour normal? Using energia 0101e0017 on win7 with msp430g2553 launchpad. Also i'm not 100% sure but i think bitshifting 16 bits worked fine on a tm4c123gxl launchpad because i ran into this while converting a code that was written for tm4c to msp.
×
×
  • Create New...