Jump to content

Maddox675

Members
  • Content Count

    2
  • Joined

  • Last visited

Everything posted by Maddox675

  1. With some schematic tracing and launchpad pin correlation, here is what I found: nrf24l01 nrf24l01 430G2 Stellaris boosterpack Signal Launchpad Launchpad Pin 7 SCLK P1.5 SCK(2) Pin 8 CE P2.0 PA_5 Pin 9 CSN P2.1 PA_6 Pin 10 IRQ P2.2 PA_7 Pin 14 MISO P1.6 MISO(2) Pin 15 MOSI P1.7 MOSI(2) SPI(2) is the default SPI on the Stellaris so I modified the sketch to add the following: // Add Stellaris Pin mapping #define P2_0 PA_5 // CE #define P2_1 PA_6 // CSN #define P2_2 PA_7 // IRG Now the Sketch compiles...next, see if it all works!
  2. This seems like it must be a simple "problem," but I can't figure it out. I have a Stellaris launchpad, the NRF24L01+ boosterpack board that I have added the radios to, I only have the single row of headers on the boosterpack (like the original 430G2 launchpad), and have downloaded the energia Enrf24 library. The stellaris passes all the blink tests with energia, so I loaded up the txdemo, imported the Enrf24 library, and hit upload and got the following: Enrf24_TXdemo.ino:9:14: error: 'P2_0' was not declared in this scope Enrf24_TXdemo.ino:9:20: error: 'P2_1' was not declared in this scope Enrf24_TXdemo.ino:9:26: error: 'P2_2' was not declared in this scope Must be this line that is bombing: Enrf24 radio(P2_0, P2_1, P2_2); // P2.0=CE, P2.1=CSN, P2.2=IRQ I'm guessing I somehow need to define the Stellaris pins...any hints? Apologies if this is not the right thread to post to. Thanks in advance.
×
×
  • Create New...