Jump to content

andimmike15

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. andimmike15

    [POTM] dAISy - A Simple AIS Receiver

    hello @chicken. I have given up about using PIC. Now i move back to MSP430. But, there is some errors again. I didnt receive anything. I actually use my own AIS transponder. I live far away from ocean so I use my own transponder. I start to think if I can generate a dummy AIS signal through si4362 because I am not so sure where is the problem. Do you think it is possible to generate dummy AIS signal to si4362?
  2. andimmike15

    [POTM] dAISy - A Simple AIS Receiver

    thank you @chicken i encountered a problem. In PIC16f877a, the data bank memory only 96 byte. but in your fifo.c, you set the fifo array buffer for 128 byte and and 256 byte with fifo packet 8 byte. I have looked for the AIS signal and it only consist of 256 bit or 32 byte. Is it possible to use PIC16f877a with only 96 byte to fifo buffer? thank you once again.
  3. andimmike15

    [POTM] dAISy - A Simple AIS Receiver

    Thank you @chicken Actually, my msp430G2553 was broken somehow. But, I have some PIC16F877A in my home. I was wondering if I can use PIC16F877A instead of msp430G2553. What do you think? Is it feasible to use PIC16F877A with si4362 as AIS receiver? I believe converting msp430 code to PIC16F code isnt a big deal.
  4. andimmike15

    [POTM] dAISy - A Simple AIS Receiver

    @chicken Thank you so much for answering my questions. I am really new in this field (embedded programming) but I have done couple programming tasks in Pascal and C/C++. Just want to make things clear, So Debug_Messages and Test_Mode only works for CCS IDE? If I remove #define Debug_Messages and #define Test_Mode, can your dAISy still run?
  5. andimmike15

    [POTM] dAISy - A Simple AIS Receiver

    hello @chicken. I really like your work in here. You have done such an amazing thing by building dAISy from scratch. I am new in MSP430. I would like to ask you more about your source code. In main.c, you wrote ifdef DEBUG_MESSAGES and ifdef TEST. How do you run DEBUG_MESSAGES and TEST? How is it activated? Do you use CCS to activate DEBUG_MESSAGES and TEST? Really aprreaciate your help.
×