Jump to content

FredinMcKinney

Members
  • Content Count

    3
  • Joined

  • Last visited

About FredinMcKinney

  • Rank
    Noob Class

Profile Information

  • Location
    McKinney, Texas

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. FredinMcKinney

    Serial Monitor/Serial.print() issue

    I am also having a problem in getting the serial monitor to work. I had no problem on a MSP-EXP430G2 platform but the board quit working. I purchased a new MSP-EXP430G2ET board to replace the old one. I have no problem downloading a program but the serial monitor refuses to work. Looking at the TXD pin with a scope I can see a good signal being produced. On the jumpers, the same signal shows up on the RXD pin which I don't understand. A simple program using the onboard switch to turn on the onboard LED with a Serial.println embedded in the loop turns on the LED just fine but the Serial.println command does not produce any external results (but it does show up on the scope). I have played with different (besides 9800) baud rates with no success. I have been writing code for this application for 3 or 4 years and never had the problem in the past--only with the ET board. Any help would be greatly appreciated. Also tried everything in the troubleshooting section. Windows7, Energia18, 2553 chip, Thanks, Fred
  2. FredinMcKinney

    Serial Port Problem

    I have an interesting problem that has been popping up over the last several months. I am presently using a MSP-EXP430G22553 Rev 1.5. I am running Energia 17. Every so often when I load a program into the editor, the serial port option on the tools menu will be grayed out. I am able to download the program into the board and the program will run but I am unable to open the serial port window. I am running Windows 7 and if I look at the ports in device manager, it show port 66 being assigned to the TI board. This problem will continue for several days and then suddenly it will start to work again. No matter what program I load, the problem will persist. Any thoughts would certainly be appreciated.
  3. FredinMcKinney

    Serial Port Problem

    I have an interesting problem that has been popping up over the last several months. I am presently using a NSP-EXP430G22553 Rev 1.5. I am running Energia 17. Every so often when I load a program into the editor, the serial port option on the tools menu will be grayed out. I am able to download the program into the board and the program will run but I am unable to open the serial port window. I am running Windows 7 and if I look at the ports in device manager, it show port 66 being assigned to the TI board. This problem will continue for several days and then suddenly it will start to work again. No matter what program I load, the problem will persist. Any thoughts would certainly be appreciated.
×