Jump to content

litos97

Members
  • Content Count

    7
  • Joined

  • Last visited

  1. litos97

    How set max power 14 dBm on CC1350 Launchpad

    Hi there, Nobody knows how to setup 14 dBm for CC1350 Launchpad with Energia ?? How can I change that register with any command to compiler or any function ?? Thank´s a lot. Litos97
  2. litos97

    How set max power 14 dBm on CC1350 Launchpad

    Thank´s spirilis. I tried to import Energia sketch in CCS and put a define line in predefine option. All compilation ok, the communication works between launchpads but not at full power. I need max power because I would like to install the launchpad on a rotative big machine and sends the Temperature to an electrical cabinet, and I´m not sure if it will work with less power than 14 dBm. Any help will be appreciated. Litos97
  3. Hi there, I´m testing radio range with two new CC1350 Launchpad Rev. 1.1 on Windows 7 64bits. When I try with SmartRF Studio V2.6.0 with 625 bps, Legacy Long Range mode the communication has good range. I transmit with a 12 dBm and I receive 12 dBm in the other Launchpad at 1 meter between both ( on my desk). When I do the similar test with Energia EasyLink Tx - Rx example, I changed to " myLink.begin(EasyLink_Phy_625bpsLrm); ", I received a poor signal (rxPacket.rssi = -70) with the same Launchpad at the same distance. I´ve tried to save smartrf_settings.c and .h from SmartRf Studio to my Energia path, but I haven't notice any difference. My Energia path is: C:\energia_1_6_10E18\libraries\EasyLink-master\src\smartrf_settings\CC1350_LAUNCHXL Somebody knows how to improve range with Energia as same as SmartRF Studio ? Thank´s in advance. Litos97
  4. litos97

    How set max power 14 dBm on CC1350 Launchpad

    Thank you very much for your information spirilis. But I checked that there isn´t any change from 12 dBm to 14 dBm in my scketch, always I have the same rssi value at received side. This is because I think I do something wrong. I checked with SmartRf Studio at 14 dBm and I have better rssi value. Is it correct the path of ccfg.c that I must modify ?? Path: C:\Users\litos97\AppData\Local\Energia15\packages\energia\hardware\cc13xx\4.9.0\system\source\ti\devices\cc13x0\startup_files Must I modify other file or only ccfg.c and compile Energia sketch ?? Thank´s a lot. Litos97
  5. Hi there, I was looking for at this forum about how can I increase the transmit power on Launchpad C1350 to 14 dBm, but I didn't find any complete solution. I read about de ccfg.c file, I edited that file and deleted comment in red line (see below): Path: C:\Users\litos97\AppData\Local\Energia15\packages\energia\hardware\cc13xx\4.9.0\system\source\ti\devices\cc13x0\startup_files //##################################### // Force VDDR high setting (Higher output power but also higher power consumption) //##################################### #ifndef CCFG_FORCE_VDDR_HH //#define CCFG_FORCE_VDDR_HH 0x0 // Use default VDDR trim #define CCFG_FORCE_VDDR_HH 0x1 // Force VDDR voltage to the factory HH setting (FCFG1..VDDR_TRIM_HH) #endif Now in my sketch I change the power to 14 dBm: // begin defaults to EasyLink_Phy_50kbps2gfsk myLink.begin(EasyLink_Phy_625bpsLrm); EasyLink_setRfPwr(14); delay(1000); After that I check the power: #ifdef DEBUG Serial.println(myLink.version()); Serial.print ("Potencia TX (dBm) : "); Serial.println(EasyLink_getRfPwr()); #endif But nothing change, I always is 12 dBm. If I decrease the power to 10 dBm for example, getRFPwr() shows the correct information 10 dBm. Can you help with this, please ?? Thank´s in advance. Litos97
  6. litos97

    REALLY? main() not found ? MSP432 Launchpad

    Thank you dubnet. I´ve tried to short the paths and delete some blank spaces and so, but it doesn't work. I´ve attached a screenshot where you can see the compilation error log window. My project path now is C:\energia_1_6_10E18\MGG\ Thank´s a lot. Litos97
  7. litos97

    REALLY? main() not found ? MSP432 Launchpad

    Hi there, I´m having the same problem, with Energia 1.6.10E18 an my launchpad CC1350. I´m working with Windows 7 VM over Mac OS X Sierra. This happens when I start Engergía the first time. To solve the problem I comment the 70 - 80 % of code and then the compilation is OK. After that I remove the comments (/* ...*/) and all is ok again. Now I can make changes for all day and no error. How can I solve this issue ?? Thank´s a lot. Litos 97
×