Jump to content
43oh

gr8going

Members
  • Content Count

    20
  • Joined

  • Last visited

Everything posted by gr8going

  1. Hi 430h Energia Experts I'm using Energia along with cc3200, i feel using energia is simple and straight since I'm not a "c" expert. I understand that cc3200 has two UART ports (uart0 and uart1) uart0 is in GPIO P01 and P02 - when Jumper J6 and J7 are connected uart1 is in GPIO P57 and P55 - when Jumper J6 and J7 are NOT connected While working on a project with cc3200 I used P01 & P02 as UART1 (Jumper J6 and J7 are connected) to communicate to device1 and now I would like to add another UART based device for which I would like to use UART0 without disturbing UAR
  2. Hi Experts I'm using cc3200 MOD and currently using GPIO pin "P01 and P02" as UART modul I know cc3200 has two UART modules - one can be from P01andP02 and other is from P55 and P57. I have a requirement whare I need to retain UART0 and URAT1 for two different use case - one fore display and other to transmit data. I'm using Energia for coding and new to this pinmux etc., Question: from where I need to do the configuration? Should I need to update my INO file? if so with what? can you please help! appreciate your time. Regards,
  3. Hi Andy I'm referring to this post which I recently updated seeking for some guidance. I'm using cc3200 LP and now facing conflict between UART1 (Serial1) Vs I2C where default ports mentioned are 9 and 10 (P01 and P02) for both!! can we have I2C configured or multiplexed to some other GPIO ports? if so how? Thanks!
  4. BTW, I just referred this topic. Hope multiplexing is possible shall try and let you know.. All what I need to do is either #1) Move the Serilal1 (UART1) to other GPIO pin (say 56, 57) and retain default I2C pin as 9 & 10. #2) Move the I2C from 9 or 10 to some other GPIO and retain UART2 as is... any other suggestions!!
  5. I agree! Since I dont have logic analyszer.. I'm forced to do trial and error After many trials finally I got work around .. so now my circuit looks like CC3200 -> UART1 (Serial1) -> TTL/232 -> 232/485 -> external device which has RS485 Where Serial1 = P01 and P02 But I was expecting to have below connection which did not work CC3200 -> UART (Serial) -> TTL/232 -> 232/485 -> external device which has RS485 Where Serial = P03 and P04 Any ways .. thanks for reading and suggestion! Love this forum !
  6. This is what I did and working for I2C... and the same pin is what I'm using for Serial1 (UART communication) also so there is a conflict. Is it possible to do multiplexing between I2C and UART1 (serial1) which has same pin 9 and 10 ??
  7. Hi FmilBurn, Thanks for your reply... From the Note: "...Note: the lighter colors indicate no connects..." Does it mean in cc3200 LP we just have only one I2C ?? that is conflicting with UART1 (Serial1) ?? is it possible for me to do multiplexing?? please help, both Serial communication and I2C interface are important for my project Regards,
  8. Case 3 cc3200 with simple Serial1.print "A & 8" flashed ==> through converter TTL/232 => 232/485 converter => USB/485 converter ==> Laptop/Tera Term (COM port console) :: Result Failure Update>> The above did not work (may be) the USB/485 converter is bad or I was missing something ... But when I modified above conversions as below through converter TTL/232 => 232/USB converter => Laptop/Tera Term (COM port console) :: Result PASS I used Serila1 which is P01 and P02 in CC3200 LP Till today I'm still NOT clear why other serial (say TX(0) or RX
  9. Hi I'm using external RTC which has DS1307 where it communicates to my cc3200 using (SDA and SCL) I2C. Please note as oer block diagram there are two I2C interface available in cc3200 LP I'm using RTC lib specified for ds1307 from here Option #1: when I connect my RTC module to Pin P01 and P02 (SCL and SDA) as detailed in CC3200 block diagram I see valid clock/time in my COM port Option #2: Now, When I try the with other I2C port in P4 40 and 39 (top two pins) I'm not seeing any clock/timer value Please help me to understand what might be the reason? why one I2C interface works w
  10. Hi Can some one help me to understand what is the pin number for Serial. port when used in BP (non-flash mode) The doc says it's P03 (Tx ) and P04 (Rx) but looks like the value are showing always ZERO BTW, I tried with Serial1. and it works perfectly for the same sketch. My Sketch
  11. Hey folks.. can you please check this topic and suggested what i'm missing
  12. This is in continuation with this post where I was working with two cc3200 one for transmit second for receive so my Energia code as described in other posted was /* Serial Transmit:*/ and for receive Please note: TX pin (P01) in transmit CC3200 is connected to RX pin (P02) of receiver CC3200 PS: P01 == P1-10 P02 == P1-9 The above is working fine and could see character "c" printed in console Now... when I change the Transmitter code as below where I have replaced "serial1" with "Serial" as shown below ... I'm NOT see any results - what is th
  13. Lovely! Catch is #1) Baud Rate .. for Serial > Serial1 #2) Baud Rate for Serial1 in Transmitter == Serial1 in Receiver Also, while sampling on computer com port make sure we set Receiver Serial baud rate (NOT Serial1) I've tried this with TWO CC3200 and Screen shot attached! please watch out for #1) baud rate in COM port console #2) and TX pin (P01) in transmit CC3200 is connected to RX pin (P02) of receiver CC3200 PS: P01 == P1-10 P02 == P1-9
  14. Thanks .. Will update once I figure out what's going wrong ... For now all parameter(s) like baud rate, connections (Tx to Rx and Rx to Tx etc.,) looks okay... BTW, I changed my HardwareSerial.cpp lines to MAP_UARTConfigSetExpClk(UART_BASE, 80000000, baudRate, (UART_CONFIG_PAR_EVEN | UART_CONFIG_STOP_ONE | UART_CONFIG_WLEN_8)); And it's working under EVEN parity now... Regards, Ranga
  15. Hi Adrian Thanks a lot for your reply. I'll surly use your suggestion of changing the UART_CONFIG_PAR_NONE to UART_CONFIG_PAR_EVEN. Yes as you said, I used USB/485 adaptor and learnt that I should be using 485 library on top of HardwareSerial.cpp which creates a wrapper to generate protocol packets and planned to read from external device to my cc3200. My External Device (slave) : that has RS485 o/p from which we can tap the register values and it works on ModBus protocol. cc3200 (master): using UART (TX and RX) com port.. Using Energia for flashing. Now, before deep diving
  16. Thanks Admin! I've started a new here
  17. Hi experts!! I'm a beginner and working on CC3200 LP along with Energia IDE. I'm working on a simple project where I've an external device which has RS485 o/p and I need to fetch the values in specified addr location in that device to CC3200 LP. My doubts are #1) we have external module that has device ID+parameter Address and we need to transmit the value in LP through UART, here I'm not sure how to use the UART function to specifically target device+address and return/get the same.... #2) what I'm looking/exploring is that in above example (UART code which Andy shared here
  18. Hi experts!! I'm a beginner and working on CC3200 LP along with Energia IDE. I'm working on a simple project where I've an external device which has RS485 o/p and I need to fetch the values in specified addr location in that device to CC3200 LP. My doubts are #1) we have external module that has device ID+parameter Address and we need to transmit the value in LP through UART, here I'm not sure how to use the UART function to specifically target device+address and return/get the same.... #2) what I'm looking/exploring is that in above example (UART code which Andy shared ) what funct
×
×
  • Create New...