Jump to content
43oh

zico

Members
  • Content Count

    8
  • Joined

  • Last visited

  • Days Won

    1
  1. Hello, We have a student lab with over 30 PC's running Windows 7 64 bit and we are using the MSP 432 boards. Energia 18 installs and runs fine, but because only the MSP 430 is installed as default, every user has to install the MSP 432 every time that they login due to a new profile being created. This adds an extra two minutes every time a student needs to use this combination of PC & MSP 432 board (Tools->Board->Board Manager). Is there a way that I can add the MSP 432 as a permanent default for my setup, to eliminate the need for this installation every time. Thanks,
  2. Hi @@Fmilburn, Thanks, I changed the pins_energia.h file and everything is working perfectly now. Thanks also for the link to the Launchpad pin map guide ... all makes sense now! Thanks again, Regards, Z.
  3. Hello, I am Using Energia 17 on TI MSP432 (Windows 7 PC): analogRead works for all the Analog pins except for A9. Initially, I thought that I must have just damaged the Analog port, but I have since tried this on numerous boards and they are all the same. Basically A9 is tied to A8, so whatever A8 is reading can also be read through A9. When I check the pins.h file, both A8 & A9 are mapped to "27", but I don't know what this "27" refers to or what the correct number should be for A9. If anyone knows how to find out the correct pin to use and how to modify it, please let me know.
  4. That's perfect, I've updated the drivers and everything is working now. Thanks for all the help.
  5. Hello, this seems to have been fixed by using the CCS Cloud and following the above instructions, i.e. clicking the update button: Once the update is is finished, Energia 17 works fine. We have over 100 of these TI 432 boards that we are going to use in a project lab. Will I need to do this update on each board?? CS_DAP_0: Error connecting to the target: (Error -1040 @ 0x0) A firmware update is required for the debug probe. Click the "Update" button to update the firmware and connect to the debug target. DO NOT UNPLUG THE DEBUG PROBE DURING THE UPDATE. (Emulation package 6.0.14
  6. Hello, thanks for reply. Below is the error message I get when I try to upload: C:\energia-0101E0017-windows\energia-0101E0017\tools\common\DSLite\common\targetdb\Modules\MSP432\MSP432_JSTATE_2_NotVisible.xml Initializing: CS_DAP_0 Mapping registers: CS_DAP_0 - Core Registers Mapping registers: CS_DAP_0 - Hidden Building search data: CS_DAP_0 Executing Startup Scripts: CS_DAP_0 Initializing: CORTEX_M4_0 Mapping registers: CORTEX_M4_0 - Core Registers Mapping registers: CORTEX_M4_0 - ADC14 Mapping registers: CORTEX_M4_0 - AES256 Mapping registers: CORTEX_M4_0 - CAPTIO0 Mapping registers: C
  7. Sorry, forgot to mention it's Windows 7 64 bit.
  8. Hello, I have been using Energia 16 for the last few weeks with everything working perfectly. Today I downloaded Energia 17, but it won't upload to Ti 432. I have installed the drivers and Energia 16 still works perfectly. I have tried it on two PC's with the same result. The software freezes at the upload stage ... see message below: Thanks, Zico. Binary sketch size: 26351 bytes (of a 262144 byte maximum) >>>> Done <<<< xcopy C:\energia\energia-0101E0017\hardware\emt\ti\runtime\wiring\msp432\configPkg\package\cfg\energia_*.rov.xs . /Y C:\energia\energia-0
×
×
  • Create New...