Jump to content

mahmoud899

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. mahmoud899

    Stellaris interfacing with LCD

    Hello, I have a Stellaris Launchpad LM4F120XL Board and I am trying to interface with an 16x2 LCD. My LCD requires 5V and my Stellaris Launchpad has 3.3V output power pin. I have 2 questions, 1) Would it be alright if I connected the LCD to an external 5V supply and connected the data pins (D0-D7) to the Stellaris Launchpad GPIOs or do I have to have an LCD that operates on 3.3V supply? 2) Will it work if I connected the LCD to the 3.3V output power pin of the Stellaris Launchpad and connected the data pins (D0-D7) to the Stellaris Launchpad GPIOs ? Thank You
  2. mahmoud899

    Delay Calculation

    Hello, I have a Stellaris Launchpad LM4F120XL, I am having troubles calculating delays. I set the System Clock to 20MHz with the following code "SysCtlClockSet(SYSCTL_SYSDIV_10 | SYSCTL_USE_PLL | SYSCTL_XTAL_16MHZ | SYSCTL_OSC_MAIN);". Now I want a 1 second delay, what is the formula I use to be able to calculate the correct number to pass as a parameter to the SysCtlDelay() function so it can give me a 1 seccond delay. Thank You
  3. Hello, I am having trouble building and compiling a new project in the Code Composer Studio v6. I have a Stellaris Launchpad EK-LM4F120XL. I downloaded the Stellarisware and the Code Composer Studio v6 on my C Drive. I followed the instructions in this link "http://processors.wiki.ti.com/index.php/Creating_new_CCS_v5_Project_with_Stellarisware" ?and I get errors when I try to builld my project. This is the Error Description Resource Path Location Type #20 identifier "tBoolean" is undefined .ccsproject /test_app_01 line 583, external location: C:\StellarisWare\driverlib\sysctl.h C/C++ Problem Any suggestions on how to solve my problem Thank You
×