Jump to content
43oh

Greenworld

Members
  • Content Count

    15
  • Joined

  • Last visited

Posts posted by Greenworld

  1. Hi everyone,

    I use the following function to compute the angle from accelerometer:

    float a =atan2f(-0.143798828, -0.680053711);

    But it can not return a proper result (a huge number ~10^22).

    How I can compute the angle directly on the chip. (I used CCS IDE).

    Thanks!

  2. Hi buddy,

    I have a trouble, on both Stellaris and Tiva Lanchpad, PD0 and PB6 are joined through R9 0ohm resistor and PD1 and PB7 are joined through R10 0ohm resistor. Why is supplier do that ?. If I unsolder R9 and R10, will I face with any problems ?

    Some case, PD0, PB6 not work properly because two resistors.

    Thanks everyone!

  3. Hi everybody,

    I have tried to use  ADC1 (ADC1_BASE, 2) to read analog signal, but no more affection. I change it to ADC0 (ADC0_BASE, 2), it have done perfectly. My programe only have ADC reading. I have test many time. What I can do to use ADC1 ?

    Please help me to solve it.

    Thanks !

     

  4. I wanna implement I2C communication, when I write data, it can not exit the following command:

    while(I2CMasterBusy)

    {

    }

    How I can solve my problem.

    Thanks in advanced!

  5. Hi everybody,

    I now that BBB have six pwm channel, includes: PWM 0A, 0B;1A,1B;2A,2B

    I have enable all six channel ( write to slots), but it only have three channel with full file ( duty, period, polarity) and another are have not this file. (I have attached these file)

    Please give me the answer for my problem.

    Much appreciate !

     

    post-367-14264691162259_thumb.jpg

    post-367-14264691162328_thumb.jpg

  6. Hi everybody,

    I have a bug, please help me to solve it

    When I enable this module and access to this path/sys/devices/ocp.3/48304000.epwmss/48304180.eqep#
    when I use 'ls' command, I only get :modalias  power  subsystem  uevent
    It's not display as normal(tutorial):driver  enabled  modalias  mode  period  position  power  subsystem  uevent
    I hope anyone give me a recommend to complete my project,Please.
    Much Appreciated!
  7. 
    

    Hi everybody,

    I have a bug, please help me to solve it.

    When I enable this module and access to this path

     

    /sys/devices/ocp.3/48304000.epwmss/48304180.eqep#

    
    

    when I use 'ls' command, I only get :

     

    modalias power subsystem uevent

    
    

    It's not display as normal(tutorial):

     

    driver enabled modalias mode period position power subsystem uevent

    
    

    I hope anyone give me a recommend to complete my project,Please.

     

    
    

    Much Appreciated!

     

×
×
  • Create New...