Jump to content
43oh

help950

Members
  • Content Count

    3
  • Joined

  • Last visited

  1. help950

    I2C Issue

    Hi, I'm using the latest Code Composer Studio (v5.5.0.0007), with the stellaris board, having an issue with the I2C. I'm trying to write to an EEPROM chip. I have succeeded in writing to address 0x0000 and 0x0001, and reading the same addresses (2-byte Addressing). (EEPROM = 24AA64). With the same api, trying to talk to any other register within the EEPROM, I fail to write, but believe I succeed in reading (returns 0xFF, not 0- which would indicate ACK error). Stepping through the program I notice that the data register on some iterations is never changed. E.g. I2C_MDR will stick at wh
  2. Hey, I'm using the LM4F120H5QR, with CCS. I've encountered the same error as you describe above 'Description Resource Path Location Type #20 identifier "GPIO_PA1_U0TX" is undefined main.c /SecondUartTest line 101 C/C++ Problem' I've added the following to the Predefined Symbols tab: 'PART_LM4F120H5QR', 'TARGET_IS_BLIZZARD_RA1' (tried RB1 as well) I am still getting the error. I've tried using energia and I can get the other UARTs to work. I've also tried looking through the include files for a reference to GPIO_PA1_U0TX, as I guess this is just a memory location, but I can't find it
  3. help950

    ButtonsPoll()

    Hi, I'm having a lot of issues trying to get the ButtonsPoll() function working as recommended at the end of tutorial 3 from TI. I've done the first 3 lab instruction videos, followed the guidance on http://unboxnbeyond.wordpress.com/2013/04/14/using-button-h-for-inbuilt-buttons/#more-166, and also followed the guidance on a previous topic: http://forum.stellarisiti.com/topic/577-polling-a-switch/ . I think I've managed to set the include options to the right place, they are identical to the first link, same with the file search paths, and set the macros ( compliler|advanced options|predefined
×
×
  • Create New...