Jump to content
43oh

PaoloIT

Members
  • Content Count

    15
  • Joined

  • Last visited

Everything posted by PaoloIT

  1. My application never freeze from my last fix. I tried with a netgear and tplink router and a lot of brand of WiFi repeater
  2. Hello everybody, I need to use WDT to hardware reset CC3200. I tried to include driverlib/wdt.h in energy.h but when I try to use some WDT function, like WatchdogRunning, the CC3200 go to freeze... If I comment the code in the function and leave only "return 1;" the system freeze the same... Can you help me?
  3. i used this command unsigned char str[32] = "home.net"; unsigned char len = strlen((const char *)str); sl_NetAppSet(SL_NET_APP_DEVICE_CONFIG_ID, NETAPP_SET_GET_DEV_CONF_OPT_DOMAIN_NAME,len, (unsigned char*)str);
  4. Hello everybody, I seen that the POST data are put after the header of html response. If you read more than 50 bytes after '/r' you will find the POST data
  5. I used my fix ( how said nitred put inside wifi.cpp) and work fine. Never freeze or crash... AP to STA and viceversa work very well
  6. This is my received buffer: new client POST / HTTP/1.1 Host: 192.168.0.10 Content-Type: application/x-www-form-urlencoded Origin: http://192.168.0.10 Content-Length: 10 Connection: keep-alive Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8 User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/600.2.5 (KHTML, like Gecko) Version/8.0.2 Safari/600.2.5 Referer: http://192.168.0.10/ Accept-Language: it-it Accept-Encoding: gzip, deflate The Content-Length change with the text input but I can't find it!
  7. Hello, I created a webserver on cc3200 with GET method, some text parameters and one submit button.. Everything work fine with GET method but there is a problem that the browser save the url with parameters and the parameters are present in url so everybody can see the value. To avoid this I tried to use POST method in form and submit but in the receive buffer I have only "POST" message and nothing else.... How can I use a POST to my webserver and read a value of parameters?
  8. Work fine thank's. I've another question, I changed the url name to "myname.net" This work when the application is in AP mode but no when change to STA mode. To open the webserver I need to write the IP assigned from router... Is it possible to use the url also in STA ?
  9. Hello, I've a problem with the default mysimplelink.net web page of CC3200 launchpad. How can i delete it? I tried to format my flash with uniflash but when my system connect to my router, if write mysimplelink.net on my web browser the mysimplelink page is loaded..... I hate it !!!!!
  10. My system , after some firmware upgrades, started to freeze... To resolve I formatted the flash with Uniflash and after I uploaded firmware with Energia IDE and everything work fine... I think that the code in flash is not deleted right and after some upload start to create problems...
  11. Hello guys, I tested my fix and work fine.... I tryed AP->STA, STA->AP->STA and everything work fine. this is the fix in wifi.cpp file in /hardware/CC3200/Libraries/WIFI. I added role = ROLE_STA; int WiFiClass::begin(char* ssid, char *passphrase) { // // If we already called begin and are already connecting // then return the status. This prevents sl_WlanConnect() // from being called repeatedly. // if(_connecting) { delay(500); return status(); } role=ROLE_STA; // // Set IP address configuration t
  12. Hello, Sorry for delay. I'll post this night (night in italy!).
  13. SOLVED!!! As soon as I will post the solution. The problem is in the library
  14. Hello, I've the same problem. If I start in STA mode all work fine, with start AP and after STA mode nothing to do....
×
×
  • Create New...