Jump to content
43oh

AlexH

Members
  • Content Count

    7
  • Joined

  • Last visited

Everything posted by AlexH

  1. I'm a n00b too, but try this... Make sure you've done the "Adding Include Path" in that tutorial. Then make sure you've also got... #include <stdbool.h> Does that help?
  2. @altineller Any updates on when/where you code will be posted? I'm currently working on a project and have been looking around for libraries to use on my Tiva C Eval board and Sensor Hub BoosterPack setup and it looks like you tested your ported code on the exact same setup successfully. Thanks!
  3. You are awesome! I took a break from this project over winter break since I've been trying to figure out this issue for over a month and just got plain tired of it. Came back at it and took a look at what you had suggested. I found those shunts you were talking about. I did not see that at all in the datasheet. Today, I hooked up both the Sensor Board and the SD card (using SSI 1). I had to fiddle with my code for a few minutes, but I got it to work! After months of researching and experimenting with the wiring, it finally works. Thank you so much, @@igor. You saved this project.
  4. A last resort option I thought of would be to pick up a cheap PICAXE 20X2 or something and use it as an I2C slave device to control the SD car module. I'd rather not do that if I don't have to. I really want to use a local SSI bus on the Tiva C.
  5. Thanks for the reply. And, yes, the whole first half of my post was explaining that the SD card does work perfectly without the BoosterPack. When I add the sensor hub and use some code (which I've already verified that it works on its own) to get a pressure reading via I2C, both the sensor and the SD card initialize, but then there's always an error getting a reading from the sensor, which I attribute to both SD card and sensor being on the same physical pins. Since I need the sensor hub, I'm trying to move the SD card pins. I was going off of page 4 of the Sensor Hub BoosterPack guide
  6. Hi all, I have a question that's directed a little more towards the hardware side of interfacing my TM4C123G launchpad with my SD card module using this library. If anyone has any thoughts or ideas, please let me know here: http://forum.stellarisiti.com/topic/2205-help-with-sd-card-module-on-tm4c123gxl/ Thanks so much.
  7. Hello, I have a question regarding communication between my Tiva C EK-TM4C123GXL lauchpad and a generic SD Card breakout board. Using: Energia 0101E0013 Windows 8.1 SD Library (SD_TM4C) 4 GB FujiFilm SD card I CAN get the ReadWrite demo program in the SD library to work sucessfully by wiring everything up according to the 1-page pinout diagram that came with my board for the SPI bus. Hardware wiring (SD breakout --> Launchpad): SDCS --> J2.9 / PA3 / 12 MOSI --> J2.6 / PB7 / 15 SCK --> J1.7 / PB4 / 7 MISO --> J2.7 / PB6 / 14 And th
×
×
  • Create New...