Jump to content

jing

Members
  • Content Count

    6
  • Joined

  • Last visited

About jing

  • Rank
    Noob Class

Profile Information

  • Location
    United States
  1. It's all cleaned up and works great. Let me know if you have any trouble with it. Upstream homebrew did not accept the toolchain for inclusion, it'll continue to live in my tap at 8bitsofme/homebrew-msp430.
  2. If I just ask newlib to install-target-newlib and install-target-libgloss everything seems to work ok. Now i'm just polishing some Homebrew specific quirks.
  3. With your alterations everything compiles fine, but when make installing newlib I get an error on what looks like building a directory. I can ignore it and everything else finishes happily. I'd love to get that fixed. It seems to happen somewhere in install-target-newlib. Any ideas on how to track the error down?
  4. Sweet, thanks. Can you help me understand why you build newlib outside of gcc? Also, how did you come to those configure flags? Your scripts look like the ones found here: http://www.mail-archive.com/mspgcc-users@lists.sourceforge.net/msg12028.html
  5. I've been working on some homebrew formulas for using gcc 4.9 with the msp430. I've got some preliminary builds working (though I haven't had the chance to upload code to a board yet). They're available via my tap '8bitsofme/homebrew-msp430'. I've been running into this issue where the 'make install' step fails, but if I repeat 'make install' everything seems to work out fine. I'm new to cross compiling. If anyone can guide me I'd love to fix this issue and try to get these formulas published in mainline homebrew. https://github.com/8bitsofme/homebrew-msp430
  6. jing

    Hey there

    I'm an AVR enthusiast looking for something different. I'm glad to have found this site. I come by way of IRC.
×
×
  • Create New...