Jump to content
43oh

EnergiaAtStellarisiti

Members
  • Content Count

    25
  • Joined

  • Last visited

About EnergiaAtStellarisiti

  • Rank
    Member
  1. Hello, I am trying to Interface my temperature sensor MLX90620(16*4 IR array) with TIVA microcontroller(tm4c123gxl).The Serial communication used here is i2c(just the wire library) and the platform used is Energia.The first part of the process is to obtain the EEPROM values,which has been completed successfully. Now I have to write the oscillator trimming value,obtained from a particular location in EEPROM(0xF7),into the register(0x93).This is the place where Iam stuck. I have written the oscillator trimming value according to the protocol,but when I read the lo
  2. hello all, Using energia with the tiva c launchpad and the included ethernetudp library, polling read doesn't seem to react to any broadcast packets (sent to 192.168.1.255 in my setup). Likewise sending packets to that address with udp.write doesn't get detected with my pc. Trying to dig though the energia source code to confirm if it's setup to allow send and receive of broadcasts. Anyone know? Best Sol View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  3. <p>Hello,</p> <p> </p> <p>For a certain experiment I need to do, I need to generate some pulses, as fast as possible.</p> <p> </p> <p>For beginning I need a square wave, basically, so I wrote the following code: (which does not work, according to my scope)</p> <p> </p> <div>#include <Energia.h></div> <div>#include "inc/lm4f120h5qr.h"</div> <div>#include "driverlib/gpio.h"</div> <div> </div> <div>void setup() {</div> <div> GPIOPadConfigSet(G
  4. Hi community, I have a problem using the LCD_5110 Display library with my CC3200 Launchpad. The Compiler does not throw any error but the main Example sketch is not working. The Display just stay white like dead. I double checked the pin configuration but I con not find the problem. With the example Sketch: https://github.com/sparkfun/GraphicLCD_Nokia_5110/blob/master/Firmware/Nokia_5110_Arduino_Example/Nokia_5110_Arduino_Example.ino everything works fine but with the same pin configuration and wiring the example sketch https://github.com/energia/Energia/blob/master/examples/7.Display/LC
  5. The best example of Stellaris as a tool is as a logic analyzer see here.. http://www.sodnpoo.com/posts.xml/variable_sample_rate_stellaris_logic_analyser.xml Currently I am working with the ESP8266 modules and I wanted to see what was being transmitted and received over the serial interface without cluttering my code with debug. Stellaris is perfect. View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  6. <p>Can i use Energia Libraries in Keil uVision5.</p> <p> </p> <p>I want to use 430Boosterpack with TM4C123G Launchpad.</p> <p> </p> <p>Energia has built in libraries for 430Boosterpack & SPI. Can i use these libraries with Keil?????</p> View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  7. Hello, fellow launchpad enthusiasts! I am having problems reading temperature sensor values on my stellaris launchpad (LM4F120H5QR). The values returned by analogRead(TEMPSENSOR) are erratic and do not correlate with actual temperature. I use ubuntu 14.04 and energia 0101E0014. I tried following code: While runnning this code and putting my finger on MCU this code gives: View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  8. Hi guys, does someone know of a way to implement "lost signal" on the reciever side with Spirilis's ENRF24 library? I tried using rfSignalDetected() it seems to always evaluate to true. Because the while(!radio.available()) always just sits waiting until the data is ready I can't seem to think of a way to check if I stopped recieving data. Something like: Thanks View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  9. Hi, cc3200 firmware So i created ap network and i am able to connect to it. Now i wanted to destroy this ap mode and want to connect to some other network. when i try dissconnect() and then scannetworks() it returns zero available networks. how can i do this. and is there software RESET for Wi-Fi module Thanks View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  10. Hello guys, Im trying to establish a I2C conection between my stellaris and SRF08 sensor. Which I2C ports pins on the stellaris pad do you think ,would be the most suitable ?(as there are about 3-4 pairs of I2C ports on the stellaris launchpad) And as im Using energia to compile , can someone give me a good code to establish I2C between them and obtain good results ? It would be very helpful and kind if someone could help me out . Thank you in advance. View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear
  11. My program is not functioning as desired, and the Energia environment doesn't have debug tools. So I am trying to use Energia on the CCS. The TI Resource Explorer locate Energia examples, but only for the C2000 hardware. I try to re-escan but not hapens. Any information will be helpfull. Thanks View the full article on Stellarisiti. 43oh pulls Stellarisiti Energia posts, so that members do not miss out questions. Please bear with this arrangement for now. Thanks!
  12. <p>Hi folks</p> <p> </p> <p>I started to use CC3200 in the ENERGIA environment.</p> <p>I was using the examples from the Book "Arduino projects to save the world"</p> <p> </p> <p>I tested the code on an Arduino UNO board, and is OK.</p> <p> </p> <p>But in the CC3200, only one Analog channel is printed correctly, in the getADC() function, I can comment any two // ADC1 = analogRead(A1); statement and the third will print correctly</p> <p> </p> <p> </p> <p>I am
  13. I can't get Ethernet and Serial5 to work at the same time. If I run the ethernet the programs hangs when I write to serial5. Anyone seen this before? If I comment out ethernet.begin etc... the program runs fine. If I run as is the programs hangs at the first println to serial5. If I comment out any println's to serial5 the program runs fine. What could be the problem with ethernet and writing to serial port? #include <Ethernet.h> #include <EthernetClient.h> #include <EthernetServer.h> #include <EthernetUdp.h> #include <Ethernet.h> byte mac[] = {0x00, 0x1
  14. Hello, I have a question regarding communication between my Tiva C EK-TM4C123GXL lauchpad and a generic SD Card breakout board. Using: Energia 0101E0013 Windows 8.1 SD Library (SD_TM4C) 4 GB FujiFilm SD card I CAN get the ReadWrite demo program in the SD library to work sucessfully by wiring everything up according to the 1-page pinout diagram that came with my board for the SPI bus. Hardware wiring (SD breakout --> Launchpad): SDCS --> J2.9 / PA3 / 12 MOSI --> J2.6 / PB7 / 15 SCK --> J1.7 / PB4 / 7 MISO --> J2.7 / PB6 / 14 And th
  15. I have found the Energia pin map pdf's are difficult to match with the (several) pin numbering systems so I created an Excel spreadsheet to combine all of these. It's in a spreadsheet so you can sort on any column. This makes it much easier to find the pins and their functions. The pin functional groups are color coded. Two sample images of the tables are included, one based on the Boosterpack pins (booster_pack), and the second on the breadboard pins (breadboard). Numbering lists include physical pins X6-X9, boosterpack pins A1- D2, GPIO pins PA-PQ, and digital pin-to-port numbers 1-95
×
×
  • Create New...