Jump to content
43oh

reme

Members
  • Content Count

    6
  • Joined

  • Last visited

About reme

  • Rank
    Noob Class

Profile Information

  • Gender
    Not Telling
  1. this also didnt work. but thanks for the help! i guess i need to learn to read schematics myself. otherwise i will not be able to do, even the basic button thing. thank you!
  2. tried, but did not work. i will post an image because i also dont know why p2.4 led is almost on..what is happenning in there, maybe it gives you an idea? switch is connected o p2? well i dont know actually. my lack of knowledge in electronics..i really appriciate the help.
  3. now my code looks like this.but still button is not working. half of the leds are on whether i press or not.. why is that? did i got you wrong? P2REN |= 0x01; P2OUT |= 0x01; P1DIR = 0xFF; P1OUT = 0x00; while(1){ if(P2IN & 0x01){ P1OUT = 0xFF; gecikme(); } else{ P1OUT = 0xF0; gecikme(); } } return 0; }
  4. i did not use an interrupt in this particular code. i just wanted to make sure that my buttons are working. i wrote exactly the same statements, in a different way, but does he same job. problem should not be related to those 3 lines.
  5. i have msp430g2231 development kit. i wanted to do something with leds and buttons. my leds works fine. but somehow buttons are not. i have limited knowledge in electronics so i could not figure out whether this is because of my code, or i need to do some arrangements in the kit itself, like something related to jumpers.. this is the code that i tried to run. it works when i wrote while(1). but it could not get response from the button. while(P2IN & 0X01) does not seem to work. what is wrong with this? #include "io430.h" void gecikme(void); int main( void ) { // Watc
×
×
  • Create New...