Jump to content
43oh

ofer

Members
  • Content Count

    27
  • Joined

  • Last visited

Everything posted by ofer

  1. HI @spirili, i have to routers in my lan that can provide DHCP, maybe that's causing the problems? Thanks, Ofer.
  2. Ahhh... yeah I use CCS with TI's proprietary compiler
  3. hi @@spirilis, when i use the debug i only use the basic example code.
  4. The DHCP server keeps on changing every reset: DHCP lease information: 54550 seconds, DHCPserver = 106.227.230.24 DHCP lease information: 54550 seconds, DHCPserver = 3.0.8.0 DHCP lease information: 54550 seconds, DHCPserver = 34.123.255.91
  5. thanks @@spirilis, I got the debug working: Beginning: Waiting for PHY: PHY up dhcp_loop_configure(): Sending DHCPDISCOVER dhcp_send_packet(): Our MAC = 00:08:DC:04:03:00 dhcp_loop_configure(): Waiting for DHCPOFFER dhcp_loop_configure(): Packet received dhcp_loop_configure(): SrcPort = 67, PktLen = 548, RXrecv = 556 dhcp_r
  6. Hi @@spirilis, First I want to say that your DHCP lib is awesome! But some times it doesn't work and i dont know why, plus i had to loose all the wiznet_debug stuff couse this did not work for me (most likely i don't know how to use it) Other then that i did'nt change a thing in your code and my own code starts after i get the IP address. Do you have any idea why this happens? P.S. i see that i get an IP address in the Router but after a second it disappear. Thanks a lot, Ofer.
  7. ofer

    VCC OUT

    @@SixSixSevenSeven method worked but is there a better way to do this? maybe a buffer or a CMOS transistor? Thanks, Ofer.
  8. ofer

    VCC OUT

    Thanks to all ill try and post back.
  9. ofer

    VCC OUT

    hi @@roadrunner84, I tried using the enable pin but i see that it only stops the conversion from 3.3 to 5 volts so the output to the load is 3.3 volts. maybe im using it wrong, do you know of a way to connect it so the enable pin would shut down the output voltage? thanks, Ofer.
  10. ofer

    VCC OUT

    thanks @@SixSixSevenSeven i will try it, although i would have prefer a software based solution.
  11. ofer

    VCC OUT

    Hi all, I have an msp-exp430g2, my power supply is from USB and i have another unit (LMR61428) that convert 3.3 volt to 5 volt. I need this conversion unit to work only when I need. if i connect it to the VCC pin, it works all the time. Ive tried to connect it to an I/O pin that I can program to be on and off but the current output from the I/O pins is to low. Is there anyway to program the VCC pins on and off? or to increase the current output of the I/O ports? P.S. i tried to build an electronic switch with a bi-poler transistor but i couldnt make it work Thanks, Ofe
  12. hi biza, define an Array: samples[3] and then : ADC10CTL0 &= ~ENC; while (ADC10CTL1 & BUSY); ADC10SA = (unsigned int)samples; ADC10CTL0 |= ENC + ADC10SC; // ENC = enable conversion, ADC10SC = Sampling and conversion start __bis_SR_register(CPUOFF + GIE); // LPM0, ADC10_ISR will force exit In the interrupt: #pragma vector=ADC10_VECTOR __interrupt void ADC10_ISR(void) { __bic_SR_register_on_exit(CPUOFF); // Clear CPUOFF bit from 0(SR) } and just read the values of samples[0..3] Hope this helps.
  13. Hi @@RobG Is their a way to add DHCP to the project? I read in one of your posts that the MSP430G2553 does't have enough memory, is their a way around it? Thanks for all your help, Ofer.
  14. thanks Rob, i tried to do this but my program gets stuck on: while (readFromRegister(Sn_CR)); in the functuon: void connect(u_char s, u_char * addr, u_int port) i think its because when i tried to mix both W5500 and W5200 files i get Sn_XX duplicates.. i tried to override some and change some but i guess im not doing it right. can you give me a direction? thanks, Ofer.
  15. I used the code you sent me and some code from "w5200-0716.zip" and i was able to create a server but i couldn't understand how to run it as a client and handle the responses. my goal is to have a client that communicate with a server via TCP. any help would be great. thanks a lot, Ofer.
  16. hi, i got RobG's Ethernet Boosterpack v3 a few days ago and i cant get it to work. does anyone have a working code for it? thanks, Ofer.
  17. hi, i used this: http://e2e.ti.com/cfs-file.ashx/__key/communityserver-discussions-components-files/156/3146.cc110L_5F00_easy_5F00_link_5F00_msp_5F00_exp430g2.zip I created a new CSS project and added all the files from "source" dir, you will have an RX file and TX file so you can use them separately or combine them. good luck.
  18. hi, I have MSP430G2553 and im using RF boosterpack on SPI B, is there a way to use SPI A and not SPI B for the Ethernet Booster Pack? thanks. Ofer.
  19. hi, I have MSP430G2553 and im using RF boosterpack on SPI B, is there a way to use SPI A and not SPI B for the Ethernet Booster Pack? thanks. Ofer.
  20. thanks Yosh, I have tried it but im using CCS it seems that hi used Energia for his code to convert it to MSP430 from Arduino and i dont really know how to work around all the errors i get when i open it in CCS.
×
×
  • Create New...