Jump to content
43oh

jetjaguar

Members
  • Content Count

    10
  • Joined

  • Last visited

Everything posted by jetjaguar

  1. Thank you both very much, it works now! I was able to replicate what grahamf72 suggested and the robot can now sing. I really appreciate all the help you both gave me, I believe I understand most of your explanations. Once it is done I'll post it somewhere on this forum.
  2. Thank you for that great in depth explanation grahamf72! Whether I alter tone.cpp the way you suggest, or the way roadrunner84 suggests, or incorporating both of your changes into the file, I still get the same error as if I hadn't changed it at all. I've also tried compiling with and without the servo.cpp mod and the error is still the same. here is my servo.cpp: http://pastebin.com/vspia1et here is my tone.cpp: http://pastebin.com/VdtQV4f4 This is the sketch I am compiling (Servo.h & pitches.h are tabs in the sketch): #define SERVO_TIMER 1 #define TONE_TIMER 1 #includ
  3. I installed Energia in a new location because I've monkeyed with my libraries so much that I don't trust them. After doing that I replaced tone.cpp with your code from post #2. Then I replaced some of the code as instructed from your post #5. Then I replaced my servo.cpp code with yours and made sure sure to add #define SERVO_TIMER 1 to the top of the sketch. Here are the new errors: C:\TiLaunchpad_startfresh\energia-0101E0011\hardware\msp430\cores\msp430\Tone.cpp, -o, C:\Users\VisLab\AppData\Local\Temp\build312496893865346441.tmp\Tone.cpp.o] C:\TiLaunchpad_startfresh\energia-0101E00
  4. Maybe I should spell out exactly what I did: I replaced my tone.cpp code with yours. Next, I added #define TONE_TIMER 1 to the top of my sketch (the same one from my opening post). That is all.
  5. Thank you so much roadrunner84! Unfortunately I get new errors now. After I got them I noticed that you reference, but I did not have, "pins_energia.h", so I added that from here https://github.com/energia/Energia/blob/master/hardware/msp430/variants/launchpad/pins_energia.h . However I still receive errors: C:\TiLaunchpad\energia-0101E0011-windows\energia-0101E0011\hardware\msp430\cores\msp430\Tone.cpp:90:26: error: 'AVAILABLE_TONE_PINS' was not declared in this scope C:\TiLaunchpad\energia-0101E0011-windows\energia-0101E0011\hardware\msp430\cores\msp430\Tone.cpp:90:63: error: 'SETARRAY' w
  6. Hello everyone, I'm trying to add some sound to my robot. The Energia example sketch "toneMelody" compiles without error unless you also include the library Servo.h. I have read that Arduinos have the same problem, it is because both libraries call upon the same timer. Is it possible to change the code for one of the libraries so that it uses a different timer, if one exists, so that the libraries do not conflict? I'm still a novice at all of this so any help would be much appreciated, thank you. I am using the m430g2553 chip on the Ti Launchpad MSP430 rev.1.5 board. Energia v0101e0011
  7. I did. I tried another and it work just fine, so I must have damaged the first launchpad... Thank you everyone!
  8. No USB hubs. Only one Launchpad plugged in, no other boards. Device manager only shows "MSP430 Application UART" under COM ports. No mention of "virtual" or FET. However, I do remember seeing FET430UIF in the device manager of my other computer (#1), which is at work. I took off all of the jumpers and put them back. No change. 3.53v is going to the VCC pin.
  9. Thank you both for your quick responses! The board came with the chip on it, I have not removed it. Yes, I used Energia's drivers for comp 2. I switched out the chip with the 2452, changed the board in the program, uploaded blink, but got the same error=4 message. Maybe I did somehow damage something. I'll be able to try another launchpad on Monday...
  10. Hello everyone! I'd like some help getting my new ti Launchpad working with Energia... part: MSP430G2, chip M430G2553 All I've done to it so far is replace the pins with female headers. Now I'm trying to upload the example blink code and all I ever get is this: Binary sketch size: 677 bytes (of a 16,384 byte maximum) tilib: MSP430_OpenDevice: Could not find device (or device not supported) (error = 4) tilib: device initialization failed On computer #1 (win7, 64bit) I first installed CCS, then Energia. When I plug in the launchpad the green and red lights blink. When I try to uplo
×
×
  • Create New...