Jump to content
43oh

starkrobotics

Members
  • Content Count

    10
  • Joined

  • Last visited

Everything posted by starkrobotics

  1. Yeah I should have realized the I2C expander was only sending 4 data bits to the LCD. Switching to 4 bit mode fixes things
  2. Hi, I've been playing around with the I2C mode of a Bus Pirate trying to control an LCD (pretty sure it's an HD44780) in I2C mode. My LCD has a PCF8574 backpack on it, and its address is 0x7E. I'm running into something weird at the end of initalization. I'm using minicom to communicate over USB to the Bus Pirate (running on a Linux OS). I put my Bus Pirate into I2C mode, and turn on the power and internal pullup resistors - and I've used all 3 speeds (5, 50 and 100 kHz) to replicate the behaviour. This is the startup sequence I am using (note, the bar at the beginning there is in
  3. Adding the 'all' target did the trick. Thanks!
  4. I've been learning to program/debug via command prompt instructions and I'm now trying to set up a project structure where my source files are included in a /lib directory, and I dump my object files into an /obj directory. I've modified my makefile to reflect this, however after doing a couple test runs ('make -n'), the only command that gets executed is the first one in the file (cmd to build make.o). However if I type out the commands manually I can successfully generate an .elf file which is uploaded to my Launchpad. Could somebody please take a look at my makefile? For reference, I'
  5. Aaaaand there goes my self-restraint. Ah well, I was in the market for a new board anyways
  6. Hmm yeah. I went back and re-ran my script with double-quotes, worked just fine. It's possible I had the syntax wrong in something else...
  7. Thanks! For whatever reason I've never tried using only single quotemarks, and I could download/run the program if I entered that line right into the cmd prompt. But I could never get the "prog main.elf" line to work in any of my scripts. Cripes, syntax is a pain....
  8. I ended up installing a Lubuntu partition on my laptop and decided that I'd like to figure out how to program my MSP430. After trying for some time to get Eclipse working, I decided that it would probably be simpler (and slightly more tech-savvy) to do everything via Makefiles and the command prompt. Anybody else here doing the same thing?
  9. Been toying around with the MSP430 Launchpad on-and-off for about a year now, figured it would be cool to join the forums here.
×
×
  • Create New...