Jump to content
43oh

vinodstanur

Members
  • Content Count

    26
  • Joined

  • Last visited

About vinodstanur

  • Rank
    Member

Contact Methods

  • Website URL
    http://blog.vinu.co.in

Profile Information

  • Location
    India
  • Github
    http://github.com/vinodstanur
  1. Hi, I am a terminal user (vim), recently tried the eclipse IDE for stellaris launchpad, and it seems to be interesting because it was automatically highlighting the functions, I can move mouse over the function to navigate inside the function and many more... Also it was auto completing the brackets, automatically indenting the code while typing etc etc... But today when I am trying to do the same, it was not showing these features. Just I can type code thats all... Dono what happened. Can any one help me to configure it to get all the previous features?
  2. Hi, I am trying to read resistive touchscreen. But problem is, while multiplexing the pin as analog input and digital output, the digital output written previously is having an effect in the analog read. Seems to be like a residual charge accumulation or some thing like that because if I am writing 1 to pin and then making it to analog input pin then the adc read data is showing little higher value and even if I am grounding the input pin via 1k resistor, still there is an offset in the reading data which depends on the previous digital data written on the pin,..... This is making trouble in
  3. Hi Doragasu, Today I tried it again and it is working fine.... :-) Now I don't want to use the "TI's" CCS ;-)
  4. Hi, I recently downloaded stellrisware from ti and I couldn;t find a lot of stuff in the boards folder. There is no lab exercises... I dono why...
  5. Hi, here is my new mad project, a small video player which plays uncompressed video file stored in as sd card. It can play 25fps video at 320x140 resolution with audio... Color depth is 16bit/pixel. http://blog.vinu.co.in/2013/04/stellaris-launchpad-based-video-player.html It plays a special format, my own uncompressed video format, the only disadvantage is it will take more memory in sd card compared to compressed formats... Source code is open....
  6. I think in gcc even const will be copied to RAM in startup. In avr-gcc it is like that, and we need to use PROGMEM there. Any way I will try...
  7. Hi, I want to write some lookup tables in flash memory and I don't want those to be copied to RAM in startup. So how can I write it? In AVR I were using PROGMEM.
  8. Also if I am writing GPIO_PORTD_DATA_R |= 1<<0; Then the PORTB BIT 6 minimum voltage is as high as 2.3v At that time if I am writing 1 to PB6 it becomes 3.2 and if writing 0 it gives 2.3 instead of 0V.... So I am totally confused! Dont know if my launchpad is damaged or not... But I am sure that I didn't used my launchpad much and there is no chance of any shorting the gpio externally by mistake...
  9. Hi, I am having a starnge problem with stellaris launchpad.. When PORTB is enabled and if I am writing 1 to pins, it is giving 3.3V. BUT when PORTD is also activated and not connected to anywhere and if I am writing 1 to all pins of PORTB, the PORTB bits - PB6 & PB7 are not properly working, means their voltage is 2v only.... What would be the reason? Here is my two codes... ROM_SysCtlClockSet(SYSCTL_SYSDIV_2|SYSCTL_USE_PLL|SYSCTL_XTAL_16MHZ|SYSCTL_OSC_MAIN); ROM_SysCtlPeripheralEnable(SYSCTL_PERIPH_GPIOB); GPIO_PORTB_DIR_R = 255; GPIO_PORTB_DEN_R = 255; ////IF
  10. Hi, I found a tutorial here but that is not working for me. Only release mode is working but the debugging is not working. It is working in terminal with openocd but not in eclipse. I followed the exact steps as documented here (http://kernelhacks.blogspot.com.es/2012/11/the-complete-tutorial-for-stellaris_25.html). Pls comment if it works for you or not...
×
×
  • Create New...