Jump to content
43oh

Mihec

Members
  • Content Count

    17
  • Joined

  • Last visited

Everything posted by Mihec

  1. Hi, thanks for suggestion. It is true, on CC3200 launchpad default pin location for "Serial" is on FLASH jumpers TX and RX (in the middle of the board) and for "Serial1" is on P1.9 (TX) and P1.10 (RX).
  2. Hi, I tried to establish UART communication with output device and CC3200 over pinout RX(0) and TX(0). With RX(1) and TX(1) communication works fine but I use those pins for I2C connection. Is this possible? Is there any "pin change" command in Energia? Thanks for any suggestion! Miha
  3. Hi! What is your value of "CC112X_XOSC2" register?
  4. Hi, I had a similar problem with CC1120. It didn't want to go on Power Down mode when I strobe with "PWD" commannd. Try to strobe with "IDLE" command before "POWERDOWN" strobe command.
  5. If you attempt to use BLE module inside your product, you need to pay Product Listing Fee to SIG organization for using Bluetooth knowledge.
  6. Trying to connect Bluegiga BLE112 module with tablet PC.
  7. It's working:) Thank you! And happy Anniversary National:)
  8. It seems that first day of the week is Sunday! If we look at Example 4 in "Real-Time Clock Alarm Function", there say that Tuesday is "0x02". So, there is no error in two post back mentioned bug in code samples. I usually start week with Monday, so I didn't think of it:) @Level 1: I didn't know that 32k LFXT port has more than one driving options. I'll check that!
  9. Thank you all for all ideas, problem is solved for now! Problem was in software (quartz settings). In the beginning, I used that kind of code (witch is obviously wrong) to initialize 32768 quartz : // Set MCLK, SMCLK, ACLK UCSCTL4 = SELS0 | SELS1 | SELM0 | SELM1;// MCLK = SMCLK = DCO, ACLK = 32kHz // ACLK = 32768kHz P5SEL |= (XIN | XOUT); // P5.4, 5 UCSCTL6 &= ~(XT1OFF); // XT1 On UCSCTL6 |= XCAP_3; // Internal load cap do { UCSCTL7 &= ~XT1LFOFFG; // Clear XT1 fault flags }while (UCSCTL7&XT1LFOFFG);
  10. RTC time is faster that should be. I've 10 identical PCBs, and there is the same problem at all teen. So could be software? Is possible that RTC didn't work with ACLK (32768Hz), insted that RTC work with DCO or VLC? Thanks for help!
  11. Hi! I program RTC module on MSP430F5342 with code from MSP430F543xA Code Examples. ACLK (32768 quartz) run RTC. After one day running CPU in LPM3 and update RTC time to LCD every minute, I get a couple of minutes error. What could be wrong for so much big error in one day? Internal cup for XTAL is default (12.5pF). I measure quartz and it is in predicted range (32768.xx). Any suggestions or ideas?
  12. I'm interested of this! I was thinking about same sort of things coupe weeks ago. It will be great to include new MSP staff inside oldschool Lego creations. Or to new design also!
  13. I just want to say HI...after a couple years without permission of posting on forum because "SpamBOT"
×
×
  • Create New...