Jump to content

chindi

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. This scheme has only been partly successful! The F5172 program compiles and loads into the device fine but the debugger does not work well. I've had to resort back to the CCS5.4 app under the VirtualBox VM on my Linux machine to have any success here.
  2. Paul, Thanks! No real hurry now as I have worked around this issue... I acquired a MSP430FR5969 Launchpad with a newer FET emulator. I then installed CCS6 on my Linux Mint machine. Using this newer Launchpad as a SBW host to my F5172 board (same as I did with the value-line Launchpad), I am now able to run and debug my application on it via CCS6. Thanks again!
  3. Hello all! I'm new to Linux Mint 17, Eclipse and to linking toolchains and libraries. Although I have been using CCS5 under Windows XP for a few years. I've -downloaded and unpacked the package msp430-toolchain-linux-i386-2.1.tar.bz2 -downloaded unpacked and run Eclipse Luna -Installed the http://eclipse.xpg.dk/ patch into Eclipse My platform is the MSP430G series Launchpad that I'm using in the SBW mode to work with a MSP430F5172 project of mine. My problem is that I'm unable to load the program into the F5172 board. I am able to load a program into a MSP430G2553 no problem and am able to load the F5172 program when using CCS5 under Windows XP (I have a Win VM in my Linux Mint machine). When I choose the "rf2500" platform, I get the following error: Args: [/opt/msp430-toolchain-linux-i386-2.1/bin/mspdebug-wrapper, rf2500, prog /home/jim/workspace/UCS_Test/Debug/UCS_Test.elf] Waiting for mspdebug to finish MSPDebug version 0.20 - debugging tool for MSP430 MCUs Copyright © 2009-2012 Daniel Beer <dlbeer@gmail.com> This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. Trying to open interface 1 on 006 Initializing FET... FET protocol version is 30066536 Configured for Spy-Bi-Wire Set Vcc: 3000 mV Device ID: 0x3080 msg28_data: [0x1a bytes] 30 80 30 10 08 0a b2 5b 94 46 19 00 04 00 f8 fe de ee 91 04 11 00 1a 00 04 05 fet: unknown device fet: identify failed Trying again... Initializing FET... FET protocol version is 30066536 Configured for Spy-Bi-Wire Sending reset... Set Vcc: 3000 mV Device ID: 0x3080 msg28_data: [0x1a bytes] 30 80 30 10 08 0a b2 5b 94 46 19 00 04 00 f8 fe de ee 91 04 11 00 1a 00 04 05 fet: unknown device fet: identify failed So it's not recognizing the F5172 signature. If I select the "tilib" platform, I get an error window saying the file libmsp430.so file cannot be found. I have located a copy of this file but don't know which directory to put it in? ... and if this will work or not? I have read the post about the Olimex platform supporting the F5172 with a possible workaround but it involves recompiling a fet_core.c file after making changes to it but I don't know how to do that. Anyone know what I can do besides going back to CCS5 on Windows? Thanks Jim
  4. I've been having trouble with this issue for a few days since I got my new FR5969 + Sharp LCD Boosterpack. Using Linux-Mint 17 KDE. 1. Loaded the LCD_SharpBoosterPack_SPI.ino example into Energia. 2. It would not compile due to an UPPERCASE-lowercase issue with the SPI.h (spi.h) file. 3. Managed to fix that issue to get it to compile (Verify). 4. Tried to UPLOAD to the target board but got an error msg saying the FET firmware must be upgraded. 5. Clicked on "Upgrade Programmer" and all hell broke loose. It failed to upgrade with an error message number 74. Failed to initialize. 6. So now the FET firmware seemed to be in never-never land. 7.Went to a root terminal, did dmesg | tail and found the Device parameters and serial number fields were 0! 8. Installed MSP430Flasher and entered MSP430Flasher -n MSP430FR5969 -r [Output.txt,MAIN] in the root terminal window which started a successful firmware update. 9. Energia still refised to Upload saying same error, FET firmware must be upgraded. 10. I stumbled on this thread which helped tremendously. 11. I copied the libmsp430.so file from /opt/MSPFlasher/MSPFlasher_1.3.1 folder into the /opt/energia-0101E0012/hardware/tools/msp430/bin folder replacing the file that was there. 12. I am now able to Upload the compiled Sharp_LCD program to the FR5969 launchpad and the Sharp LCD displays the expected. So thanks to all in this thread! Jim
  5. A related question to post #72 ... Using the FREE version of CCS5, can the LP-SBW be used to program this F5172?
×
×
  • Create New...