Jump to content

aadeesh

Members
  • Content Count

    8
  • Joined

  • Last visited


Reputation Activity

  1. Like
    aadeesh reacted to Rickta59 in Release of MSP430Eclipse 1.0.4.1   
    Do you have actually have " instead of " in your entry? If so change all the &qout; to " and save
    then unplug and replug the launchpad usb cable.
     
    -rick
  2. Like
    aadeesh reacted to xpg in Release of MSP430Eclipse 1.0.4.1   
    Hi folks,
     
    Despite not having too much time to spend on this project, I have made a new release, which fixes a couple of bugs, and changes the way the msp430 tools are used:
     


    [*:2ct61l15]- gcc, gdb, and mspdebug are no longer distributed as an eclipse plugin, but as a separate download package. This allows the tools to be installed in a user select location, rather than trying to install into the eclipse directory.
     
    [*:2ct61l15]- MSP430 C/C++ projects can now be created.
     
    [*:2ct61l15]- The protocol (SBW, JTAG) used by MSPDebug can now be selected.
     
    In order to install the plugin, ensure that you have Eclipse Indigo, and add http://eclipse.xpg.dk as a software source in Eclipse, and install the Msp430Eclipse plugin.
    Currently, only Indigo is supported, but the plugin might work with Helios as well.
     
    If your system does not have up-to-date version of msp430-gcc, msp430-gdb, and mspdebug, you can download one of the following tool-packages:
     
    Linux 64-bit: msp430-toolchain-linux-amd64-1.0.tar.bz2
    Linux 32-bit: msp430-toolchain-linux-i386-1.0.tar.bz2
     
    Extract the package in an appropriate location ($HOME, for instance), and go to Eclipse (with the MSP430Eclipse plugin installed), and from the menu select MSP430->Tool Manager. Click the "Add..."-button, and browse to the tool-package directory. Click "close".
     
    Next, go to the Eclipse preference and select "MSP430". Here you will be able to choose if you want to use the tools from the tool-package, or supplied by the system.
     
    If you are upgrading from an older, simply upgrade the Msp430 Eclipse plugin. You can remove the toolchains installed through eclipse, and install the toolchain packages as described above.
     
    For more information see http://xpg.dk/projects/msp430/msp430-eclipse/.
     
    Feedback is very welcome.
     
    Cheers,
    Paul
×
×
  • Create New...