Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 07/21/2018 in all areas

  1. 1 point
    energia

    MSP430 Serial Monitor not working

    You might have one of those LaunchPads that comes out of the box configured to use software uart. On a Rev 1.5 LaunchPad, J3's RX and TX jumpers need to be set to the horizontal position to work with Serial. Also make sure that you match the baudrate set in the Sketch in the Serial monitor. In your test Sketch, you might want to add a small delay (e.g. delay(200)) at the end of the loop to not flood the Serial monitor. Please see the pinmap:
  2. 1 point
    >Appreciate if you can further assist me Unfortunately, my current system configuration doesn't support Energia builds at the moment. So, hopefully someone else will be able to help.
  3. 1 point
    Rei Vilo

    Arduino Library to Energia

    Read the FAQ.
  4. 1 point
    mgh

    Error during download

    I don't know that any of these ideas will help, it's just what I looked at when I tried to see what the problem might be. When you first start the Boards Manager, do you see the message "Downloading platforms index..."? It gets the small file http://www.energia.nu/pacakges/package_index.json . If you can see that, then it's talking to the package server OK. I've got a slow dial-up connection, so it sits there long enough for me to read it (and wait a little, too!). If you have a fast connection then it might blip past in an instant. It's interesting that it wants to get a 1.0.2 release, when there's a 1.0.3 release up on the site. Have you made any changes in Preferences / Network? If so, could they be blocking something?
  5. 1 point
    > What am I doing wrong? @Jacamo, really hard to say. However, looking at the code (it always help to actually post what you wrote - saves time for looking things up...), you might want to explore increasing the delay interval so the steps, if occuring, are easier to see. FWIW, looking at the schematic in the page you referenced, the resistor is 220 Ohm, not 10K. Also, another FWIW, P1.6 (pin 14) is factory connected to the green LED2 on the board. You needn't actually add an external LED. I had a spare LP with a G2553 (same pinout for the first 14 as your G2231, so same code works) available, pasted the code, added the jumper for LED 2 and ran the code; all works as promised. Do you have the jumper on the LED2? If so, that might interfere...
  6. 1 point
    Let me know if you have a problem with the above steps.
  7. 1 point
    I solved the problem by following these steps exactly: copy <energia directory>\hardware\tools\DSLite\DebugServer\drivers\MSP430.dll to <energia directory>\hardware\tools\msp430\bin\ edit <energia directory>\hardware\energia\msp430\boards.txt an change the 2 occurrences of rf2500 with tilib restart energia and you should be able to upload to the MSP-EXP430G2 with MSP430G2553. Apparently this is a known issue but there's some question about whether it's resolved using latest versions of the tool. The issue is also posted on github: https://github.com/energia/msp430-lg-core/issues/12
×