Jump to content

All Activity

This stream auto-updates     

  1. Today
  2. error message not shown

    First of all, welcome to the forum. in order for someone to help you, you will need to provide more information. Please see this link for guidance.
  3. error message not shown

    i have been trying to connect the server and client to communicate i am getting an error "Err" without any message how should i debug it ? many thanks
  4. RGB_LED_RANDOM not working

    Energia implements a sub-set of the available features. If you want to uses PWMs, you'd need to work with Code Composer Studio.
  5. RGB_LED_RANDOM not working

    Sorry, im still not getting this! I've attached the pin-outs for the eval board and also the booster pack. The eval board shows PWM assigned to the pins that map to the pins on the boostxl-edumkii RGB LED. To me, this shows that PWM should be available on the pins that map to the RGB LED. If the routine analogWrite(pin,duty) is able to provide PWM to those pins (the micro can) then all should be well.
  6. RGB_LED_RANDOM not working

    Unfortunately answer is the same. BOOSTXL-EDUMKII RGB LED uses pins 37, 38, 39 for PWM. But EK-TM4C1294XL does not provide PWM on pins 37, 38, 39 or pins 77,78,79.
  7. RGB_LED_RANDOM not working

    But those are the LED's that are on the EK-TM4C1294XL board. My query relates to the RGB LED that is on the BOOSTXL-EDUMKII board. The RGB LED is on pins 39,38,37 of the 40 pin stackable connectors. These map to header C1 on the EK-TM4C1294XL pins 2,3,4 which have PWM allocated to them. I'm not convinced the analogWrite(pin,duty) is supported on my board and im also confused as to what i pass in the pin argument - is it 39,38 or 37 or 2,3,4 depending on which pin i want the PWM on? This isn't clear. Thanks for all your help but i think im going to give up on this shortly.
  8. An extra USB for MSP430

    If the usb is really a keyboard interface you could get one of those usb to ps/2 dongles.
  9. Yesterday
  10. An extra USB for MSP430

    MSP430 can be only USB device, not host. For MSP430 USB device, there is open source TI USB dev pack with examples. http://www.ti.com/tool/MSP430USBDEVPACK
  11. An extra USB for MSP430

    Hi! It's my first time using MSP430 and I'm a little bit lost . I want to connect a barcode scanner module with the MSP430. In order to do that, I need an USB port extra. I know that Arduino has a USB Host shield, but MSP430 doesn't have any shields, does it? So, how can I do it? Is there any way to use the USB Shield of Arduino for the MSP430? Thanks!
  12. RGB_LED_RANDOM not working

    The code was for the LM4F120H5QR / TM4C123GH6PM. On the TM4C1294NCPDT, the LEDs aren't PWM. See the pins map! Select pins in violet instead on the pins map.
  13. SSD1308 I2C OLED - Stellaris driver API

    tm4c123g = new name for Stellaris.
  14. SSD1308 I2C OLED - Stellaris driver API

    hello .... will it work for tm4c123g?
  15. Anyone interested in grouping PCB fab orders?

    Thanks. There is a pattern. Account suspended until the user responds back.
  16. RGB_LED_RANDOM not working

    This still isn't working. I've taken my code and added the pinMode() into the setup routine. Still no joy. Your supplied code didn't compile giving me errors that 'BLUE_LED' was not declared in this scope. I re-wrote the code so that i could get it to compile and whilst i'm seeing the serial port information, the RGB LED isn't coming on. As i can't get the PWM to work i have to now point the finger at the underlying code behind analogWrite() for my board EK-TMC1294XL. How would i go about writing my own analogWrite() routine, i.e. writing/reading to the micro registers directly?
  17. Support for C2000 by Energia has been discontinued. Try using an earlier version of the C2000 Code Generation Tools. On macOS, release v15.3.0 works for me.
  18. May be it is noise but not external.... cuz if i use internal Pulldown resistor , I am getting the same result. But If I connect it to 3.3V ....I am getting almost constant 4095 value. I have also tried using hardware avg and dither enable. When using hardware avg it is taking avg over the noise and thus giving a value between 10 to 15. But I need 0 output when connected to GND.
  19. Hi, I am trying to run F28027F launchpad with Energia E17 and I have the errors below when I run the example file at Basics/Blink. The positions of the switches S1 are UP, DOWN, DOWN. Position of the switch S4 is UP. Jumpers for J1, J2 and J3 are in place. I installed C2000 Code Generation Tools v18.1.0.LTS on a 64-bit Windows 10 operating system. I will appreciate if someone can help. Ekrem. Error message: "...\energia-0101E0017\hardware\c2000\cores\C2000\main.cpp" line 14: warning #218-D: controlling expression is constant "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 67: error #136: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 75: error #136: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 84: error #136: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 93: error #136: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 101: error #136: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 67: error #261: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 67: error #269: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 67: error #277: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 285: error #136: namespace "std" has no member "ltoa" "...\energia-0101E0017\hardware\c2000\cores\WString.cpp" line 67: error #293: namespace "std" has no member "ltoa" Compilation failure
  20. Sounds like noise. How is the ADC input physically connected to ground? If it is a long jumper wire you may want to shorten it as much as possible. A long jumper wire will act as an antenna, picking up noise from the digital clocks on your board. Another thing you can try is placing a small capacitor right at the ADC pin to ground.
  21. Last week
  22. I cant compile codes for tm4c123g anymore. My boards suddenly disappeared from board manager. Now when I want to open it, it shows the following error: Error downloading http://www.energia.nu/packages/package_index.json java.lang.RuntimeException: java.lang.Exception: Error downloading http://www.energia.nu/packages/package_index.json at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$0(ContributionManagerUI.java:151) at java.lang.Thread.run(Unknown Source) Caused by: java.lang.Exception: Error downloading http://www.energia.nu/packages/package_index.json at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:113) at cc.arduino.contributions.packages.ContributionInstaller.download(ContributionInstaller.java:330) at cc.arduino.contributions.packages.ContributionInstaller.downloadIndexAndSignature(ContributionInstaller.java:305) at cc.arduino.contributions.packages.ContributionInstaller.updateIndex(ContributionInstaller.java:283) at cc.arduino.contributions.packages.ui.ContributionManagerUI.lambda$onUpdatePressed$0(ContributionManagerUI.java:147) ... 1 more Caused by: java.io.IOException: Received invalid http status code from server: 416 at cc.arduino.utils.network.FileDownloader.downloadFile(FileDownloader.java:194) at cc.arduino.utils.network.FileDownloader.download(FileDownloader.java:128) at cc.arduino.contributions.DownloadableContributionsDownloader.download(DownloadableContributionsDownloader.java:111) ... 5 more
  23. I am using TM4C123GXL launchpad ....MCU TM4C123GH6PM.... when I am trying to read ADC value using analogRead() it is fluctuating very much....even if I directly connect it to the GND pin it is giving random value between 0 to 50( 50*0.8mV = 40mV).
  24. measure battery voltage level

    Hi @kiMedia You cannot supply 12 V to the G2553 directly without damaging the microcontroller - see datasheet for maximum voltages. Use an external voltage divider to get to safe values. Do a search on this site for how to use internal references - eg
  25. ADC not giving 0 value when grounded

    Please have a look at What Information to Provide When Asking for Help so others can help you.
  26. When using analog read function, ADC never gives 0 value even when it is directly connected to the ground. But when I connect it to 3.3V it gives constant 4095 value. What is the problem?
  27. I would like to measure the voltage of a NiMH DC battery not exceeding 12V and I just knew that msp430g2553's ADC has an internal voltage divider. Is it appropriate to use the internal voltage divider directly without any external circuit?
  28. These processes can be quite complex and the control is very dependent on the system. Autotune doesn't always work and hand tuning is sometimes necessary. It is impossible to guess what the constants should be without knowledge of the system and possibly experimentation. Read the background material in the link I have given above for a better idea of how PID works. If I remember correctly there is a very good link to a method for hand tuning when autotune fails.
  1. Load more activity
×