Jump to content


Photo

Troubleshooting first time use & serial port reading

msp430g2553 upload

  • Please log in to reply
1 reply to this topic

#1 emat86

emat86

    Noob Class

  • Members
  • 1 posts

Posted 27 December 2016 - 09:05 AM

​Hello,

 

I am trying to upload a "Blink" program to my MSP-EXP430G2. I have no problems uploading code successfully through Code Composer Studio. But if I try to update the same code through Energia, it won't work. The error message is: 

usbutil: unable to find a device matching 0451:f432
An error occurred while uploading the sketch

I have checked that the port number and board are correctly selected.

 

Could anyone offer any help troubleshooting this?

 

I want to use Energia over CCS, mainly so I can quickly and easily get a read-out of the serial port. But if anyone knows of an easy-to-setup way to read the serial port, then I could always just upload code via CCS and be done with it!

 

Many thanks in advance for any help offered.

 

Eddie



#2 Fmilburn

Fmilburn

    Level 3

  • Members
  • 497 posts
  • LocationSeattle

Posted 27 December 2016 - 05:12 PM

Hi @emat86

Which version of Energia and what OS are you using? I suggest trying Energia V17 if you haven't already. Sometimes V18 seems to have problems with a G2 LaunchPad.

Edit: also see https://github.com/e...-error-messages

https://e2e.ti.com/s.../539487/1967376





Also tagged with one or more of these keywords: msp430g2553, upload

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users