B@tto

EasyLink CC1310 LP - Poor range ?

9 posts in this topic

Hi,

 

I received my CC1310 LPs and started to play with them. After a correction (https://github.com/energia/cc13xx-core/issues/2) it was OK and I wanted to see the maximal distance I can let between the two LPs. But I am pretty disapointed : of course I'm in a urban zone (but not dense at all, I let a LP in front of a windows and walked throught the parking in front of it) and CC1310 LP antenna are PCB type so I'm conscious that the environnement and the hardware are not optimal at all, but max range I got was ~100m. I used easylink long range mode of course. Considering that in optimal conditions, TI announced 20 km range, the gap seems heavy.

 

Is it normal ?

 

Regards

Share this post


Link to post
Share on other sites

As I understand, TX power is managed in the config. But as I had a doubt about this, I implemented setTxPwr() in energia Easylink library and set it to 12 dbm. It changed nothing

Share this post


Link to post
Share on other sites

You changed the TX power before initialization right?  (I think the txPower field has to be set before the Frequency Synthesizer is programmed... IIRC... well unless your setTxPwr implementation does a CMD_FS reprogram itself)

Share this post


Link to post
Share on other sites

For the issue reported on github. Make sure that you update to the latest CC13xx core. It should be version 3.7.0 that is installed. With version 3.6.1 I was able to reproduce it. Hence your core needs an update to 3.7.0. You can do so through the board manager.

 

For the range issue. I'll get somebody from TI RF team to look at it. Just to make sure we are all looking at the same versions. Make sure that you install the latest core (3.7.0). It would be great if you could do a quick retest with that core.

 

Also, I discovered an issue in the platform.txt. The version number is wrong. If you install 1.0.1 it will still show as 1.0.0. I will push out an update in a couple hours. This update will also fix a couple other minor issues. None of them are range related though.

Share this post


Link to post
Share on other sites

Ok so, I updated core to 3.7 and I saw that EasyLink was updated too. It's clearly better, maybe 200m with a building between LPs.

 

Notice that I check the RSSI nothing seems strange (-20 dbm distance = 1 m, ~-110 dbm distance = 200m)

Share this post


Link to post
Share on other sites

When I tested mine CC1310 I got 0.25 km and I talked to a guy Named Robert from Energia and gave me a code to make it jump to 0.30 km still bad~ and not as TI claims 20 km~ 

Share this post


Link to post
Share on other sites

Mind you the 20km (actually 30km now?) was tested at the top of two buildings in Norway with clear line-of-sight between them.... but 0.3km still sounds bad to me.  Wish I had some time to keep playing with these, as I want to follow up on a lot of this stuff.

Share this post


Link to post
Share on other sites

what did you test it with? Energia?

My customer wants over 1 Km in range..

we only changed myLink.begin () to myLink.begin(EasyLink_Phy_625bpsLrm);but still this is not goooooooooooooood

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now