Search the Community

Showing results for tags 'server'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

There are no results to display.


Found 3 results

  1. Hi , I have written a code for ethernet client using TM4c1294NCPDT launchpad and I am sending data to a server at api.pushingbox.com. The code sends data to the server after every 15 seconds, It works all the time, however sometimes suddenly the ethernet data transfer hangs, the microcontroller does not hang. Below is the void loop() I have used.Please help. void loop(){ kemasData(); //packing GET query with data Serial.println("connecting..."); if (client.connect(server, 80)) { sendData(); // koneksi = true; //connected = true u.count++; Serial.println(length); length = 0; EEPROM.write(0,u.b[0]); EEPROM.write(1,u.b[1]); Serial.println("conn serv"); } else{ Serial.println("connection failed"); } // loop while(client.connected()){ while (client.available()) { char c = client.read(); //save http header to c Serial.print(c); //print http header to serial monitor } //Serial.print("-"); } if (!client.connected()) { Serial.println(); Serial.println("disconnecting."); Serial.print("Count :"); Serial.println(u.count); //print sent value to serial monitor client.stop(); Serial.println("Client Stopped"); // koneksi = false; Serial.println("koneksi = false"); data = ""; //data reset } delay(15000); // interval } When I check the serial port the code hangs at conn serv printed above.
  2. Buy: The 43oh Store or Rob's Tindie Store. The newest version of the Ethernet BoosterPack is based on the newest chip from WIZnet, W5500. P1.5 - SCLK P1.6 - MISO P1.7 - MOSI P2.3 - /CS P2.4 - /INT P2.5 - /RST Configuration jumpers are on the bottom, PMODE1-PMODE3, LINK LED, and ACT LED. LED jumpers control which LEDs are used, on board or socket. Available on Tindie.
  3. Hi, I have a Mac desktop app that connects to a Connected Launchpad via USB serial. I decided to try to add ethernet port connection. I got tantalizing close but no cigar! I've been stuck on this for a week now so I need help. I had no problems adding the Ethernet.h library except for something very weird trying to do a conditional import. I have been using directives to compile for either the LaunchPad or the Connected LaunchPad: #ifdef PART_TM4C1294NCPDT // Connected LaunchPad #include "Ethernet.h" #elif defined( PART_LM4F120H5QR ) // LaunchPad #endif This seems to have been working, but it doesn't work for the above code. I have to comment out the #include "Ethernet.h" to compile for the EX-TM4C123GXL, but this is only a minor inconvenience. I set up a Telnet socket and was able to connect to it using the Unix Telnet program. I could connect, disconnect and reconnect, but the server does not recognize the disconnection. The client.connected() function continues to return true so I only get my sign message with the first connection. Still, I thought I was ready to go so I added NSStream to my app. It could connect and exchange a few messages before giving me a Stream Code 54: The operation couldnz6MainEthernet.ino