• Announcements

    • bluehash

      Forum Upgrade   03/11/2017

      Hello Everyone, Thanks for being patient while the forums were being fixed and upgraded. Please see details and report issues in this thread. Thanks!

Search the Community

Showing results for tags 'lm35'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • Announcements
    • Suggestions
    • New users say Hi!
  • Spotlight!
    • Sponsor Spotlight
    • Sponsor Giveaways
  • Energia
    • Energia - MSP
    • Energia - TivaC/CC3XXX
    • Energia - C2000
    • Energia Libraries
  • MSP Technical Forums
    • General
    • Compilers and IDEs
    • Development Kits
    • Programmers and Debuggers
    • Code vault
    • Projects
    • Booster Packs
    • Energia
  • Tiva-C, Hercules, CCXXXX ARM Technical Forums
    • General
    • SensorTag
    • Tiva-C, Hercules, CC3XXX Launchpad Booster Packs
    • Code Vault
    • Projects
    • Compilers and IDEs
    • Development Kits and Custom Boards
  • Beagle ARM Cortex A8 Technical Forums
    • General
    • Code Snippets and Scripts
    • Cases, Capes and Plugin Boards
    • Projects
  • General Electronics Forum
    • General Electronics
    • Other Microcontrollers
  • Connect
    • Embedded Systems/Test Equipment Deals
    • Buy, Trade and Sell
    • The 43oh Store
    • Community Projects
    • Fireside Chat
  • C2000 Technical Forums
    • General
    • Development Kits
    • Code Vault
    • Projects
    • BoosterPacks

Calendars

  • Community Calendar

Found 2 results

  1. I am interfacing LM35 and SIM900 using MSP430F5529 board . For this purpose i am using Energia software . As we all know arduino code is compatible in Energia . Hence , I have used the same code that i used in Arduino Uno . The code works fine and i get my thingspeak channel updated with every HTTP request however , when i use Energia , it doesnt show any error , neither does it show/update my thingspeak channel . I had used Pin 7 and 8 for receiving and transmitting in Arduino . In Msp430 , I have used Pin P3.4 and P3.3 for receiving and transmitting . My Energia code is as follows - #include <SoftwareSerial.h> #include <String.h> SoftwareSerial mySerial(P3_4, P3_3); boolean pin2=LOW,pin3=LOW,pin4=LOW,pin5=LOW,pin6=LOW; float temp=0.0; void setup() { mySerial.begin(9600); // the GPRS baud rate Serial.begin(9600); // the GPRS baud rate pinMode(2,INPUT); pinMode(3,INPUT); pinMode(4,INPUT); pinMode(5,INPUT); pinMode(6,INPUT); delay(1000); } void loop() { temp=analogRead(A0); temp=temp*0.4887; delay(2); Send2Pachube(); if (mySerial.available()) Serial.write(mySerial.read()); } void Send2Pachube() { mySerial.println("AT"); delay(1000); mySerial.println("AT+CPIN?"); delay(1000); mySerial.println("AT+CREG?"); delay(1000); mySerial.println("AT+CGATT?"); delay(1000); mySerial.println("AT+CIPSHUT"); delay(1000); mySerial.println("AT+CIPSTATUS"); delay(2000); mySerial.println("AT+CIPMUX=0"); delay(2000); ShowSerialData(); mySerial.println("AT+CSTT=\"aircelgprs\"");//start task and setting the APN, delay(1000); ShowSerialData(); mySerial.println("AT+CIICR");//bring up wireless connection delay(3000); ShowSerialData(); mySerial.println("AT+CIFSR");//get local IP adress delay(2000); ShowSerialData(); mySerial.println("AT+CIPSPRT=0"); delay(3000); ShowSerialData(); mySerial.println("AT+CIPSTART=\"TCP\",\"api.thingspeak.com\",\"80\"");//start up the connection delay(6000); ShowSerialData(); mySerial.println("AT+CIPSEND");//begin send data to remote server delay(4000); ShowSerialData(); String str="GET https://api.thingspeak.com/update?api_key=--------C&field1=" + String(temp); mySerial.println(str);//begin send data to remote server delay(4000); ShowSerialData(); mySerial.println((char)26);//sending delay(5000);//waitting for reply, important! the time is base on the condition of internet mySerial.println(); ShowSerialData(); mySerial.println("AT+CIPSHUT");//close the connection delay(100); ShowSerialData(); } void ShowSerialData() { while(mySerial.available()!=0) Serial.write(mySerial.read()); }
  2. Hey all, I'm relatively new to all this and I have been trying to get a temperature sensor to work with the launchpad. As in my previous posts I was trying for the DS18b20. I have the port of the code project on the back burner because there is a hell of a lot I need to learn to be able to port that over. So just to get something off the ground I have been trying to use the LM35 to read some temps. Here is the code I'm running float tempC; float tempF; void setup() { Serial.begin(9600); } void loop() { tempC = analogRead(6); //read the value from the sensor hooked up to pin 6 tempC = (3.3 * tempC * 100.0)/1024.0; //convert the analog data to temperature (Assuming 10bit ADC and 3.3v ref voltage I suspect this is where I'm screwing up) tempF = ((9.0*tempC)/5.0)+32.0; Serial.println(tempC); Serial.println(""); Serial.println(tempF); Serial.println(""); delay(1000); } The issue is that It is showing very high values. Like the order of 178 c? I also tried chaning the tempC calculation to tempC = (tempC*100.0)/1024.0 It gets closer but still not quite. (I'm monitoring through the serial monitor and I have not made any changes to the jumper position to my 1.4 board) Any and all help is appreciated. Regards, Alex