FieldsOfFire

Members
  • Content count

    8
  • Joined

  • Last visited

  1. Thanks for your reply nickds1.....great advice and this is exactly what I've done. I'm now using CCS and its various tools, gaining a better understanding of the microcontroller and its low power features. Bit of a steep learning curve but I'll get there.
  2. I'm guessing then I define the clock freq etc in the main code? This is all rather new to me but thanks for the response Robert I'll see what I can do, or tear more hair out.
  3. Thanks for the reply Robert. Yes I'm using Energia. I'll look at what you suggested but can this delay be overcome?
  4. Hi, I'm interested in energy harvesting applications with the FR5969. I've noticed there's quite a delay before the code runs, probably 500mS or more. This is just testing with a simple piece of code that turns on the LED. Launchpad supplied direct from a power supply and all jumpers removed. Is there some boot-up routine or something going on that is automatically programmed that I'm not aware of, or something else? Obviously this is quite a significant delay for these type of applications, as all the energy is being exhausted in starting the thing up. Any ideas/experiences would be great. I'm using Energia 17 and MSP430FR5969 Launchpad. Cheers.
  5. Thanks for the info LiviuM. This all gets a bit flakey for me and not what I need. I took advantage of the TI $10 CCS offer so I might go down that route.
  6. First time I've been able to use this forum for a few days as all I've been getting is an error page. I'm using the 430G2553. I had a look on data and clock pins and they were just sat high. Thought I'd try the code on an Arduino and I had data and clock activity. Sorting the I2C address out form A2h to a 7 bit address which became 51h (cheers for the reminder roadrunner84) I was able to communicate over I2C to my device :-) Out of interest I tried an MSP430FR5969 with my bit of code and that worked fine too. It would seem it there's an issue when using the 2553. I do have another 2553 which I tried and still no joy. I'm using Energia 17 by the way as 18 wouldn't work for me!
  7. #include <Wire.h> void setup() { Wire.begin(); // join i2c bus } byte val = 0xAB; byte val_1 = 0xCD; void loop() { Wire.beginTransmission(0xA2); // transmit to device 0xA2 10100010 Wire.write(byte(0x20)); // sends address hi byte Wire.write(byte(0x04)); // sends address lo byte Wire.write(val); // sends value into memory Wire.write(val_1); // sends value into memory Wire.endTransmission(); // stop transmitting } Sorry, found the paste function.
  8. Hi all, Is there a fundamental flaw(s) with the attached code. I know it isn't elegant :-). New to this and I'm trying to write the word ABCDh to address location 2004h of an RFID chip with serial EEPROM. The device address is Ah but bits b3-b1 allow for multiple devices on the same bus hence 0xA2. I'm using p1.7 = SDA and P1.6 = SCL and have the necessary pull-ups. Any help/pointers/advice appreciated whilst I still have some hair.